Loading ...
Sorry, an error occurred while loading the content.

Ending CSS block with semicolon

Expand Messages
  • cse_html_validator
    JSLint wants CSS blocks to end in semicolons, like this: #eid{color:navy} It s perfectly OK to not have a semicolon in
    Message 1 of 4 , Feb 1, 2012
    • 0 Attachment
      JSLint wants CSS blocks to end in semicolons, like this:

      <style type="text/css">
      #eid{color:navy}
      </style>

      It's perfectly OK to not have a semicolon in "{color:navy}".

      I don't see an option for this? Is there an option to stop this check?

      And if not, can such an option be added?
    • douglascrockford
      ... I recommend that you follow JSLint s advice.
      Message 2 of 4 , Feb 1, 2012
      • 0 Attachment
        --- In jslint_com@yahoogroups.com, "cse_html_validator" <alhome@...> wrote:

        > JSLint wants CSS blocks to end in semicolons, like this:
        >
        > <style type="text/css">
        > #eid{color:navy}
        > </style>
        >
        > It's perfectly OK to not have a semicolon in "{color:navy}".

        I recommend that you follow JSLint's advice.
      • Doc Emmett Splendid
        This is a difference between maintainable CSS (which should follow a very strict format) and ~minified~ CSS. Just as JSLint won t pass minified JS (which would
        Message 3 of 4 , Feb 1, 2012
        • 0 Attachment
          This is a difference between maintainable CSS (which should follow a very strict format) and ~minified~ CSS. Just as JSLint won't pass minified JS (which would also be written with a missing semicolon in the same essential location), it won't, and should not, pass minified CSS.

          -- DES


          ________________________________
          From: cse_html_validator <alhome@...>
          To: jslint_com@yahoogroups.com
          Sent: Wednesday, 1 February 2012, 11:02
          Subject: [jslint] Ending CSS block with semicolon


           

          JSLint wants CSS blocks to end in semicolons, like this:

          <style type="text/css">
          #eid{color:navy}
          </style>

          It's perfectly OK to not have a semicolon in "{color:navy}".

          I don't see an option for this? Is there an option to stop this check?

          And if not, can such an option be added?




          [Non-text portions of this message have been removed]
        • Rob Richardson
          It is less effective to lint minified or processed code as anything you discover usually can t be repaired in its current format. Also note that JSLint s CSS
          Message 4 of 4 , Feb 1, 2012
          • 0 Attachment
            It is less effective to lint minified or processed code as anything you discover usually can't be repaired in its current format. Also note that JSLint's CSS support is pretty rudimentary. Csslint.net is a similar tool for CSS.

            Rob


            -----Original Message-----
            From: jslint_com@yahoogroups.com [mailto:jslint_com@yahoogroups.com] On Behalf Of Doc Emmett Splendid
            Sent: Wednesday, February 01, 2012 2:46 PM
            To: jslint_com@yahoogroups.com
            Subject: Re: [jslint] Ending CSS block with semicolon



            This is a difference between maintainable CSS (which should follow a very strict format) and ~minified~ CSS. Just as JSLint won't pass minified JS (which would also be written with a missing semicolon in the same essential location), it won't, and should not, pass minified CSS.

            -- DES

            ________________________________
            From: cse_html_validator <alhome@... <mailto:alhome%40wiersch.com> >
            To: jslint_com@yahoogroups.com <mailto:jslint_com%40yahoogroups.com>
            Sent: Wednesday, 1 February 2012, 11:02
            Subject: [jslint] Ending CSS block with semicolon




            JSLint wants CSS blocks to end in semicolons, like this:

            <style type="text/css">
            #eid{color:navy}
            </style>

            It's perfectly OK to not have a semicolon in "{color:navy}".

            I don't see an option for this? Is there an option to stop this check?

            And if not, can such an option be added?

            [Non-text portions of this message have been removed]
          Your message has been successfully submitted and would be delivered to recipients shortly.