Loading ...
Sorry, an error occurred while loading the content.

Re: Problem with JSLint options

Expand Messages
  • Douglas Crockford
    ... That was a great bug report, and it was very helpful. Please try it now.
    Message 1 of 2 , Feb 11 7:43 AM
    • 0 Attachment
      --- In jslint_com@yahoogroups.com, "DH" <david.herren@...> wrote:
      >
      > The JSLint options have been acting weird over the past few weeks and I finally reproducible bug that appears both in IE 8.0.6001.18702 and Firefox 3.6.13 in Windows XP (though I've had other problems I can't reproduce).
      >
      > Steps:
      > - Click 'Clear All Options'
      > - Paste the following into the code textbox:
      > /*jslint browser: true, forin: true */
      > - Click the JSLint button and verify there are no errors
      > - Select the ADSafe option
      > - Click the JSLint button
      > - Verify that you see 1 ADSafe Violation
      > - Uncheck the ADSafe option
      > - Click the JSLint button
      > - Verify that a slightly different Adsafe error remains.
      > - Refresh the page.
      > - Note that the Safe Subset, Disallow Undefined Variables, and Disallow dangling _ in identifiers Options are now checked.
      >
      > Hope this helps, thanks,

      That was a great bug report, and it was very helpful. Please try it now.
    Your message has been successfully submitted and would be delivered to recipients shortly.