Loading ...
Sorry, an error occurred while loading the content.

Re: [jslint] Re: Another lint for node.js

Expand Messages
  • Harry Whitfield
    ... Code removed. ... Douglas provides a minimised version of the current JSLint at http://www.JSLint.com/jslint.js . In my Widget Tester Widget, there is an
    Message 1 of 3 , Oct 8, 2010
    • 0 Attachment
      On 6 Oct 2010, at 21:33:25, NickT wrote:

      > I'm just wondering if anyone would consider the irony (and disgrace) of using node.js to fetch the latest fulljslint.js and EVAL!!!ing it to make sure you were always using the latest version. TO wit:

      Code removed.

      > This is just an exercise, makes no allowance for node.js globals but produces the same html report as before.
      > As a courtesy, the age should be checked against a locally cached version before requesting a download but I for one have no intention of actually using this...

      Douglas provides a minimised version of the current JSLint at http://www.JSLint.com/jslint.js .

      In my Widget Tester Widget, there is an option to download and use the current version instead of the version built into the Widget. I have been using this since April 2009 without any problems. To limit the load on the server, the Widget downloads the code no more than once a day. The Widget uses the include() function call to access the JSLint code, but that is much the same as using eval().

      The latest version of the Widget Tester Widget is at http://tinyurl.com/5unocx and at

      http://widgets.yahoo.com/widgets/widget-tester/with/history .

      The Widget can be unzipped to provide access to the JavaScript code.

      Clearly, if you run downloaded code, you are putting your trust in the web site from which it was fetched.
      If you build JSLint into your own programs, you are also putting your trust in the web site from which it was obtained.

      Harry.
    Your message has been successfully submitted and would be delivered to recipients shortly.