Loading ...
Sorry, an error occurred while loading the content.
 

Re: Fleischmann Twin Centre

Expand Messages
  • alextheochari
    Thanks for the info, however special option 5 does not have an option 5 to select only 1 or 2 ... through ... after that ... LocoNet
    Message 1 of 24 , Aug 5, 2004
      Thanks for the info, however special option 5 does not have an option
      5 to select only 1 or 2

      --- In jmriusers@yahoogroups.com, "Wim Ros" <rosoft@z...> wrote:
      > Hi
      > To set the Intellibox/Twin-Center in loconet mode by default
      >
      > change the following special options.
      >
      > SO 2 in value 4
      > SO 5 in value 5
      > SO 6 in value 255
      > And set the default baudrate to 19200bps
      >
      > If you want to try if your Twin-Centre is working with the LocoNet
      through
      > RS232C, you can download this program
      > http://people.zeelandnet.nl/rosoft/PT.exe
      > It allows you to start the Twin-Center in the old way (P50x) and
      after that
      > you can change this on-fly to LocoNet mode and back to P50x mode.
      > Or you can choice to try to connect your Twin-Center directly to the
      LocoNet
      > through a LocoBuffer, or to the RS232C with the previous settings above.
      >
      > Regards
      > Wim Ros
    • Wim Ros
      ... From: alextheochari To: Sent: Thursday, August 05, 2004 4:38 PM Subject: [jmriusers] Re:
      Message 2 of 24 , Aug 5, 2004
        ----- Original Message -----
        From: "alextheochari" <alextheochari@...>
        To: <jmriusers@yahoogroups.com>
        Sent: Thursday, August 05, 2004 4:38 PM
        Subject: [jmriusers] Re: Fleischmann Twin Centre


        > Thanks for the info, however special option 5 does not have an option
        > 5 to select only 1 or 2
        >
        > --- In jmriusers@yahoogroups.com, "Wim Ros" <rosoft@z...> wrote:
        > > Hi
        > > To set the Intellibox/Twin-Center in loconet mode by default
        > >
        > > change the following special options.
        > >
        > > SO 2 in value 4
        > > SO 5 in value 5
        > > SO 6 in value 255
        > > And set the default baudrate to 19200bps


        Sorry typo

        SO 2 value 4
        SO 5 value 1
        SO 6 value 255

        Baudrate 19200

        Regards
        Wim Ros
      • alextheochari
        I have set the unit to this, however it still doesn t work, the settings I was really after was on the start up of Decoder Pro where it asks you what unit to
        Message 3 of 24 , Aug 5, 2004
          I have set the unit to this, however it still doesn't work, the
          settings I was really after was on the start up of Decoder Pro where
          it asks you what unit to pick and set the settings there, as I am
          unsure that I am selecting the correct information here.

          I have set everything as you say with the Twin Centre so that is
          correctly set but I still get nothing from the program.

          I also tried to use Railroad and Co. to make sure communication was
          possible with the unit, and it was I successfully moved the loco back
          and forth.

          Regards
          Alex Theochari


          --- In jmriusers@yahoogroups.com, "Wim Ros" <rosoft@z...> wrote:
          >
          > ----- Original Message -----
          > From: "alextheochari" <alextheochari@y...>
          > To: <jmriusers@yahoogroups.com>
          > Sent: Thursday, August 05, 2004 4:38 PM
          > Subject: [jmriusers] Re: Fleischmann Twin Centre
          >
          >
          > > Thanks for the info, however special option 5 does not have an option
          > > 5 to select only 1 or 2
          > >
          > > --- In jmriusers@yahoogroups.com, "Wim Ros" <rosoft@z...> wrote:
          > > > Hi
          > > > To set the Intellibox/Twin-Center in loconet mode by default
          > > >
          > > > change the following special options.
          > > >
          > > > SO 2 in value 4
          > > > SO 5 in value 5
          > > > SO 6 in value 255
          > > > And set the default baudrate to 19200bps
          >
          >
          > Sorry typo
          >
          > SO 2 value 4
          > SO 5 value 1
          > SO 6 value 255
          >
          > Baudrate 19200
          >
          > Regards
          > Wim Ros
        • Alex Shepherd
          ... The currently available versions of DecoderPro DO NOT have the mods I did to support the IBX Serial Port. If you want I can send you a beta version built
          Message 4 of 24 , Aug 5, 2004
            > I have set the unit to this, however it still doesn't work,
            > the settings I was really after was on the start up of
            > Decoder Pro where it asks you what unit to pick and set the
            > settings there, as I am unsure that I am selecting the
            > correct information here.

            The currently available versions of DecoderPro DO NOT have the mods I did to
            support the IBX Serial Port. If you want I can send you a beta version built
            from the current CVS archive but that could well be a bit broken around the
            bleeding edges. However the core functionality should still work ok.

            Let me know and I can email a new jmri.jar file to you.

            Cheers

            Alex
          • Wim Ros
            ... From: alextheochari To: Sent: Friday, August 06, 2004 12:01 AM Subject: [jmriusers] Re:
            Message 5 of 24 , Aug 5, 2004
              ----- Original Message -----
              From: "alextheochari" <alextheochari@...>
              To: <jmriusers@yahoogroups.com>
              Sent: Friday, August 06, 2004 12:01 AM
              Subject: [jmriusers] Re: Fleischmann Twin Centre


              > I have set the unit to this, however it still doesn't work, the
              > settings I was really after was on the start up of Decoder Pro where
              > it asks you what unit to pick and set the settings there, as I am
              > unsure that I am selecting the correct information here.
              >
              > I have set everything as you say with the Twin Centre so that is
              > correctly set but I still get nothing from the program.
              >
              > I also tried to use Railroad and Co. to make sure communication was
              > possible with the unit, and it was I successfully moved the loco back
              > and forth.
              >
              > Regards
              > Alex Theochari

              Alex,

              Do not start any other program to communicate with your Twin-Center after
              starting up. It will reset the default Loconet settings with the P50x
              setting.
              I ask you to download and try the PT program. Please do, and tell use what
              happens. This program is fully IB and TC aware, and sets all nessesary
              setting through the software. http://people.zeelandnet.nl/rosoft/PT.exe

              Regards
              Wim Ros
            • Wim Ros
              ... From: Alex Shepherd To: Sent: Friday, August 06, 2004 12:33 AM Subject: RE: [jmriusers] Re:
              Message 6 of 24 , Aug 5, 2004
                ----- Original Message -----
                From: "Alex Shepherd" <maillists@...>
                To: <jmriusers@yahoogroups.com>
                Sent: Friday, August 06, 2004 12:33 AM
                Subject: RE: [jmriusers] Re: Fleischmann Twin Centre


                > > I have set the unit to this, however it still doesn't work,
                > > the settings I was really after was on the start up of
                > > Decoder Pro where it asks you what unit to pick and set the
                > > settings there, as I am unsure that I am selecting the
                > > correct information here.
                >
                > The currently available versions of DecoderPro DO NOT have the mods I did
                to
                > support the IBX Serial Port. If you want I can send you a beta version
                built
                > from the current CVS archive but that could well be a bit broken around
                the
                > bleeding edges. However the core functionality should still work ok.
                >
                > Let me know and I can email a new jmri.jar file to you.
                >
                > Cheers
                >
                > Alex

                Alex,

                With the current file it is also possible to start the connection with the
                Intellibox and after the Update of the Twin Center it must also be possible
                to connect to a Twin-Center. The only problem is the time out message
                reading the CV's. But a connection must be possible without any trouble.

                Regards
                Wim Ros
              • Alex Shepherd
                Hi Alex, ... AFTER you try the program Wim has suggested and can verify you have the right version of firmware in your system and the comms cable is good etc,
                Message 7 of 24 , Aug 5, 2004
                  Hi Alex,

                  > Do not start any other program to communicate with your
                  > Twin-Center after starting up. It will reset the default
                  > LocoNet settings with the P50x setting. I ask you to download
                  > and try the PT program. Please do, and tell use what happens.
                  > This program is fully IB and TC aware, and sets all necessary
                  > setting through the software.
                  > http://people.zeelandnet.nl/rosoft/PT.exe
                  >
                  > Regards
                  > Wim Ros

                  AFTER you try the program Wim has suggested and can verify you have the
                  right version of firmware in your system and the comms cable is good etc,
                  you could download this beta version of JMRI the main JMRI Jar file:
                  http://www.wave.co.nz/~ashepherd/jmri.jar and give it a try.

                  You will need to rename the current jmri.jar file in the "C:\Program
                  Files\JMRI" directory and put this new one in its place.

                  Then you need to start JMRI and change the Layout connection in Preferences
                  to use the "LocoNet Intellibox Serial Port" option at 19200 and use Hardware
                  Handshaking and then exit.

                  Then setup the SO settings as per Wim's list and restart JMRI and hopefully
                  it will communicate.

                  Cheers

                  Alex
                • Bob Jacobsen
                  I m trying to figure out what options are needed for the Twin Centre and Intellibox, so that I can put them on a web page. I m not clear ... Are these needed?
                  Message 8 of 24 , Aug 6, 2004
                    I'm trying to figure out what options are needed for the Twin Centre
                    and Intellibox, so that I can put them on a web page. I'm not clear
                    about two that were mentioned early on in this thread:

                    >Special Option 25 = 1
                    >and Special Option 907 = 4

                    Are these needed?

                    Bob
                    --
                    --------------
                    Bob_Jacobsen@..., +1-510-486-7355, fax +1-510-643-8497, AIM JacobsenRG
                    Currently travelling. Emails may be greatly delayed between the time
                    I write then and you
                    get them. Phone messages won't be checked until August 9th.
                  • Bob Jacobsen
                    ... With the current version (1.4) of JMRI/DecoderPro, select: LocoBuffer (Your serial port) 19200 baud Hardware flow control DCS100 command station I don t
                    Message 9 of 24 , Aug 6, 2004
                      > > I have set the unit to this, however it still doesn't work,
                      >> the settings I was really after was on the start up of
                      >> Decoder Pro where it asks you what unit to pick and set the
                      >> settings there, as I am unsure that I am selecting the
                      >> correct information here.

                      With the current version (1.4) of JMRI/DecoderPro, select:

                      LocoBuffer
                      (Your serial port)
                      19200 baud
                      Hardware flow control
                      DCS100 command station

                      I don't know whether those will work without Alex Shepherd's
                      additions to the code, but they're the right settings if you'd like
                      to try.

                      Bob
                      --
                      --------------
                      Bob_Jacobsen@..., +1-510-486-7355, fax +1-510-643-8497, AIM JacobsenRG
                      Currently travelling. Emails may be greatly delayed between the time
                      I write then and you
                      get them. Phone messages won't be checked until August 9th.
                    • Wim Ros
                      ... From: Bob Jacobsen To: Sent: Friday, August 06, 2004 7:56 PM Subject: Re: [jmriusers] Fleischmann Twin
                      Message 10 of 24 , Aug 7, 2004
                        ----- Original Message -----
                        From: "Bob Jacobsen" <Bob_Jacobsen@...>
                        To: <jmriusers@yahoogroups.com>
                        Sent: Friday, August 06, 2004 7:56 PM
                        Subject: Re: [jmriusers] Fleischmann Twin Centre


                        > I'm trying to figure out what options are needed for the Twin Centre
                        > and Intellibox, so that I can put them on a web page. I'm not clear
                        > about two that were mentioned early on in this thread:
                        >
                        > >Special Option 25 = 1
                        > >and Special Option 907 = 4
                        >
                        > Are these needed?
                        >
                        > Bob

                        Bob,

                        They are not needed at all.

                        This are the settings
                        SO 2 in value 4
                        SO 5 in value 1
                        SO 6 in value 255
                        And set the default baudrate to 19200bps

                        And do not start any other software that puts the Intellibox or Twin-Center
                        into the P50x mixed mode.
                        If this is done the Intellibox or Twin-Center has to be resetted or put off
                        and cold boot again.

                        The current version of DecoderPro will work, to connect. Only you are unable
                        to read the Cv values. (it results in a timeout error).

                        The best way to setup the IB or TC is to handle those settings by
                        Decoderpro, see the messages on this subject with Alex.
                        After my vacation I will look and see what I can do to help you with this.

                        Regards
                        Wim Ros
                      • tinytrains2003
                        Hi there, Just wondering if anybody has actually managed to get this working with the built in serial port as its beginning to get me very frustrated. I m
                        Message 11 of 24 , May 23, 2005
                          Hi there,
                          Just wondering if anybody has actually managed to get this working
                          with the built in serial port as its beginning to get me very
                          frustrated.
                          I'm running decoder pro 1.5.6 I have updated the software on the twin
                          centre to version 1.100 have set all the special options correctly,
                          have set all the prefs in decoder pro as nessesary but when i try to
                          write the speed table to the decoder it seems to do the first 6 or 7
                          and then seems to come up with an timeout error talking to the twin
                          centre.

                          any pointers to resolve this problem will be greatly appreciatted.
                        • Peter Lloyd-Jones
                          ... Hi I use Lenz, but our clubs Ntrak modules use the Twin Centre and it all works fine. However we only meet once a month. If the owner of the Twin Center
                          Message 12 of 24 , May 23, 2005
                            --- In jmriusers@yahoogroups.com, "tinytrains2003"
                            <martin_brandon@l...> wrote:
                            > Hi there,
                            > Just wondering if anybody has actually managed to get this working
                            > with the built in serial port as its beginning to get me very
                            > frustrated.

                            Hi

                            I use Lenz, but our clubs Ntrak modules use the Twin Centre and it all
                            works fine. However we only meet once a month. If the owner of the
                            Twin Center does not respond soon (go to it Neil) I will contact him
                            and I am sure he can sort out the problem.

                            Peter
                          • Wim Ros
                            ... From: Peter Lloyd-Jones To: Sent: Tuesday, May 24, 2005 8:55 AM Subject: [jmriusers] Re:
                            Message 13 of 24 , May 24, 2005
                              ----- Original Message -----
                              From: "Peter Lloyd-Jones" <peterpeterlj@...>
                              To: <jmriusers@yahoogroups.com>
                              Sent: Tuesday, May 24, 2005 8:55 AM
                              Subject: [jmriusers] Re: Fleischmann Twin Centre


                              > --- In jmriusers@yahoogroups.com, "tinytrains2003"
                              > <martin_brandon@l...> wrote:
                              >> Hi there,
                              >> Just wondering if anybody has actually managed to get this working
                              >> with the built in serial port as its beginning to get me very
                              >> frustrated.
                              >
                              > Hi
                              >
                              > I use Lenz, but our clubs Ntrak modules use the Twin Centre and it all
                              > works fine. However we only meet once a month. If the owner of the
                              > Twin Center does not respond soon (go to it Neil) I will contact him
                              > and I am sure he can sort out the problem.
                              >
                              > Peter

                              Peter,

                              This is not a Twin-Center problem, this is a decoder, and/or DecoderPro
                              problem, this is reported several times.
                              The problem is the decoder is to slow with answering. And with the higher
                              cv's the time increase.
                              Example CV69 respons time 200 ms, CV 80 repsons time 2000 ms this is just a
                              example not the correct times.
                              I don't know what the max time out time is of DecoderPro. The respons time
                              using a Twin-Center is longer then with Lenz Digital Plus using the same
                              Decoder.
                              Don't know why there is a Time Out in DecoderPro, because if there is no
                              respons of the decoder the Digital system itselfs send a message to tell
                              there is a fault.

                              Regards
                              Wim Ros
                            Your message has been successfully submitted and would be delivered to recipients shortly.