Loading ...
Sorry, an error occurred while loading the content.

Re: some keys (e.g tilde) not working

Expand Messages
  • Dr. Detlef Groth
    Hello, just to note: I am running, UNIX OSF-1 windomanager fvwm1 with an german keyboard and I don t have any problems with the tilde with me2002december. I
    Message 1 of 8 , Jan 19, 2004
    • 0 Attachment
      Hello,

      just to note: I am running, UNIX OSF-1 windomanager fvwm1 with an
      german keyboard and I don't have any problems with the tilde with
      me2002december.
      I checked my personal emf-files for any translate-key setting which
      may achieve this but with no sucess. So no clue in the moment where
      the problems comes from.

      regards,
      Detlef


      --- In jasspa@yahoogroups.com, Jon Green <jon@j...> wrote:
      > sgermer wrote:
      > > Hi Jon,
      > >
      > > thank you for your answer. I'm currently running me (dec 2002) on red
      > > hat 7.2 using fluxbox as window manager. Got rid of the rpm package
      > > and rebuilt microemacs from the sources. When I use show-binding and
      > > enter the tilde it returns "right" forward-char. Looking in
      > > $recent-keys it shows "right".
      >
      > If you are getting "right" back ONLY then this is not good
      > and translation will be a problem unless the cursor right key
      > is producing something else.
      >
      > You are using the dec2002 release. Can I ask you to try
      > the Jan 2004 release please. This has a new version of
      > the X-Windows key handling and I'm hoping that you will
      > get something different. You will need the source and
      > the macros.
      >
      > Thanks for persisting with this problem.
      >
      > Now here's what I tried to translate in
      > > keyboard.emf and user.emf: translate-key "A-C-= A-C-~" "\x7e"
      (this is
      > > what Detlef entered to get it to work under win).
      >
      > The windows key translations are very very different
      > than UNIX so I would not expect these to look anything
      > like windows.
      >
      > It's still not
      > > working under unix. I thought maybe there is something wrong in my
      X11
      > > settings, but in other editors as xemacs and nedit it works fine.
      > > Anyway, for now I'm using the command line version to get my work
      > > done. Maybe you have another idea?
      > >
      > > Regards
      > > Stef
      >
      > Regards
      > Jon.
    • sgermer
      Hello, thanks for the info. I will check my settings and try with fvwm. Regards Stef ... on red ... package ... and ... my ... fine. ... work
      Message 2 of 8 , Jan 19, 2004
      • 0 Attachment
        Hello,

        thanks for the info. I will check my settings and try with fvwm.

        Regards
        Stef


        --- In jasspa@yahoogroups.com, "Dr. Detlef Groth" <dgroth@g...> wrote:
        > Hello,
        >
        > just to note: I am running, UNIX OSF-1 windomanager fvwm1 with an
        > german keyboard and I don't have any problems with the tilde with
        > me2002december.
        > I checked my personal emf-files for any translate-key setting which
        > may achieve this but with no sucess. So no clue in the moment where
        > the problems comes from.
        >
        > regards,
        > Detlef
        >
        >
        > --- In jasspa@yahoogroups.com, Jon Green <jon@j...> wrote:
        > > sgermer wrote:
        > > > Hi Jon,
        > > >
        > > > thank you for your answer. I'm currently running me (dec 2002)
        on red
        > > > hat 7.2 using fluxbox as window manager. Got rid of the rpm
        package
        > > > and rebuilt microemacs from the sources. When I use show-binding
        and
        > > > enter the tilde it returns "right" forward-char. Looking in
        > > > $recent-keys it shows "right".
        > >
        > > If you are getting "right" back ONLY then this is not good
        > > and translation will be a problem unless the cursor right key
        > > is producing something else.
        > >
        > > You are using the dec2002 release. Can I ask you to try
        > > the Jan 2004 release please. This has a new version of
        > > the X-Windows key handling and I'm hoping that you will
        > > get something different. You will need the source and
        > > the macros.
        > >
        > > Thanks for persisting with this problem.
        > >
        > > Now here's what I tried to translate in
        > > > keyboard.emf and user.emf: translate-key "A-C-= A-C-~" "\x7e"
        > (this is
        > > > what Detlef entered to get it to work under win).
        > >
        > > The windows key translations are very very different
        > > than UNIX so I would not expect these to look anything
        > > like windows.
        > >
        > > It's still not
        > > > working under unix. I thought maybe there is something wrong in
        my
        > X11
        > > > settings, but in other editors as xemacs and nedit it works
        fine.
        > > > Anyway, for now I'm using the command line version to get my
        work
        > > > done. Maybe you have another idea?
        > > >
        > > > Regards
        > > > Stef
        > >
        > > Regards
        > > Jon.
      Your message has been successfully submitted and would be delivered to recipients shortly.