Loading ...
Sorry, an error occurred while loading the content.

Re: [jasspa] rebind set-mark to Ctrl-space

Expand Messages
  • Jon Green
    ... C-space should be bound to set-mark by default if you are using a recent release. I ve just checked the NanoEmacs version and it is set in this as well
    Message 1 of 2 , Nov 4, 2003
    • 0 Attachment
      ajacs1 wrote:
      > Hi. i'm new to MicroEmacs, and I'm attempting to rebind my set mark
      > from "esc space" to ctrl-space to match up with the "full" emacs
      > installations I'm used to. I've tried adding this line to my me.emf file:
      >
      > global-bind-key set-mark "C-space"
      >

      C-space should be bound to set-mark by default if you are
      using a recent release. I've just checked the NanoEmacs
      version and it is set in this as well which means that
      the binding is hard coded. The syntax you have above is
      correct but you should not need to define it.
      The 02/12 release should include this binding by default.

      I assume that you are not really editing "me.emf" as
      supplied but mean <logname>.emf, i.e. your private
      profile. If you have been editing the standard
      macro files I suggest that you re-install the originals
      and start again with your private profile start-up
      file.

      Would be useful to know what platform you are on
      and what version of software you are using. The command
      "M-x about" will show the version information like:-

      MicroEmacs 03 - Date 03/10/01 - sunos

      Global Status:
      # buffers : 16
      ....

      Regards
      Jon.


      > No error is returned when I launch me, but it still doesn't work; when
      > I do ctrl-space, the message line just reports "\x00". I tried
      > changing the above line to:
      >
      > global-bind-key set-mark "\x00"
      >
      > and an error was reported on startup in the message line.
      >
      > Is there in fact any way to rebind that particular combination? Thanks.
      >
      > -Larry Miller
      >
      >
      >
      > __________________________________________________________________________
      >
      > This is an unmoderated list. JASSPA is not responsible for the content of
      > any material posted to this list.
      >
      > To unsubscribe, send a mail message to
      >
      > mailto:jasspa-unsubscribe@yahoogroups.com
      >
      > or visit http://groups.yahoo.com/group/jasspa and
      > modify your account settings manually.
      >
      >
      >
      >
      > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
      >
      >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.