Loading ...
Sorry, an error occurred while loading the content.
 

RE: [jasspa] new install question

Expand Messages
  • Phillips, Steven
    Does esc ? (or esc x help ) work? This should bring up the on-line help pages. If not is it most likely that you have not installed the on-line help, this
    Message 1 of 5 , Jun 25, 2003
      Does 'esc ?' (or 'esc x help') work? This should bring up the on-line help pages. If not is it most likely that you have not installed the on-line help, this can be verified by looking for the me.ehf file in the macros directory. You can get this file either from you other machines or from the web-site (Downloads -> me.ehf.gz or meehf.zip).

      If this does work then the most likely reason for the help page not automatically coming up is because you have created a proper user setup (i.e. you have a psventek.erf user setup file). The assumption is that a user familiar enough with ME to do this does not want the start-up of ME slowed down every time by the load of the 1.5Mb on-line help! The other reason why the on-line help my not be auto loaded is if a file name was given on the command-line (or double clicking on a file in explorer etc).

      Hope this answers your query,

      Steve

      > -----Original Message-----
      > From: psventek [mailto:psventek@...]
      > Sent: 26 June 2003 04:25
      > To: jasspa@yahoogroups.com
      > Subject: [jasspa] new install question
      >
      >
      > Just installed microemacs on my new pc. When I launch me from the
      > desktop icon, the file that is automatically loaded is my user emf
      > macro file. On all the other machines I've loaded me on, when I launch
      > me, I get the me help file (the one with the htmlized help
      > selections). I'd like to get that help file on the new machine, too.
      > Must be easy to do that, but how?
      >
      >
      > ------------------------ Yahoo! Groups Sponsor
      > ---------------------~-->
      > Looking for the latest Free IT White Papers?
      > Visit SearchMobileComputing.com to access over 500 white papers.
      > Get instant access at SearchMobileComputing.com Today
      > http://us.click.yahoo.com/LfiLPA/PLNGAA/yigFAA/89EolB/TM
      > --------------------------------------------------------------
      > -------~->
      >
      > ______________________________________________________________
      > ____________
      >
      > This is an unmoderated list. JASSPA is not responsible for
      > the content of
      > any material posted to this list.
      >
      > To unsubscribe, send a mail message to
      >
      > mailto:jasspa-unsubscribe@yahoogroups.com
      >
      > or visit http://groups.yahoo.com/group/jasspa and
      > modify your account settings manually.
      >
      >
      >
      >
      > Your use of Yahoo! Groups is subject to
      http://docs.yahoo.com/info/terms/
    • psventek
      Steven, ... on-line help pages. Yes it does, this is the window I want to come up when I d double click the me32 icon to fire up the editor. ... Yes, this
      Message 2 of 5 , Jun 26, 2003
        Steven,

        > Does 'esc ?' (or 'esc x help') work? This should bring up the
        on-line >help pages.

        Yes it does, this is the window I want to come up when I d\double
        click the me32 icon to fire up the editor.

        >If not is it most likely that you have not installed the on-line
        >help, this can be verified by looking for the me.ehf file in the
        >macros directory.

        Yes, this file exists in the macros directory.

        > If this does work then the most likely reason for the help page not
        >automatically coming up is because you have created a proper user
        >setup >(i.e. you have a psventek.erf user setup file).

        Yes, I have a "psventek.erf" file in the macros directory (but even
        when I remove it, I still get the psventek.emf file in the me32 window
        when I fire the editor up). Is there a line in the psventek.erf file I
        can put the name of the *help* file in to get this file to load first
        time?!
      • Phillips, Steven
        I need to understand the problem first, the mail below suggests that the file psventek.emf is being loaded and displayed, why? I m guessing that this is caused
        Message 3 of 5 , Jun 27, 2003
          I need to understand the problem first, the mail below suggests that the file psventek.emf is being loaded and displayed, why? I'm guessing that this is caused by either your short-cut having the emf file on the command-line (i.e. "me32 psventek.emf" instead of just "me32") or your psventek.emf file is being executed and it has an error in it (ME will then display the file and set the cursor to the point of the error). The first is most likely as having removed psventek.erf it should not be executing psventek.emf.

          If you can stop psventek.emf being automatically loaded you will either get the "*scratch*" or the "*help*" buffer displayed, if its the *scratch* buffer, you have a valid user setup and you need to add the following to your psventek.emf start-up file (taken from the top of me.emf):

          define-macro start-up
          !if &seq $buffer-bname "*scratch*"
          help
          delete-window
          !endif
          !emacro

          Steve

          > -----Original Message-----
          > From: psventek [mailto:psventek@...]
          > Sent: 27 June 2003 02:06
          > To: jasspa@yahoogroups.com
          > Subject: [jasspa] Re: new install question
          >
          >
          > Steven,
          >
          > > Does 'esc ?' (or 'esc x help') work? This should bring up the
          > on-line >help pages.
          >
          > Yes it does, this is the window I want to come up when I d\double
          > click the me32 icon to fire up the editor.
          >
          > >If not is it most likely that you have not installed the on-line
          > >help, this can be verified by looking for the me.ehf file in the
          > >macros directory.
          >
          > Yes, this file exists in the macros directory.
          >
          > > If this does work then the most likely reason for the help page not
          > >automatically coming up is because you have created a proper user
          > >setup >(i.e. you have a psventek.erf user setup file).
          >
          > Yes, I have a "psventek.erf" file in the macros directory (but even
          > when I remove it, I still get the psventek.emf file in the me32 window
          > when I fire the editor up). Is there a line in the psventek.erf file I
          > can put the name of the *help* file in to get this file to load first
          > time?!
          >
          >
          > ------------------------ Yahoo! Groups Sponsor
          > ---------------------~-->
          > Looking for the latest Free IT White Papers?
          > Visit SearchNetworking.com to access over 500 white papers.
          > Get instant access at SearchNetworking.com Today
          > http://us.click.yahoo.com/KfiLPA/OLNGAA/yigFAA/89EolB/TM
          > --------------------------------------------------------------
          > -------~->
          >
          > ______________________________________________________________
          > ____________
          >
          > This is an unmoderated list. JASSPA is not responsible for
          > the content of
          > any material posted to this list.
          >
          > To unsubscribe, send a mail message to
          >
          > mailto:jasspa-unsubscribe@yahoogroups.com
          >
          > or visit http://groups.yahoo.com/group/jasspa and
          > modify your account settings manually.
          >
          >
          >
          >
          > Your use of Yahoo! Groups is subject to
          http://docs.yahoo.com/info/terms/
        • psventek
          Steven, ... the file psventek.emf is being loaded and displayed, why? ... When I look into the properties window of the me32 icon on my desktop, it says:
          Message 4 of 5 , Jun 27, 2003
            Steven,

            > I need to understand the problem first, the mail below suggests that
            the file psventek.emf is being loaded and displayed, why?
            >
            > If you can stop psventek.emf being automatically loaded...

            When I look into the properties window of the me32 icon on my desktop,
            it says:

            Target: "C\Program Files\JASSPA\MicroEmacs\me32.exe" -c

            On a lark, I removed the -c tag.

            When I click on the me32 icon now, MicroEmacs behaves properly; I get
            the help window.
          Your message has been successfully submitted and would be delivered to recipients shortly.