Loading ...
Sorry, an error occurred while loading the content.
 

Re: [jasspa] xml -- Don't see as open tag:

Expand Messages
  • Jon Green
    Thanks Tom, Picked up your changed and will drop it into the next release. Hopefully will be pushing out some source (not binaries) tonight. Jon.
    Message 1 of 2 , Dec 5 11:34 AM
      Thanks Tom,

      Picked up your changed and will drop it into the next
      release. Hopefully will be pushing out some source
      (not binaries) tonight.
      Jon.

      Thomas Hundt wrote:
      >
      > This line which appears at the beginning of many XML files causes ME
      > to indent whatever follows, as if it were an "opening" tag. (It's a
      > "processing instruction" line. I've only seen this one but there could
      > be more.) Trouble is, it's not an "open" tag, there is never a
      > closing tag for it, so it should not really indent:
      > <?xml version="1.0"?>
      > something-else
      > the-whole-rest-of-the-file-is-indented
      >
      > I wanted to disable this behavior, and found the solution by changing
      > this line in hkxml.emf:
      >
      > indent .hilight.xml n "<[^/!]" 2 ; line 78
      > to
      > indent .hilight.xml n "<[^/!?]" 2 ; add '?' to exclusion regexp
      >
      > And actually I put this in my myxml.emf file, in order to leave the
      > hkxml.emf in its original state:
      > ; Replace entire indentation scheme (in hkxml.emf) with mine
      > 0 indent .hilight.xml 1 20
      > indent .hilight.xml e "\"" "\"" "\\"
      > indent .hilight.xml b "<!--" "-->"
      > indent .hilight.xml n "<[^/!?]" 2 ; different!
      > indent .hilight.xml o "</" -2
      > indent .hilight.xml o "/>" -2
      >
      > -Tom Hundt
      >
      >
      > __________________________________________________________________________
      >
      > This is an unmoderated list. JASSPA is not responsible for the content of
      > any material posted to this list.
      >
      > To unsubscribe, send a mail message to
      >
      > mailto:jasspa-unsubscribe@yahoogroups.com
      >
      > or visit http://groups.yahoo.com/group/jasspa and
      > modify your account settings manually.
      >
      >
      >
      > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
    Your message has been successfully submitted and would be delivered to recipients shortly.