Loading ...
Sorry, an error occurred while loading the content.

Re: KeyBoard Problemes

Expand Messages
  • bill@jasspa.com
    François, This is more my area and I ve been on holiday for 2 weeks so sorry for the even slower response. The difficulty for us is that unless we sit at
    Message 1 of 1 , Oct 8, 2002
    • 0 Attachment
      Fran�ois,

      This is more my area and I've been on holiday for 2 weeks so sorry for the
      even slower response. The difficulty for us is that unless we sit at a French
      machine using a French keyboard (which we don't have) we cannot reproduce or
      fix the problem so we are totally reliant on submissions from users - so
      please continue to send us any fixes you have.

      The current French support is actually taken from the Belgium keyboard so its
      not totally surprising that it does not fully work. Looking at your first
      attempt to fix the problem I think you have been caught out by a nasty Windows
      problem. Logic dictates 'Press one key, get one key in $recent-keys' - NOT
      TRUE! Look at the original French section in keyboard.emf again:

      translate-key "A-C-] A-C-[" "["

      translates 2 keys into one and this is a common source of problem for foreign
      keyboards on Windows (you may be thinking 'how come I don't get these issues
      with other editors?' - the answer is simple, either they are more mature like
      Emacs or they don't support such an extensive control key re-binding (such as
      the ability to rebind Alt-space etc)).

      The best way to show this is to type the following keys in ME (with no
      translations - please comment them all out first!):

      A
      A
      [
      B
      B
      C-h v (list variables)

      Then look at the value of $recent-keys, on my machine I get:

      $recent-keys .................. "v C-h B B [ A A .....

      (Note the order of the keys is reversed!), but on a Belgium (and may be French)
      machine without any correction you will get:

      $recent-keys .................. "v C-h B B A-C-[ A-C-] A A .....

      Once you master this method of getting the key sequence it is usually pretty
      easy to get the whole keyboard mapped - BUT please remove ALL your current
      key-translations and start again as a bad translation will lead to problems
      and lots of confusion! For instance in you last email you had the following
      translation:

      translate-key "A-C-[" "]"

      with this translation consider above key sequence, $recent-keys will show:

      $recent-keys .................. "v C-h B B ] A-C-] A A .....

      As the translation happens first - get these wrong and weird things start
      happening. In your mail you state that:

      ']' -> ']'
      '[' -> '[]'

      I would therefore guess that you really need something like the following
      translations:

      translate-key "A-C-] A-C-[" "]"
      translate-key "A-C-[ [" "["

      This looks weird but does explain the behaviour. Good luck and again please
      send us any fixes you have,

      Steve


      > Subject: Re: [jasspa] KeyBoard Problemes ( Syntaxe error but everything dont work
      > )
      > From: Jon Green <jon@...>
      > Date: Wed, 02 Oct 2002 20:56:41 +0100
      > To: jasspa@yahoogroups.com
      >
      > Fran�ois,
      >
      > Sorry for the delay in getting back to you.
      > You do not say what platform you are running
      > on. I assume that it is Windows as you
      > have submitted this E-Mail from Microsoft
      > Outlook.
      >
      > The first question is - have you enabled
      > the French Keyboard from the user setup.
      > From the menu this is:-
      >
      > Help->User Setup->Start-Up
      >
      > Within this dialogue then you need to
      > specify that you are using a French
      > keyboard. Once this is set up then
      > this should invoke the French keyboard
      > settings in keyboard.emf. You can
      > see if this is running by adding
      > a
      >
      > 5000 ml-write "Running French Config"
      >
      > into the French keyboard setup i.e.
      >
      > ....
      > !elif &seq #l0 "Francais"
      > !if &seq $platform "win32"
      > 5000 ml-write "Running French Config"
      > ; Thanks to Meyer Jean-Francois
      > translate-key "A-C-4" "{"
      > .....
      >
      > If the print appears then you
      > are running the correct configuration.
      > If you are running with a French Keyboard
      > configuration then we need to establish
      > exactly what you are getting for the
      > key strokes. You message identifies
      > what does and does not work - but it
      > does not indicate what you are getting
      > instead. To do this then we need
      > to look at the key history as follows:-
      >
      > a) Enter the key that does not work.
      > b) C-h v for "list-variables".
      > c) Search for the variable $recent-keys
      > this shows recent key presses and
      > can be used to identify what key
      > sequence is being received.
      > d) Add a new "translate-key" sequence to
      > correct the received key sequence to the
      > required key - add to "keyboard.emf".
      > e) Restart the editor.
      >
      > If you manage to correct all of the keys
      > then please submit the changes so that
      > they can be corrected.
      >
      > Regards
      > Jon.
      >
      >
      > > GUILLET Fran�ois wrote:
      > >
      > > Hello
      > >
      > > i have lot of problemes
      > >
      > > i have edite keyboard.eml but the change dont work
      > > i join my keyboard.eml
      > >
      > > [ dont work do [ ] (5b)
      > >
      > > ` dont work (ef) make �
      > >
      > > please help me
      > > your sofware is grate like emacs is greate
      > > but configuration is hard
      > >
      > > bye
      > > Fran�ois GUILLET
      > > email : k.bastet@...
      > > web : http://k.bastet.free.fr
      > > tel : 06 08 70 69 38
      > > fix : 04 67 79 69 68
      > >
      > > __________________________________________________________________________
      > >
      > > This is an unmoderated list. JASSPA is not responsible for the content
      > > of
      > > any material posted to this list.
      > >
      > > To unsubscribe, send a mail message to
      > >
      > > mailto:jasspa-unsubscribe@yahoogroups.com
      > >
      > > or visit http://groups.yahoo.com/group/jasspa and
      > > modify your account settings manually.
      > >
      > > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
      > >
      > > Name: keyboard.zip
      > > keyboard.zip Type: Zip Compressed Data
      > > (application/x-zip-compressed)
      > > Encoding: base64
      >
      >
      > __________________________________________________________________________
      >
      > This is an unmoderated list. JASSPA is not responsible for the content of
      > any material posted to this list.
      >
      > To unsubscribe, send a mail message to
      >
      > mailto:jasspa-unsubscribe@yahoogroups.com
      >
      > or visit http://groups.yahoo.com/group/jasspa and
      > modify your account settings manually.
      >
      >
      >
      >
      > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
      >
      >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.