Loading ...
Sorry, an error occurred while loading the content.

RE: [jasspa] Re: NanoEmacs and German keyboards

Expand Messages
  • Steven Phillips
    I had a suspicion it was a Windows/Console issue - I hate this crap inconsistent operating system, it causes so much grief! Whats the betting that this only
    Message 1 of 6 , Jun 5, 2002
    • 0 Attachment
      I had a suspicion it was a Windows/Console issue - I hate this crap
      inconsistent operating system, it causes so much grief! Whats the betting that
      this only occurs on a Win98 Console... What flavour of windows are you using
      just in case we do have more problems in this area?

      You can test as follows:

      !if &band $system 1
      ; console
      !else
      ; window
      !endif

      Steve

      > -----Original Message-----
      > From: hughes_dj [mailto:hughes_dj@...]
      > Sent: 05 June 2002 15:20
      > To: jasspa@yahoogroups.com
      > Subject: [jasspa] Re: NanoEmacs and German keyboards
      >
      >
      > Ahhh ! It seems that the German keyboard stuff in the default ne.emf
      > works only with *Windows* ne.exe and not the *console* version! Is
      > there a test I can put in ne.emf to detect which version is running?
      >
      > -- David
      >
      > --- In jasspa@y..., "hughes_dj" <hughes_dj@h...> wrote:
      > > I know ne.emf is being loaded because I get the dark red modeline ;-
      > )
      > >
      > > Actually, that reminds me - although I have set MEPATH to point to
      > > where ne.exe & ne.emf resides, ne.emf does not get read unless I
      > > start ne directly from that directory. (I added MEPATH to my PATH).
      > >
      > > Anyway, I have found the problem: For some reason, I had to change
      > > Detlef Groth's stuff as follows:
      > >
      > > !if 1 ; Deutsch
      > > ; Thanks to Detlef Groth
      > > translate-key "A-{" "\x7b"
      > > translate-key "A-]" "\x5d"
      > > translate-key "A-}" "\x7d"
      > > translate-key "A-\\" "\x5c"
      > > translate-key "A-~" "\x7e"
      > > translate-key "A-\xb5" "\xb5"
      > > translate-key "A-[" "\x5b"
      > > translate-key "A-@" "\x40"
      > > translate-key "A-¨ˆ" "\xb2"
      > > translate-key "A-|" "\x7c"
      > > !endif
      > >
      > > -- David
      > >
      > > --- In jasspa@y..., Jon Green <jnaught@s...> wrote:
      > > > Make sure that the file "ne.emf" is really loading. To test
      > > > the script then load ne.emf into "ne" and then
      > > >
      > > > M-x execute-buffer
      > > >
      > > > Try the keys again they should work. To see if
      > > > the execution is taking the correct path then could
      > > > splatter a few commands in the macro file i.e.
      > > >
      > > > 1000 ml-write "Got here"
      > > >
      > > > Once executed try the keyboard again - if it now
      > > > works then the start up file is not being located.
      > > > Put the file "ne.emf" on the execution path.
      > > >
      > > > Regards
      > > > Jon.
      > > >
      > > >
      > > >
      > > > hughes_dj wrote:
      > > > >
      > > > > I have just discovered NanoEmacs - so much editor power in such
      > a
      > > > > tiny footprint - Great work!
      > > > >
      > > > > Howver, I have a major problem using ne (under Windows) with a
      > > German
      > > > > keyboard - I changed ne.emf to say "!if 1 ; Deutsch", but this
      > has
      > > > > made no difference - I still can't type characters such as "{[]}
      > > \~@|".
      > > > >
      > > > > What else do I need to know to get a German input locale for ne?
      > > > >
      > > > > -- David J Hughes
      > > > >
      > > > >
      > > > >
      > >
      > ______________________________________________________________________
      > > ____
      > > > >
      > > > > This is an unmoderated list. JASSPA is not responsible for the
      > > content of
      > > > > any material posted to this list.
      > > > >
      > > > > To unsubscribe, send a mail message to
      > > > >
      > > > > mailto:jasspa-unsubscribe@y...
      > > > >
      > > > > or visit http://groups.yahoo.com/group/jasspa and
      > > > > modify your account settings manually.
      > > > >
      > > > >
      > > > >
      > > > > Your use of Yahoo! Groups is subject to
      > > http://docs.yahoo.com/info/terms/
      >
      >
      >
      > __________________________________________________________________________
      >
      > This is an unmoderated list. JASSPA is not responsible for the content of
      > any material posted to this list.
      >
      > To unsubscribe, send a mail message to
      >
      > mailto:jasspa-unsubscribe@yahoogroups.com
      >
      > or visit http://groups.yahoo.com/group/jasspa and
      > modify your account settings manually.
      >
      >
      >
      >
      > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
      >
      >
    • hughes_dj
      I know ne.emf is being loaded because I get the dark red modeline ;-) Actually, that reminds me - although I have set MEPATH to point to where ne.exe & ne.emf
      Message 2 of 6 , Jun 5, 2002
      • 0 Attachment
        I know ne.emf is being loaded because I get the dark red modeline ;-)

        Actually, that reminds me - although I have set MEPATH to point to
        where ne.exe & ne.emf resides, ne.emf does not get read unless I
        start ne directly from that directory. (I added MEPATH to my PATH).

        Anyway, I have found the problem: For some reason, I had to change
        Detlef Groth's stuff as follows:

        !if 1 ; Deutsch
        ; Thanks to Detlef Groth
        translate-key "A-{" "\x7b"
        translate-key "A-]" "\x5d"
        translate-key "A-}" "\x7d"
        translate-key "A-\\" "\x5c"
        translate-key "A-~" "\x7e"
        translate-key "A-\xb5" "\xb5"
        translate-key "A-[" "\x5b"
        translate-key "A-@" "\x40"
        translate-key "A-¨ˆ" "\xb2"
        translate-key "A-|" "\x7c"
        !endif

        -- David

        --- In jasspa@y..., Jon Green <jnaught@s...> wrote:
        > Make sure that the file "ne.emf" is really loading. To test
        > the script then load ne.emf into "ne" and then
        >
        > M-x execute-buffer
        >
        > Try the keys again they should work. To see if
        > the execution is taking the correct path then could
        > splatter a few commands in the macro file i.e.
        >
        > 1000 ml-write "Got here"
        >
        > Once executed try the keyboard again - if it now
        > works then the start up file is not being located.
        > Put the file "ne.emf" on the execution path.
        >
        > Regards
        > Jon.
        >
        >
        >
        > hughes_dj wrote:
        > >
        > > I have just discovered NanoEmacs - so much editor power in such a
        > > tiny footprint - Great work!
        > >
        > > Howver, I have a major problem using ne (under Windows) with a
        German
        > > keyboard - I changed ne.emf to say "!if 1 ; Deutsch", but this has
        > > made no difference - I still can't type characters such as "{[]}
        \~@|".
        > >
        > > What else do I need to know to get a German input locale for ne?
        > >
        > > -- David J Hughes
        > >
        > >
        > >
        ______________________________________________________________________
        ____
        > >
        > > This is an unmoderated list. JASSPA is not responsible for the
        content of
        > > any material posted to this list.
        > >
        > > To unsubscribe, send a mail message to
        > >
        > > mailto:jasspa-unsubscribe@y...
        > >
        > > or visit http://groups.yahoo.com/group/jasspa and
        > > modify your account settings manually.
        > >
        > >
        > >
        > > Your use of Yahoo! Groups is subject to
        http://docs.yahoo.com/info/terms/
      • hughes_dj
        Ahhh ! It seems that the German keyboard stuff in the default ne.emf works only with *Windows* ne.exe and not the *console* version! Is there a test I can put
        Message 3 of 6 , Jun 5, 2002
        • 0 Attachment
          Ahhh ! It seems that the German keyboard stuff in the default ne.emf
          works only with *Windows* ne.exe and not the *console* version! Is
          there a test I can put in ne.emf to detect which version is running?

          -- David

          --- In jasspa@y..., "hughes_dj" <hughes_dj@h...> wrote:
          > I know ne.emf is being loaded because I get the dark red modeline ;-
          )
          >
          > Actually, that reminds me - although I have set MEPATH to point to
          > where ne.exe & ne.emf resides, ne.emf does not get read unless I
          > start ne directly from that directory. (I added MEPATH to my PATH).
          >
          > Anyway, I have found the problem: For some reason, I had to change
          > Detlef Groth's stuff as follows:
          >
          > !if 1 ; Deutsch
          > ; Thanks to Detlef Groth
          > translate-key "A-{" "\x7b"
          > translate-key "A-]" "\x5d"
          > translate-key "A-}" "\x7d"
          > translate-key "A-\\" "\x5c"
          > translate-key "A-~" "\x7e"
          > translate-key "A-\xb5" "\xb5"
          > translate-key "A-[" "\x5b"
          > translate-key "A-@" "\x40"
          > translate-key "A-¨ˆ" "\xb2"
          > translate-key "A-|" "\x7c"
          > !endif
          >
          > -- David
          >
          > --- In jasspa@y..., Jon Green <jnaught@s...> wrote:
          > > Make sure that the file "ne.emf" is really loading. To test
          > > the script then load ne.emf into "ne" and then
          > >
          > > M-x execute-buffer
          > >
          > > Try the keys again they should work. To see if
          > > the execution is taking the correct path then could
          > > splatter a few commands in the macro file i.e.
          > >
          > > 1000 ml-write "Got here"
          > >
          > > Once executed try the keyboard again - if it now
          > > works then the start up file is not being located.
          > > Put the file "ne.emf" on the execution path.
          > >
          > > Regards
          > > Jon.
          > >
          > >
          > >
          > > hughes_dj wrote:
          > > >
          > > > I have just discovered NanoEmacs - so much editor power in such
          a
          > > > tiny footprint - Great work!
          > > >
          > > > Howver, I have a major problem using ne (under Windows) with a
          > German
          > > > keyboard - I changed ne.emf to say "!if 1 ; Deutsch", but this
          has
          > > > made no difference - I still can't type characters such as "{[]}
          > \~@|".
          > > >
          > > > What else do I need to know to get a German input locale for ne?
          > > >
          > > > -- David J Hughes
          > > >
          > > >
          > > >
          >
          ______________________________________________________________________
          > ____
          > > >
          > > > This is an unmoderated list. JASSPA is not responsible for the
          > content of
          > > > any material posted to this list.
          > > >
          > > > To unsubscribe, send a mail message to
          > > >
          > > > mailto:jasspa-unsubscribe@y...
          > > >
          > > > or visit http://groups.yahoo.com/group/jasspa and
          > > > modify your account settings manually.
          > > >
          > > >
          > > >
          > > > Your use of Yahoo! Groups is subject to
          > http://docs.yahoo.com/info/terms/
        • Jon Green
          OK Thanks, I m now not sure what keyboard translation is correct for a German Keyboard ? Do you have a German Keyboard in Germany or operating with some other
          Message 4 of 6 , Jun 5, 2002
          • 0 Attachment
            OK Thanks,

            I'm now not sure what keyboard translation is
            correct for a German Keyboard ? Do you have a
            German Keyboard in Germany or operating with
            some other country code ?

            I would be interested in knowing if the translations
            as they were worked with Detlef's keyboard/locale
            setting.

            Locales are always difficult !

            Jon.

            hughes_dj wrote:
            >
            > I know ne.emf is being loaded because I get the dark red modeline ;-)
            >
            > Actually, that reminds me - although I have set MEPATH to point to
            > where ne.exe & ne.emf resides, ne.emf does not get read unless I
            > start ne directly from that directory. (I added MEPATH to my PATH).
            >
            > Anyway, I have found the problem: For some reason, I had to change
            > Detlef Groth's stuff as follows:
            >
            > !if 1 ; Deutsch
            > ; Thanks to Detlef Groth
            > translate-key "A-{" "\x7b"
            > translate-key "A-]" "\x5d"
            > translate-key "A-}" "\x7d"
            > translate-key "A-\\" "\x5c"
            > translate-key "A-~" "\x7e"
            > translate-key "A-\xb5" "\xb5"
            > translate-key "A-[" "\x5b"
            > translate-key "A-@" "\x40"
            > translate-key "A-¨ˆ" "\xb2"
            > translate-key "A-|" "\x7c"
            > !endif
            >
            > -- David
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.