Loading ...
Sorry, an error occurred while loading the content.

Filtering out \0xA0?

Expand Messages
  • Bob Paddock
    Every time I copy&past from a web page in to ME I get a lot of spaces with the 8th bit set. How do I change these to normal spaces or just get ride of them
    Message 1 of 5 , Mar 21, 2002
    • 0 Attachment
      Every time I copy&past from a web page in to ME I get a lot of spaces
      with the 8th bit set.

      How do I change these to normal spaces or just get ride of them completely?
    • Jon Green
      Never seen this. Can you provide some more information please. Platform ? Browser that you are using ? Does this happen on every HTML page or some HTML pages ?
      Message 2 of 5 , Mar 21, 2002
      • 0 Attachment
        Never seen this. Can you provide some more information
        please.

        Platform ?
        Browser that you are using ?
        Does this happen on every HTML
        page or some HTML pages ?
        Where is this HTML page ?

        Thanks
        Jon.

        Bob Paddock wrote:
        >
        > Every time I copy&past from a web page in to ME I get a lot of spaces
        > with the 8th bit set.
        >
        > How do I change these to normal spaces or just get ride of them completely?
      • Steven Phillips
        If you are looking for a simple way to remove all 0xa0 characters (a zero sized space - I have seen these as well) then with magic mode enabled and at the top
        Message 3 of 5 , Mar 21, 2002
        • 0 Attachment
          If you are looking for a simple way to remove all 0xa0 characters (a zero
          sized space - I have seen these as well) then with magic mode enabled and at
          the top of the buffer do:

          replace-string "\xa0" ""

          If you want to replace all chars above 0xa0 use:

          replace-string "[\xa0-\xff]" ""

          You can turn this into a simple macro as follows:

          define-macro remove-bogus-chars
          set-alpha-mark "P"
          -1 buffer-mode "view"
          1 buffer-mode "magic"
          beginning-of-buffer
          replace-string "\xa0" ""
          goto-alpha-mark "P"
          !emacro

          Steve

          > -----Original Message-----
          > From: Bob Paddock [mailto:bpaddock@...]
          > Sent: 21 March 2002 11:47
          > To: jasspa@yahoogroups.com
          > Subject: [jasspa] Filtering out \0xA0?
          >
          >
          >
          > Every time I copy&past from a web page in to ME I get a lot of spaces
          > with the 8th bit set.
          >
          > How do I change these to normal spaces or just get ride of them
          > completely?
          >
          >
          > __________________________________________________________________________
          >
          > This is an unmoderated list. JASSPA is not responsible for the content of
          > any material posted to this list.
          >
          > To unsubscribe, send a mail message to
          >
          > mailto:jasspa-unsubscribe@yahoogroups.com
          >
          > or visit http://groups.yahoo.com/group/jasspa and
          > modify your account settings manually.
          >
          >
          >
          >
          > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
          >
          >
          >
        • Bob Paddock
          ... Thank you, thats what I was looking for.
          Message 4 of 5 , Mar 21, 2002
          • 0 Attachment
            > You can turn this into a simple macro as follows:
            >
            > define-macro remove-bogus-chars

            Thank you, thats what I was looking for.
          • Bob Paddock
            ... Mandrake 8.2. ... Opera 5 mostly, but they all seem to do it. ... Since I ve not tried to copy and past from every HTML page I can t answer that one, but
            Message 5 of 5 , Mar 21, 2002
            • 0 Attachment
              On Thursday 21 March 2002 08:38 am, Jon Green wrote:
              > Never seen this. Can you provide some more information
              > please.
              >
              > Platform ?

              Mandrake 8.2.

              > Browser that you are using ?

              Opera 5 mostly, but they all seem to do it.

              > Does this happen on every HTML
              > page or some HTML pages ?
              > Where is this HTML page ?

              Since I've not tried to copy and past from every HTML page I can't answer
              that one, but the ones that I have, all have had this problem.

              This page has the problem:

              http://www.csonline.net/

              Looks like things that where made with FrontPage have the problem. What
              would you expect from Micro$oft.
            Your message has been successfully submitted and would be delivered to recipients shortly.