Loading ...
Sorry, an error occurred while loading the content.

[jasspa] Re: hkhtml overrides

Expand Messages
  • Jon Green
    ... You could turn this off globally from Help- User Setup . I assume that this works ?? ... The default mode is to kill line as well IF AND ONLY IF you are
    Message 1 of 7 , Aug 20, 1999
    • 0 Attachment
      Thomas Hundt wrote:
      >
      > To disable the auto-spell turned on in hkhtml, I added a couple of lines to myhtml.emf:
      >
      > define-macro my-fhook-html
      >
      > ; turn off auto-spell
      > set-variable :auto-spell 0
      > :auto-spell auto-spell
      >
      > !emacro

      You could turn this off globally from "Help->User Setup". I assume that
      this works ??

      >
      > For some reason the line-kill was getting screwed up, so I put this in, too:
      >
      > 1 global-mode "line" ; ^K doesn't kill newline too
      >
      > So that takes care of the funny business...
      >

      The default mode is to kill line as well IF AND ONLY IF
      you are at the start of the line. If you do not want this behaviour
      then you are correct in adding the above to your user.emf.

      This should probably be one of those global modes that is set in
      "Help->User Setup", this would fit after "Quiet"


      >
      > -Th
      >
      > ------------------------------------------------------------------------
      > <a target="egnewwin" href="http://clickhere.egroups.com/click/719">
      > <center>
      > <img width="468" height="60" border="0"
      > src="http://clickhere.egroups.com/img/000719/crib.gif"
      > alt="click here"><BR>
      > Click Here!
      > </center>
      > </a>
      >
      > __________________________________________________________________________
      >
      > This is an unmoderated list. JASSPA is not responsible for the content of
      > any material posted to this list.

      --
      ______________________________________________________________________

      Jon Green - jon@...
      ______________________________________________________________________
    • Thomas Hundt
      ... from a ... Brilliant! (Right clicking, now why didn t I think of that?!) ... Perfect! ... there is ... Yes!! Fantastic! Thanks, Jon! I knew you guys
      Message 2 of 7 , Aug 21, 1999
      • 0 Attachment
        >nice to have a list of currently-open buffers and be able to choose one
        from a
        >This is there now. Right click "Buffer ...." or from the menu
        >"File->Buffer ...."

        Brilliant! (Right clicking, now why didn't I think of that?!)

        >In each case, select the buffer with the mouse and the current
        >window is replaced with the selected buffer.

        Perfect!

        >> That said, another item on the same menu which would be nice to have
        there is
        >> a "Buffer Modes" option,

        >This is there now. Right click on the Buffer Mode Line (i.e the line
        >with the name of the buffer) and change the mode in the "Buffer Modes"

        Yes!!

        Fantastic! Thanks, Jon! I knew you guys wouldn't let me down!


        >Hmmmm. I do not see this. I think you must be running Auto Spell. You can
        turn
        >this off
        > "Help->User Setup->Start Up->Auto Spell"

        Mine is definitely set to N. In html files, first thing, "Enabling auto
        spell check" comes up. (Except after I implemented the "fix" I posted in
        the previous msg.)



        -Th
      • Thomas Hundt
        ... No. It s set to N, still comes up. After adding the above, it is gone. (Can t see why, either, it doesn t look like they re setting a global mode...
        Message 3 of 7 , Aug 21, 1999
        • 0 Attachment
          >> To disable the auto-spell turned on in hkhtml, I added a couple of lines
          to myhtml.emf:
          >>
          >> define-macro my-fhook-html
          >>
          >> ; turn off auto-spell
          >> set-variable :auto-spell 0
          >> :auto-spell auto-spell
          >>
          >> !emacro
          >
          >You could turn this off globally from "Help->User Setup". I assume that
          >this works ??

          No. It's set to N, still comes up. After adding the above, it is gone.
          (Can't see why, either, it doesn't look like they're setting a global
          mode... maybe it's that unconditional call to auto-spell-init in fhook-html??)

          >> For some reason the line-kill was getting screwed up, so I put this in,
          too:
          >> 1 global-mode "line" ; ^K doesn't kill newline too

          >The default mode is to kill line as well IF AND ONLY IF
          >you are at the start of the line. If you do not want this behaviour
          >then you are correct in adding the above to your user.emf.

          I had it in user.emf. Had to add it *again* to hkhtml.emf to get it to stop.

          I'm trying it again now, on my home machine, which doesn't have a modified
          myhtml.emf (yet), and guess what, the "kill" mode is correct for my
          settings (i.e., kills just from cursor forward). So I'm now not sure what
          caused the problem earlier, maybe somehow the mode got toggled by accident.
          I'll keep an eye on it and let you know if I figure it out.

          >This should probably be one of those global modes that is set in
          >"Help->User Setup", this would fit after "Quiet"

          Probably a good idea. I happened to have learned Emacs on GNU, way back,
          so I'm used to it this way. (But never got along well with Lisp, and so
          really like MicroEmacs.)

          -Th
        • bill@jasspa.freeserve.co.uk
          ... Okay, the bugs my fault, when I added Visual Basic support into html I screwed up the auto-spell settings - affects only html support. Heres a proper fix
          Message 4 of 7 , Aug 22, 1999
          • 0 Attachment
            > >> To disable the auto-spell turned on in hkhtml, I added a couple of lines
            > to myhtml.emf:
            > >>
            > >> define-macro my-fhook-html
            > >>
            > >> ; turn off auto-spell
            > >> set-variable :auto-spell 0
            > >> :auto-spell auto-spell
            > >>
            > >> !emacro
            > >
            > >You could turn this off globally from "Help->User Setup". I assume that
            > >this works ??
            >
            > No. It's set to N, still comes up. After adding the above, it is gone.
            > (Can't see why, either, it doesn't look like they're setting a global
            > mode... maybe it's that unconditional call to auto-spell-init in fhook-html??)

            Okay, the bugs my fault, when I added Visual Basic support into html I screwed
            up the auto-spell settings - affects only html support. Heres a proper fix for
            hkhtml.emf:

            *** C:/me/macros/hkhtml.emf.~0~ Fri Jul 16 14:35:46 1999
            --- C:/me/macros/hkhtml.emf Sun Aug 22 11:06:20 1999
            ***************
            *** 251,256 ****
            --- 251,257 ----
            1 global-bind-key html-toggle-mode "C-1"
            2 global-bind-key html-toggle-mode "C-2"
            auto-spell-init
            + set-variable :auto-spell &cond &seq $buffer-input "auto-spell-input" 1 -1
            ; comment the next line to switch indentation off
            1 html-toggle-mode
            !else
            ***************

            >
            > >> For some reason the line-kill was getting screwed up, so I put this in,
            > too:
            > >> 1 global-mode "line" ; ^K doesn't kill newline too
            >
            > >The default mode is to kill line as well IF AND ONLY IF
            > >you are at the start of the line. If you do not want this behaviour
            > >then you are correct in adding the above to your user.emf.
            >
            > I had it in user.emf. Had to add it *again* to hkhtml.emf to get it to stop.
            >
            > I'm trying it again now, on my home machine, which doesn't have a modified
            > myhtml.emf (yet), and guess what, the "kill" mode is correct for my
            > settings (i.e., kills just from cursor forward). So I'm now not sure what
            > caused the problem earlier, maybe somehow the mode got toggled by accident.
            > I'll keep an eye on it and let you know if I figure it out.

            I'm not sure what going on here, but hunting through all the macros there
            isn't a single reference to the mode. So there are two possibilities, either
            an internal ME bug or some how you managed to toggle the mode without
            realizing it. I know which I prefer to believe ;-)

            While we are on the subject of line mode, I have a suspicion that its a bit
            dangerous to use. The reason being that I wrote most of the macros with this
            mode disabled so any use of the function kill-line in a macro may have a
            different effect leading to problems. kill-line is used quite a lot so I will
            try and address this issue for the next release. In the mean time, if a macro
            doesn't work try disabling the mode.

            > >This should probably be one of those global modes that is set in
            > >"Help->User Setup", this would fit after "Quiet"
            >
            > Probably a good idea. I happened to have learned Emacs on GNU, way back,
            > so I'm used to it this way. (But never got along well with Lisp, and so
            > really like MicroEmacs.)

            I'll add this, but only when I've fixed the fore-mentioned issues.

            Steve
          Your message has been successfully submitted and would be delivered to recipients shortly.