Loading ...
Sorry, an error occurred while loading the content.

Re: [jasspa] obscure MEPATH

Expand Messages
  • dgroth@gmx.de
    Hmm, Thanks for the suggestions, I remember, that I need hours to setup my last me-installation on a NT4-machine editing the me32.ini, deleting it, writing
    Message 1 of 4 , Aug 8, 2001
    • 0 Attachment
      Hmm,

      Thanks for the suggestions,
      I remember, that I need hours to setup my last me-installation on a
      NT4-machine editing the me32.ini, deleting it, writing batch files ...

      I will now simple live with the quite comfortable:

      $search-path ..................
      "E:/Programme/JASSPA/MicroEmacs/dgroth/dgroth;E:/Programme/JASSPA/MicroEmacs/company;E:/Programme/JASSPA/MicroEmacs/spelling;E:/Programme/JASSPA/MicroEmacs/macros;;"

      and adjust my emf-file-putting instead of trying again to manipulate ME to
      use my ideas where these files should be located. The problem is also that
      this OS (win2000) has it's own ideas where to put my personal stuff .....
      (One try to edit the me32.ini were failing ...)
      we have to be flexibly ...

      will see tomorrow what is with my linux-machine ...

      regards, Detlef

      > Detlef,
      >
      > OK, this is how it works for Windows - this is a little bit different
      > from
      > UNIX because we interact with the me32.ini file. Inside
      > the
      > c:/windows(Winnt)/me32.ini you will find two paths as follows
      > (with
      > different directories):-
      >
      > mepath=c:\me\samsung;c:\me\macros;c:\me\spelling;
      > userpath=c:\me
      >
      > "mepath" is the base path on which all COMMON directories are placed,
      > so I
      > basically have company, macros, spelling searched in that order.
      >
      > The "userpath" is a seed, this is concatenated with the user's login
      > name,
      > so my login name is "jon", my "userpath" is "c:\me", hence the
      > resultant
      > userpath will be "c:\me\jon". This "userpath" does not really exist in
      > the
      > system and is used to personalise the "mepath", so the resultant
      > "mepath"
      > now becomes:-
      >
      > mepath=c:\me\jon;c:\me\samsung;c:\me\macros;c:\me\spelling;
      >
      > The "Setup Path" in the dialogue is the first path off the MEPATH
      > and is
      > used for user configuration, this allows config files in a
      > different
      > directory to be maintained - this is more for administration purposes.
      >
      > As for what you are seeing:-
      >
      > I do not know why the macros directory is not set up ??
      >
      > At a guess I would say that your userpath is set incorrectly,
      > guess
      > it is set to:-
      >
      > userpath=E:/Programme/JASSPA/MicroEmacs/dgroth
      >
      > Would expect it to be set to:-
      >
      > userpath=E:/Programme/JASSPA/MicroEmacs
      >
      > and your login name is "dgroth"
      >
      > If your login name is different, i.e. mine is "jnaught" and all my
      > config
      > files are "jon" then the me32.ini file is defined as follows:-
      >
      > [jnaught]
      > mename=jon
      > ME_ISHELL=c:\command.com
      > infopath=c:\emacs-20.3.1\info
      > msdevEnableEmacs=0
      > msdevAutoClose=0
      >
      > Note that you can override the login name using "mename", so setting
      > this
      > to "jon" modifies this for me.
      >
      > So for yourself I would expect your me32.ini file to read as follows:-
      >
      > ; Identify the location of the MicroEmacs executable so that the
      > ; Developer Studio "Add-In" can locate the executable
      > [Location]
      > exe=e:\Programme\JASSPA\MicroEmacs\me32.exe
      > [Defaults]
      >
      >
      mepath=e:/Programme/JASSPA/MicroEmacs/company;e:/Programme/JASSPA/MicroEmacs/macros;e:/Programme/JASSPA/MicroEmacs/spelling
      > userpath=e:/Programme/JASSPA/MicroEmacs
      > [dgroth]
      > ; Your special environment variables if you need any, otherwise omit.
      >
      > Your directory structure will be
      >
      > e:\
      > + Programme
      > + JASSPA
      > + MicroEmacs
      > me32.exe
      > + Macros
      > <Macro files>
      > + Spelling
      > <Spelling files>
      > + Company
      > <Your company files>
      > + dgroth
      > <Your private config files>
      >
      > Hope this makes some sense !!
      >
      > Regards
      > Jon
      >
      >
      > dgroth@... wrote:
      > >
      > > Hello,
      > >
      > > Jon and Steven, thanks a lot for the new release of the incredible
      > > editor....
      > >
      > > Hoewever I had some trouble setting the MEPATH on win2000 up
      > > the following output of the macro:
      > >
      > > define-macro insert-mepath
      > > execute-string
      > > $MEPATH
      > > !emacro
      > >
      > > is:
      > >
      >
      E:/Programme/JASSPA/MicroEmacs/dgroth/dgroth;E:/Programme/JASSPA/MicroEmacs/company;E:/Programme/JASSPA/MicroEmacs/spelling;;
      > >
      > > but this does not goes conform what I see in Help->User Setup->Start-Up
      > > there is simple:
      > >
      > > E:/Programme/JASSPA/MicroEmacs/macros
      > >
      > > and dgroth.emf is put in this directory. So my stuff I put into the
      > > dgroth/dgroth-directory and the dgroth.emf in the macro directory
      > > is simple:
      > > ; My own setup
      > > ;
      > > ; Last Modified : <010808.1116>
      > > ;
      > >
      > > execute-file "dgroth99.emf" ; my old ME-setupfile
      > >
      > > Something obscure bit I am ready to go ...
      > >
      > > This kind of configuration certainly confuses new users.
      > >
      > > Any suggestions ?
      > >
      > > regards,
      > >
      > > Detlef
      >

      --
      Dr.Detlef Groth
      Neue Scheune 5
      14548 Ferch
      Germany

      Aufgepasst - jetzt viele 1&1 New WebHosting Pakete ohne
      Einrichtungsgebuehr + 1 Monat Grundgebuehrbefreiung!
      http://puretec.de/index.html?ac=OM.PU.PU003K00736T0492a
    Your message has been successfully submitted and would be delivered to recipients shortly.