Loading ...
Sorry, an error occurred while loading the content.

RE: [jasspa] Bug while loading a latex/tex file

Expand Messages
  • Steven Phillips
    There s a mistake in the hklatex.emf macro file, I ll send a patch as soon as I ve figured out whats wrong! Steve
    Message 1 of 4 , Jul 17, 2001
    • 0 Attachment
      There's a mistake in the hklatex.emf macro file, I'll send a patch as soon
      as I've figured out whats wrong!

      Steve

      > -----Original Message-----
      > From: pmmg@... [mailto:pmmg@...]
      > Sent: Tuesday, July 17, 2001 4:04 PM
      > To: jasspa@yahoogroups.com
      > Subject: [jasspa] Bug while loading a latex/tex file
      >
      >
      > Hello!
      >
      > I've been testing this new release and while loading a LaTeX or
      > TeX, file it gives me an error "[No such command '']" and then
      > after pressing a key all comes back to normal.
      >
      > I've traced it to the buffer-initialize in hklatex.emf, but I
      > dont see any reason for this to happen. If after the error I go
      > to Buffer Setup and provoke the reinitialization of the hookfile
      > by pressing Save and Current all works Ok.
      >
      > This is not a major issue since all works OK except for the error message.
      >
      > It seems that is a bug in the setup flags that is calling a
      > function that is not found. The macro parser is not catching the
      > invalid command name so it displays ''.
      >
      > Regards
      >
      > Pedro Gomes
      >
      >
      >
      > __________________________________________________________________________
      >
      >
      >
      > This is an unmoderated list. JASSPA is not responsible for the content of
      >
      > any material posted to this list.
      >
      >
      >
      >
      > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
      >
      >
      >
    • Jon Green
      Always check your mylatex.emf . I suggest that you uncouple that first (i.e. rename the file) then start a new ME session with a latex file. If there is no
      Message 2 of 4 , Jul 17, 2001
      • 0 Attachment
        Always check your "mylatex.emf". I suggest that you uncouple
        that first (i.e. rename the file) then start a new ME
        session with a latex file. If there is no error then check
        your "mylatex.emf".

        Also make sure that you are not overriding the 'macros'
        file with your own i.e. have your own "hklatex.emf". I have
        just tried what you have reported and got an unbound error.
        I had my own copy of "hklatex.emf". I've just deleted it
        and the tex file comes up with no errors.

        In summary,

        Look for bad "myXXXX.emf" files which
        conflict with new release

        Look for your own overriding "hkXXXX.emf"
        that is used instead of the proper one.

        Any conflicts then fix.

        Regards
        Jon.


        pmmg@... wrote:
        >
        > Hello!
        >
        > I've been testing this new release and while loading a LaTeX or TeX, file it gives me an error "[No such command '']" and then after pressing a key all comes back to normal.
        >
        > I've traced it to the buffer-initialize in hklatex.emf, but I dont see any reason for this to happen. If after the error I go to Buffer Setup and provoke the reinitialization of the hookfile by pressing Save and Current all works Ok.
        >
        > This is not a major issue since all works OK except for the error message.
        >
        > It seems that is a bug in the setup flags that is calling a function that is not found. The macro parser is not catching the invalid command name so it displays ''.
        >
        > Regards
        >
        > Pedro Gomes
        >
        > __________________________________________________________________________
        >
        > This is an unmoderated list. JASSPA is not responsible for the content of
        >
        > any material posted to this list.
        >
        >
        >
        > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
      • Steven Phillips
        All, Simple fix to hklatex.emf, replace the command-flag variable definition to the one below. There have been a few minor teething problems which we are
        Message 3 of 4 , Jul 18, 2001
        • 0 Attachment
          All,

          Simple fix to hklatex.emf, replace the command-flag variable definition to
          the one below. There have been a few minor teething problems which we are
          ironing out and we will update the release once things have settled down -
          will let you know when that happens.

          Steve

          diff "hklatex.emf-broken" "hklatex.emf"

          46c46
          < set-variable .fhook-latex.command-flag
          "|bo|bo|bo|bo|thb|thb|thb|thb|th|thb|thb|th|thb|th|th|thbH|"
          ---
          > set-variable .fhook-latex.command-flag
          "|bo|bo|bo|bo|thb|thb|thb|thb|th|thb|th|th|thbH|"

          > -----Original Message-----
          > From: pmmg@... [mailto:pmmg@...]
          > Sent: Tuesday, July 17, 2001 4:04 PM
          > To: jasspa@yahoogroups.com
          > Subject: [jasspa] Bug while loading a latex/tex file
          >
          >
          > Hello!
          >
          > I've been testing this new release and while loading a LaTeX or
          > TeX, file it gives me an error "[No such command '']" and then
          > after pressing a key all comes back to normal.
          >
          > I've traced it to the buffer-initialize in hklatex.emf, but I
          > dont see any reason for this to happen. If after the error I go
          > to Buffer Setup and provoke the reinitialization of the hookfile
          > by pressing Save and Current all works Ok.
          >
          > This is not a major issue since all works OK except for the error message.
          >
          > It seems that is a bug in the setup flags that is calling a
          > function that is not found. The macro parser is not catching the
          > invalid command name so it displays ''.
          >
          > Regards
          >
          > Pedro Gomes
          >
          >
          >
          > __________________________________________________________________________
          >
          >
          >
          > This is an unmoderated list. JASSPA is not responsible for the content of
          >
          > any material posted to this list.
          >
          >
          >
          >
          > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
          >
          >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.