Loading ...
Sorry, an error occurred while loading the content.

Document mode

Expand Messages
  • David Edwards
    Because I have moved machines a while ago I have not used jasspa for a while. I have copied the directories from my old computer to my new one (old=Win95,
    Message 1 of 2 , Feb 28, 2001
    • 0 Attachment
      Because I have moved machines a while ago I have not used jasspa for a
      while. I have copied the directories from my old computer to my new one
      (old=Win95, new=WinNT4). I've got just about everything working fine except
      for a couple of items. (MicroEmacs 00 - Date 00/01/26 - win32).
      When I used jasspa a lot last year jon etc were very helpful in getting me
      to understand the document mode, but as always if I leave something for a
      while, I always end up with problems :-)

      1) I have a text file (notes.txt) when I open it it loads document mode
      with fill-col and ofill-col (??) set to 70 - no problem it's what I want. I
      have another text file (new1.txt), when I open it, it loads in document
      mode, but fill-col is set to 78 and ofill-col is set to 70. I want the
      fill col to be 70, but when I enter text, it is - of course - as per
      settings - at 78. This is frustrating.
      Why is it happening.

      2) When I enter a number of paragraphs with bullets (1.; 1.1; 1.1.1. etc)
      the fill process (esc q) is aligning everything on the first bullet. What
      am I doing wrong?

      Thanks for any replies.
      Dave E.
    • Jon Green
      ... Actually, I m wondering the document modes were in the 00/01/26 release. I think I did most of this work in Feb/March and is most likely supported in the
      Message 2 of 2 , Feb 28, 2001
      • 0 Attachment
        David Edwards wrote:
        >
        > Because I have moved machines a while ago I have not used jasspa for a
        > while. I have copied the directories from my old computer to my new one
        > (old=Win95, new=WinNT4). I've got just about everything working fine except
        > for a couple of items. (MicroEmacs 00 - Date 00/01/26 - win32).
        > When I used jasspa a lot last year jon etc were very helpful in getting me
        > to understand the document mode, but as always if I leave something for a
        > while, I always end up with problems :-)
        >

        Actually, I'm wondering the document modes were in the 00/01/26 release.
        I think I did most of this work in Feb/March and is most likely
        supported in the Alpha release that is on the Jasspa site ??
        Follow the comments below - if they do not work then switch to
        the alpha.

        >
        > 1) I have a text file (notes.txt) when I open it it loads document mode
        > with fill-col and ofill-col (??) set to 70 - no problem it's what I want. I
        > have another text file (new1.txt), when I open it, it loads in document
        > mode, but fill-col is set to 78 and ofill-col is set to 70. I want the
        > fill col to be 70, but when I enter text, it is - of course - as per
        > settings - at 78. This is frustrating.
        > Why is it happening.

        You need the magic header:-

        > -!- document; fill-column:70 -!-
        >
        > Copyright 2000 Orb Systems Ltd.
        >
        > Created By : Jon Green
        > Created : Tue Apr 18 17:11:08 2000
        > Last Modified : <010228.1458>
        >

        You could set the value of $fill-col to 70 in your start up file.

        set-variable $fill-col 70

        Then all text will wrap at 70. I would advocate the magic
        header myself.

        >
        > 2) When I enter a number of paragraphs with bullets (1.; 1.1; 1.1.1. etc)
        > the fill process (esc q) is aligning everything on the first bullet. What
        > am I doing wrong?


        What do you sections look like ?? As follows I hope !!


        1.1 Section one dot one

        Some text

        1.1.1 Section one dot one dot one

        Some more text

        1.1.2 Section one dot one dot two

        Some more text

        * This is actually a bullet.
        * This is another bullet.


        Regards
        Jon.

        >
        > Thanks for any replies.
        > Dave E.
        >
        > __________________________________________________________________________
        >
        > This is an unmoderated list. JASSPA is not responsible for the content of
        >
        > any material posted to this list.
        >
        >
        >
        > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/

        --
        ______________________________________________________________________

        Jon Green J.D.Naughton-Green
        Project Manager

        SAMSUNG Electronics (UK) Ltd
        Samsung Electronics Research Institute (Audio / Visual Labs)
        The Communication Centre
        South Street
        Staines Tel(direct): +44 (0)1784 428614
        MIDDLESEX Tel(s/w board): +44 (0)1784 428600 ext 614
        TW18 4QE Fax: +44 (0)1784 428620
        England Email (work): jon@...
        Email (home): jon@...
        _______________________________________________________________________
      Your message has been successfully submitted and would be delivered to recipients shortly.