Loading ...
Sorry, an error occurred while loading the content.

micro-emacs on OSX (intel)

Expand Messages
  • csynt
    Hi, I am trying the me under OSX, and I noticed that when I press the backspace, does not delete the previous character. As I see the me recognises the
    Message 1 of 6 , Aug 26 2:55 PM
    • 0 Attachment
      Hi,

      I am trying the me under OSX, and I noticed that when I press the backspace, does not delete the previous character. As I see the me recognises the backspace as "Delete" (eg when I press ESC-backspace I see the message key is not bound ESC - Delete).
      Do I need to setup any configuration file? I just unzipped the binary and put it into the /usr/bin.

      thx

      chris
    • Jon Green
      Hi Chris, I am using OSX myself and do not have this problem. So on a MacBook Pro the key labelled delete produces a backspace as expected. keys fn+delete
      Message 2 of 6 , Aug 27 12:21 AM
      • 0 Attachment
        Hi Chris,

        I am using OSX myself and do not have this problem.
        So on a MacBook Pro the key labelled "delete" produces a backspace as expected.
        keys fn+delete produces a forward-delete as expected.
        esc+backspace (esc delete key) produces backwards-kill-word
        esc-delete (esc fn+delete key) is unbound.

        me is the downloaded one:
        MicroEmacs 09 - Date 2009/12/12 - darwin

        What kind of keyboard are you using?
        Does this keyboard produce the correct response in other applications?

        Regards
        Jon.


        On 26 Aug 2013, at 22:55, csynt <csynt@...> wrote:

        > Hi,
        >
        > I am trying the me under OSX, and I noticed that when I press the backspace, does not delete the previous character. As I see the me recognises the backspace as "Delete" (eg when I press ESC-backspace I see the message key is not bound ESC - Delete).
        > Do I need to setup any configuration file? I just unzipped the binary and put it into the /usr/bin.
        >
        > thx
        >
        > chris
        >
        >
        >
        > ------------------------------------
        >
        > __________________________________________________________________________
        >
        > This is an unmoderated list, but new members are moderated to ensure that there are no spam users. JASSPA is not responsible for the content of
        > any material posted to this list.
        >
        > To un-subscribe, send a mail message to
        >
        > mailto:jasspa-unsubscribe@yahoogroups.com
        >
        > or visit http://groups.yahoo.com/group/jasspa and
        > modify your account settings manually.
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
      • csynt
        Hi Jon, Just fixed this by trial and error... ;-) I have a PC keyboard, but anyway the fix is : I enabled the option Delete sends Control-H on the terminal
        Message 3 of 6 , Aug 27 1:05 AM
        • 0 Attachment
          Hi Jon,

          Just fixed this by trial and error... ;-)

          I have a PC keyboard, but anyway the fix is :
          I enabled the option "Delete sends Control-H" on the terminal prefs,
          and btw, the backspace worked ok on other terminal apps like vi for example.

          kind regards

          chris

          --- In jasspa@yahoogroups.com, Jon Green <jon@...> wrote:
          >
          > Hi Chris,
          >
          > I am using OSX myself and do not have this problem.
          > So on a MacBook Pro the key labelled "delete" produces a backspace as expected.
          > keys fn+delete produces a forward-delete as expected.
          > esc+backspace (esc delete key) produces backwards-kill-word
          > esc-delete (esc fn+delete key) is unbound.
          >
          > me is the downloaded one:
          > MicroEmacs 09 - Date 2009/12/12 - darwin
          >
          > What kind of keyboard are you using?
          > Does this keyboard produce the correct response in other applications?
          >
          > Regards
          > Jon.
          >
          >
          > On 26 Aug 2013, at 22:55, csynt <csynt@...> wrote:
          >
          > > Hi,
          > >
          > > I am trying the me under OSX, and I noticed that when I press the backspace, does not delete the previous character. As I see the me recognises the backspace as "Delete" (eg when I press ESC-backspace I see the message key is not bound ESC - Delete).
          > > Do I need to setup any configuration file? I just unzipped the binary and put it into the /usr/bin.
          > >
          > > thx
          > >
          > > chris
          > >
          > >
          > >
          > > ------------------------------------
          > >
          > > __________________________________________________________________________
          > >
          > > This is an unmoderated list, but new members are moderated to ensure that there are no spam users. JASSPA is not responsible for the content of
          > > any material posted to this list.
          > >
          > > To un-subscribe, send a mail message to
          > >
          > > mailto:jasspa-unsubscribe@yahoogroups.com
          > >
          > > or visit http://groups.yahoo.com/group/jasspa and
          > > modify your account settings manually.
          > >
          > >
          > > Yahoo! Groups Links
          > >
          > >
          > >
          >
        • Jon Green
          Hi Chris, Thanks for info. I will play around with a pc keybosrd and see if there is anything wrong. Regards Jon. ... -- Sent from my Android phone with K-9
          Message 4 of 6 , Aug 27 1:18 AM
          • 0 Attachment
            Hi Chris,

            Thanks for info. I will play around with a pc keybosrd and see if there is anything wrong.

            Regards
            Jon.

            csynt <csynt@...> wrote:
            Hi Jon,

            Just fixed this by trial and error... ;-)

            I have a PC keyboard, but anyway the fix is :
            I enabled the option "Delete sends Control-H" on the terminal prefs,
            and btw, the backspace worked ok on other terminal apps like vi for example.

            kind regards

            chris

            --- In jasspa@yahoogroups.com, Jon Green <jon@...> wrote:

            Hi Chris,

            I am using OSX myself and do not have this problem.
            So on a MacBook Pro the key labelled "delete" produces a backspace as expected.
            keys fn+delete produces a forward-delete as expected.
            esc+backspace (esc delete key) produces backwards-kill-word
            esc-delete (esc fn+delete key) is unbound.

            me is the downloaded one:
            MicroEmacs 09 - Date 2009/12/12 - darwin

            What kind of keyboard are you using?
            Does this keyboard produce the correct response in other applications?

            Regards
            Jon.


            On 26 Aug 2013, at 22:55, csynt <csynt@...> wrote:

            Hi,

            I am trying the me under OSX, and I noticed that when I press the backspace, does not delete the previous character. As I see the me recognises the backspace as "Delete" (eg when I press ESC-backspace I see the message key is not bound ESC - Delete).
            Do I need to setup any configuration file? I just unzipped the binary and put it into the /usr/bin.

            thx

            chris









            This is an unmoderated list, but new members are moderated to ensure that there are no spam users. JASSPA is not responsible for the content of
            any material posted to this list.

            To un-subscribe, send a mail message to

            mailto:jasspa-unsubscribe@yahoogroups.com

            or visit http://groups.yahoo.com/group/jasspa and
            modify your account settings manually.


            Yahoo! Groups Links














            This is an unmoderated list, but new members are moderated to ensure that there are no spam users. JASSPA is not responsible for the content of
            any material posted to this list.

            To un-subscribe, send a mail message to

            mailto:jasspa-unsubscribe@yahoogroups.com

            or visit http://groups.yahoo.com/group/jasspa and
            modify your account settings manually.


            Yahoo! Groups Links

            <*> To visit your group on the web, go to:
            http://groups.yahoo.com/group/jasspa/

            <*> Your email settings:
            Individual Email | Traditional

            <*> To change settings online go to:
            http://groups.yahoo.com/group/jasspa/join
            (Yahoo! ID required)

            <*> To change settings via email:
            jasspa-digest@yahoogroups.com
            jasspa-fullfeatured@yahoogroups.com

            <*> To unsubscribe from this group, send an email to:
            jasspa-unsubscribe@yahoogroups.com

            <*> Your use of Yahoo! Groups is subject to:
            http://docs.yahoo.com/info/terms/

            --
            Sent from my Android phone with K-9 Mail. Please excuse my brevity.
          • Jon Green
            Hi Chris, As promised I said I would follow up on PC keyboard on a Mac. I am currently using a 105 UK PC Keyboard (a Sun Microsystems USB keyboard) on a Mini
            Message 5 of 6 , Aug 27 2:37 PM
            • 0 Attachment
              Hi Chris,

              As promised I said I would follow up on PC keyboard on a Mac.
              I am currently using a 105 UK PC Keyboard (a Sun Microsystems USB keyboard) on a Mini Mac
              with no issues. I have been using this for a long time and could not remember if I had any issues which
              I had specifically fixed or worked around in MicroEmacs, I was not aware of any. Certainly both the delete
              and backspace keys of the keyboard are mapping correctly with the right bindings. The keys are
              correct in both an X-Windows display and native terminal window.

              So I checked out what I had installed on the Mini Mac to get the PC keyboard running with OSX (10.7.5).
              In order to get the key mappings correctly then I installed the keyboard layouts from here:

              http://blog.inf.ed.ac.uk/gdutton/2009/08/real-mac-uk-keyboard-layout/

              using the "Real UK - IBM/PC" configuration. Obviously if you are not using a UK 105 keyboard
              then you will have to find the appropriate keyboard map that matches your keyboard (I cannot help you with this).

              The other thing that I do on a Mac is turn off all of the accelerator keys bound to other functions that Apple enable by default.
              Turning off the accelerators enables me to use ctrl/alt+up/down/left/right etc. So I am not bothered about short cuts on the O/S
              and just require MicroEmacs to play nicely with all of the keystrokes I want to use.

              Hope that helps.

              Regards
              Jon.
            • csynt
              Hi Jon, Cheers for this! I will try tomorrow this keyboard, as in fact some of the keys of my PC keyboard are not working correctly! like the key with | is
              Message 6 of 6 , Aug 27 3:32 PM
              • 0 Attachment
                Hi Jon,

                Cheers for this!

                I will try tomorrow this keyboard, as in fact some of the
                keys of my PC keyboard are not working correctly! like the key with |\ is on the bottom, but I have to press the left topmost (under ESC) to get these symbols...

                Its a UK (HP) "win" keyboard (PS2 in fact over USB converter)

                Kind Regards

                Chris


                --- In jasspa@yahoogroups.com, Jon Green <jon@...> wrote:
                >
                > Hi Chris,
                >
                > As promised I said I would follow up on PC keyboard on a Mac.
                > I am currently using a 105 UK PC Keyboard (a Sun Microsystems USB keyboard) on a Mini Mac
                > with no issues. I have been using this for a long time and could not remember if I had any issues which
                > I had specifically fixed or worked around in MicroEmacs, I was not aware of any. Certainly both the delete
                > and backspace keys of the keyboard are mapping correctly with the right bindings. The keys are
                > correct in both an X-Windows display and native terminal window.
                >
                > So I checked out what I had installed on the Mini Mac to get the PC keyboard running with OSX (10.7.5).
                > In order to get the key mappings correctly then I installed the keyboard layouts from here:
                >
                > http://blog.inf.ed.ac.uk/gdutton/2009/08/real-mac-uk-keyboard-layout/
                >
                > using the "Real UK - IBM/PC" configuration. Obviously if you are not using a UK 105 keyboard
                > then you will have to find the appropriate keyboard map that matches your keyboard (I cannot help you with this).
                >
                > The other thing that I do on a Mac is turn off all of the accelerator keys bound to other functions that Apple enable by default.
                > Turning off the accelerators enables me to use ctrl/alt+up/down/left/right etc. So I am not bothered about short cuts on the O/S
                > and just require MicroEmacs to play nicely with all of the keystrokes I want to use.
                >
                > Hope that helps.
                >
                > Regards
                > Jon.
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.