Loading ...
Sorry, an error occurred while loading the content.

New files, create as CR only on Windows, not CR&LF

Expand Messages
  • Jeremy Cowgar
    Hello, I have went to my user configuration and removed the Lf flag, but new files still seem to be created as CRLF, not just CR. Am I doing something wrong?
    Message 1 of 8 , Nov 26, 2011
    • 0 Attachment
      Hello,
       
      I have went to my user configuration and removed the "Lf" flag, but new files still seem to be created as CRLF, not just CR. Am I doing something wrong?
       
      Thanks,
       
      Jeremy
    • hops
      Hi all Has anyone else noticed any problems with the latest jasspa me version not using or reading session files ?? I updated to use the new version about a
      Message 2 of 8 , Nov 26, 2011
      • 0 Attachment
        Hi all

        Has anyone else noticed any problems with the latest jasspa me version
        not using or reading session files ??

        I updated to use the new version about a month ago and immediately
        noticed the latest version did not correctly read/use the previous
        version session files
        (regenerate the previous session) and does not correctly read/use
        session files made from a new changed session done within itself..

        The session files seem to have the correct ( new session ) info - file
        names at least and the startup status line message indicate the session
        has been read ( but files not loaded....)

        ??

        --
        -- hops
      • Jeremy Cowgar
        ... From: Jeremy Cowgar To: Group, MicroEmacs User Sent: 11/26/2011 11:05:38 AM Subject: [jasspa] New files,
        Message 3 of 8 , Nov 27, 2011
        • 0 Attachment
          ------ Original Message ------
          From: "Jeremy Cowgar" <jeremy@...>
          To: "Group, MicroEmacs User" <jasspa@yahoogroups.com>
          Sent: 11/26/2011 11:05:38 AM
          Subject: [jasspa] New files, create as CR only on Windows, not CR&LF
          >
          >I have went to my user configuration and removed the "Lf" flag, but
          >new files still seem to be created as CRLF, not just CR. Am I doing
          >something wrong?


          I was able to add

          -1 global-mode "lf"

          to my startup file and that seems to have done it.

          Jeremy
        • Steven Phillips
          Are the files local? ME does not read network files in as the network may not be available in which case ME will hang for a long time (there s probably a way
          Message 4 of 8 , Nov 29, 2011
          • 0 Attachment
            Are the files local? ME does not read network files in as the network may not be available in which case ME will hang for a long time (there's probably a way of making it though....).

            Are there any other symptoms as I've not had any problems myself.

            Steve

            hops wrote:
             

            Hi all

            Has anyone else noticed any problems with the latest jasspa me version
            not using or reading session files ??

            I updated to use the new version about a month ago and immediately
            noticed the latest version did not correctly read/use the previous
            version session files
            (regenerate the previous session) and does not correctly read/use
            session files made from a new changed session done within itself..

            The session files seem to have the correct ( new session ) info - file
            names at least and the startup status line message indicate the session
            has been read ( but files not loaded....)

            ??

            --
            -- hops

          • Steven Phillips
            Not sure how you had removed the lf mode but global-mode is the right way to go for a global change, alternatively consider creating a my .emf hook
            Message 5 of 8 , Nov 29, 2011
            • 0 Attachment
              Not sure how you had removed the 'lf' mode but global-mode is the right way to go for a global change, alternatively consider creating a my<file-type>.emf hook to change just one file type.

              Note that if you have 'auto' mode still enabled lf mode will still be enabled for old files that have lf chars in their end of line format.

              Steve

              Jeremy Cowgar wrote:
               


              ------ Original Message ------
              From: "Jeremy Cowgar" <jeremy@...>
              To: "Group, MicroEmacs User" <jasspa@yahoogroups.com>
              Sent: 11/26/2011 11:05:38 AM
              Subject: [jasspa] New files, create as CR only on Windows, not CR&LF
              >
              >I have went to my user configuration and removed the "Lf" flag, but
              >new files still seem to be created as CRLF, not just CR. Am I doing
              >something wrong?


              I was able to add

              -1 global-mode "lf"

              to my startup file and that seems to have done it.

              Jeremy

            • Jeremy Cowgar
              Tools User Setup General Show Modes. lf is listed, there I unchecked it. Jeremy ... From: Steven Phillips To:
              Message 6 of 8 , Nov 29, 2011
              • 0 Attachment
                Tools > User Setup > General > Show Modes. lf is listed, there I "unchecked" it.
                 
                Jeremy
                ------ Original Message ------
                From: "Steven Phillips" <bill@...>
                To: jasspa@yahoogroups.com
                Sent: 11/29/2011 1:48:45 PM
                Subject: Re: [jasspa] New files, create as CR only on Windows, not CR&LF
                 

                Not sure how you had removed the 'lf' mode but global-mode is the right way to go for a global change, alternatively consider creating a my<file-type>.emf hook to change just one file type.

                Note that if you have 'auto' mode still enabled lf mode will still be enabled for old files that have lf chars in their end of line format.

                Steve

                Jeremy Cowgar wrote:

                 


                ------ Original Message ------
                From: "Jeremy Cowgar" <jeremy@...>
                To: "Group, MicroEmacs User" <jasspa@yahoogroups.com>
                Sent: 11/26/2011 11:05:38 AM
                Subject: [jasspa] New files, create as CR only on Windows, not CR&LF
                >
                >I have went to my user configuration and removed the "Lf" flag, but
                >new files still seem to be created as CRLF, not just CR. Am I doing
                >something wrong?


                I was able to add

                -1 global-mode "lf"

                to my startup file and that seems to have done it.

                Jeremy

              • Steven Phillips
                Ahhh, that explains its lack of effect, Show modes is used to determine which modes are shown in a window s mode line (i.e. the list of letters), it doesn t
                Message 7 of 8 , Nov 29, 2011
                • 0 Attachment
                  Ahhh, that explains its lack of effect, 'Show modes' is used to determine which modes are shown in a window's mode line (i.e. the list of letters), it doesn't affect whether it's enabled or not.

                  Steve

                  Jeremy Cowgar wrote:
                   

                  Tools > User Setup > General > Show Modes. lf is listed, there I "unchecked" it.
                   
                  Jeremy
                  ------ Original Message ------
                  From: "Steven Phillips" <bill@...>
                  To: jasspa@yahoogroups.com
                  Sent: 11/29/2011 1:48:45 PM
                  Subject: Re: [jasspa] New files, create as CR only on Windows, not CR&LF
                   

                  Not sure how you had removed the 'lf' mode but global-mode is the right way to go for a global change, alternatively consider creating a my<file-type>.emf hook to change just one file type.

                  Note that if you have 'auto' mode still enabled lf mode will still be enabled for old files that have lf chars in their end of line format.

                  Steve

                  Jeremy Cowgar wrote:

                   


                  ------ Original Message ------
                  From: "Jeremy Cowgar" <jeremy@...>
                  To: "Group, MicroEmacs User" <jasspa@yahoogroups.com>
                  Sent: 11/26/2011 11:05:38 AM
                  Subject: [jasspa] New files, create as CR only on Windows, not CR&LF
                  >
                  >I have went to my user configuration and removed the "Lf" flag, but
                  >new files still seem to be created as CRLF, not just CR. Am I doing
                  >something wrong?


                  I was able to add

                  -1 global-mode "lf"

                  to my startup file and that seems to have done it.

                  Jeremy

                • hops
                  ... Yes they re local /Documents and Settings/hops/Application Data/JASSPA/hops.esf ME does not read network files in as the network ... Its not hanging at
                  Message 8 of 8 , Dec 2, 2011
                  • 0 Attachment
                    On 11/30/2011 7:42 AM, Steven Phillips wrote:
                    > Are the files local?

                    Yes they're local
                    /Documents and Settings/hops/Application Data/JASSPA/hops.esf

                    ME does not read network files in as the network
                    > may not be available in which case ME will hang for a long time (there's
                    > probably a way of making it though....).
                    Its not hanging at all. Starts up as normal
                    The status line message indicates that its read the session file
                    '[Session read]' but a session with the files is is not recreated


                    >
                    Was there any change to the session file format at the last version
                    ( this is on Windows XP)

                    > Are there any other symptoms as I've not had any problems myself.
                    Pox.

                    Thats pretty much it no session (re)made but looks like the macro code
                    is passing through the reading of the session file


                    I just tried manually saving and manually loading the session file
                    ('save-session' and 'read-session') and that seemed to work.

                    Stopping and restarting after that me-10 still didnt automatically load
                    the session on startup (in spite of the shown '[Session read]' showing
                    but if I run a 'read-session' command manually it does load the sessions
                    files.

                    In a default distribution where in the macro files run on startup is the
                    session loaded ( read-session command run)?

                    >
                    > Steve
                    >
                    > hops wrote:
                    >>
                    >>
                    >> Hi all
                    >>
                    >> Has anyone else noticed any problems with the latest jasspa me version
                    >> not using or reading session files ??
                    >>
                    >> I updated to use the new version about a month ago and immediately
                    >> noticed the latest version did not correctly read/use the previous
                    >> version session files
                    >> (regenerate the previous session) and does not correctly read/use
                    >> session files made from a new changed session done within itself..
                    >>
                    >> The session files seem to have the correct ( new session ) info - file
                    >> names at least and the startup status line message indicate the session
                    >> has been read ( but files not loaded....)
                    >>
                    >> ??
                    >>
                    >> --
                    >> -- hops
                    >>
                    >>
                    >


                    --
                    -- hops
                  Your message has been successfully submitted and would be delivered to recipients shortly.