Loading ...
Sorry, an error occurred while loading the content.

Build failure on Linux 3.0

Expand Messages
  • Ulrich Mueller
    Hello, I ve noticed that building of Jasspa Microemacs (October 2009 version) fails with the Linux 3.0 kernel. The problem is due to the new numbering scheme
    Message 1 of 2 , Aug 19, 2011
    • 0 Attachment
      Hello,

      I've noticed that building of Jasspa Microemacs (October 2009 version)
      fails with the Linux 3.0 kernel.

      The problem is due to the new numbering scheme of Linux, which is not
      properly recognised by src/build:

      elif [ $PLATFORM = "Linux" ] ; then
      MACHINE=`uname -m | cut -c 1-3`
      if [ $MACHINE = "arm" ] ; then
      MAKEBAS=zaurus
      else
      KERNEL_MAJOR=`uname -r | cut -c 1-1`
      KERNEL_MINOR=`uname -r | cut -c 3-3`
      MAKEBAS="linux$KERNEL_MAJOR$KERNEL_MINOR"
      if [ ! -r $MAKEBAS.gmk ] ; then
      MAKEBAS="linux2"
      fi
      fi

      The code will look for linux30.gmk which does not exist, and then fall
      back to linux2 (which subsequently fails because it tries linking
      against termcap instead of ncurses).

      As a workaround when packaging Jasspa Microemacs for Gentoo Linux,
      I've hardcoded linux26, see the following patch:
      <http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-editors/jasspa-microemacs/files/20091011-linux3.patch?view=markup>
      Maybe in the general case a more elaborate solution is called for.

      BTW, have you ever considered changing the build system to something
      more modern (like Autotools or CMake)?

      Ulrich
    • Jon Green
      Hi Ulrich, Thanks for this. Sorry you had to do this. Not being on the leading edge then not encountered Linux 3 yet, all been Linux 2.x systems. As for auto
      Message 2 of 2 , Aug 20, 2011
      • 0 Attachment
        Hi Ulrich,

        Thanks for this. Sorry you had to do this.
        Not being on the leading edge then not encountered Linux 3 yet, all been Linux 2.x systems.
        As for auto tools then this has simply been a lack of time to invest in doing the work.

        Thanks for your time here, we will try and get a patch out.

        Regards
        Jon.

        On 19 Aug 2011, at 11:59, Ulrich Mueller <ulm@...> wrote:

        > Hello,
        >
        > I've noticed that building of Jasspa Microemacs (October 2009 version)
        > fails with the Linux 3.0 kernel.
        >
        > The problem is due to the new numbering scheme of Linux, which is not
        > properly recognised by src/build:
        >
        > elif [ $PLATFORM = "Linux" ] ; then
        > MACHINE=`uname -m | cut -c 1-3`
        > if [ $MACHINE = "arm" ] ; then
        > MAKEBAS=zaurus
        > else
        > KERNEL_MAJOR=`uname -r | cut -c 1-1`
        > KERNEL_MINOR=`uname -r | cut -c 3-3`
        > MAKEBAS="linux$KERNEL_MAJOR$KERNEL_MINOR"
        > if [ ! -r $MAKEBAS.gmk ] ; then
        > MAKEBAS="linux2"
        > fi
        > fi
        >
        > The code will look for linux30.gmk which does not exist, and then fall
        > back to linux2 (which subsequently fails because it tries linking
        > against termcap instead of ncurses).
        >
        > As a workaround when packaging Jasspa Microemacs for Gentoo Linux,
        > I've hardcoded linux26, see the following patch:
        > <http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-editors/jasspa-microemacs/files/20091011-linux3.patch?view=markup>
        > Maybe in the general case a more elaborate solution is called for.
        >
        > BTW, have you ever considered changing the build system to something
        > more modern (like Autotools or CMake)?
        >
        > Ulrich
        >
        >
        > ------------------------------------
        >
        > __________________________________________________________________________
        >
        > This is an unmoderated list, but new members are moderated to ensure that there are no spam users. JASSPA is not responsible for the content of
        > any material posted to this list.
        >
        > To un-subscribe, send a mail message to
        >
        > mailto:jasspa-unsubscribe@yahoogroups.com
        >
        > or visit http://groups.yahoo.com/group/jasspa and
        > modify your account settings manually.
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.