Loading ...
Sorry, an error occurred while loading the content.
 

Re: [jasspa] Problem while running gdiff via the command line

Expand Messages
  • Jon Green
    ... Cor! Yes you are right. It is because gdiff runs me.emf in its startup and is restoring the session. Here is a temporary patch for the end of the
    Message 1 of 14 , Oct 20, 2009
      azynheira wrote:
      > Hello All,
      > I've found some bug in gdiff :-)
      > If I execute gdiff as an independent tool via:
      > me "@gdiff" <old> <new>
      > and I have the toolbar enabled, gdiff will never diff anything and complain with the usual message "gdiff Error: usage <new> <old".
      >
      > If I disable the toolbar it will work perfectly. It seems gdiff and toolbar do not mix together.

      Cor! Yes you are right. It is because gdiff runs me.emf in its startup and is restoring the session.

      Here is a temporary patch for the end of the gdiff.emf, replaced the existing startup code.
      It basically kills the toolbar *item-list* which is causing the problem.
      I have not figured out why there is a !force find-buffer #l0 in here at the moment, I do not think it is needed:

      !if .start-up
      define-macro start-up
      !force 2 delete-other-windows
      ; Delete the item list if the toolbar is enabled.
      !force 1 delete-buffer "*item-list*"
      !if &seq $buffer-bname "*scratch*"
      next-buffer
      !endif
      set-variable #l0 $buffer-fname
      set-variable #l2 $buffer-bname
      ; Why is this here?
      ; !force find-buffer #l0
      next-buffer
      !if &seq $buffer-bname "*scratch*"
      next-buffer
      set-variable #l1 $buffer-fname
      set-variable #l3 $buffer-bname
      !else
      set-variable #l1 $buffer-fname
      set-variable #l3 $buffer-bname
      next-buffer
      !endif
      next-buffer
      !if &or ¬ &seq $buffer-bname #l2 &seq #l2 #l3
      ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
      !else
      gdiff #l0 #l1
      !endif
      !emacro
      !endif



      >
      > Another minor problem is that if diff.exe (in Win32 of course!) does not exist in the PATH it will not complain and will think the files are equal :-)
      >

      In the 20091011 windows installer then you can install the windows tools as an option.
      These are placed in the "ME" directory so they should be found. Did you install these or are you using something else (possibly nothing)?

      Regards
      Jon


      > My 10c :P
      > Pedro
      >
      >
      >
      >
      >
      > ------------------------------------
      >
      > __________________________________________________________________________
      >
      > This is an unmoderated list, but new members are moderated to ensure that there are no spam users. JASSPA is not responsible for the content of
      > any material posted to this list.
      >
      > To un-subscribe, send a mail message to
      >
      > mailto:jasspa-unsubscribe@yahoogroups.com
      >
      > or visit http://groups.yahoo.com/group/jasspa and
      > modify your account settings manually.
      >
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
    • Jon Green
      ... Here is a better fix. I only have 1 tool installed, but you may have 2 so this will not work. The following should sort that problem. Regards Jon. !if
      Message 2 of 14 , Oct 20, 2009
        Jon Green wrote:
        > azynheira wrote:
        >> Hello All,
        >> I've found some bug in gdiff :-)
        >> If I execute gdiff as an independent tool via:
        >> me "@gdiff" <old> <new>
        >> and I have the toolbar enabled, gdiff will never diff anything and complain with the usual message "gdiff Error: usage <new> <old".
        >>
        >> If I disable the toolbar it will work perfectly. It seems gdiff and toolbar do not mix together.
        >
        > Cor! Yes you are right. It is because gdiff runs me.emf in its startup and is restoring the session.
        >
        > Here is a temporary patch for the end of the gdiff.emf, replaced the existing startup code.
        > It basically kills the toolbar *item-list* which is causing the problem.
        > I have not figured out why there is a !force find-buffer #l0 in here at the moment, I do not think it is needed:
        >
        > !if .start-up
        > define-macro start-up
        > !force 2 delete-other-windows
        > ; Delete the item list if the toolbar is enabled.
        > !force 1 delete-buffer "*item-list*"
        > !if &seq $buffer-bname "*scratch*"
        > next-buffer
        > !endif
        > set-variable #l0 $buffer-fname
        > set-variable #l2 $buffer-bname
        > ; Why is this here?
        > ; !force find-buffer #l0
        > next-buffer
        > !if &seq $buffer-bname "*scratch*"
        > next-buffer
        > set-variable #l1 $buffer-fname
        > set-variable #l3 $buffer-bname
        > !else
        > set-variable #l1 $buffer-fname
        > set-variable #l3 $buffer-bname
        > next-buffer
        > !endif
        > next-buffer
        > !if &or ¬ &seq $buffer-bname #l2 &seq #l2 #l3
        > ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
        > !else
        > gdiff #l0 #l1
        > !endif
        > !emacro
        > !endif
        >

        Here is a better fix. I only have 1 tool installed, but you may have 2 so this will not work.
        The following should sort that problem.

        Regards
        Jon.

        !if .start-up
        define-macro start-up
        ; Delete all of the windows. We use 2 to force this as there may be a
        ; toolbar present.
        !force 2 delete-other-windows
        ; Find the *scratch* buffer as our starting point.
        !while ¬ &seq $buffer-bname "*scratch*"
        next-buffer
        !done
        ; We are at *scratch*. Iterate around the list of buffers and delete
        ; any toolbar type buffers which will be temporary buffers.
        !repeat
        next-buffer
        !if &and ¬ &seq $buffer-bname "*scratch*" &seq "*" &lef $buffer-bname 1
        !force 1 delete-buffer $buffer-bname
        !endif
        !until &seq $buffer-bname "*scratch*"
        ; We are now at *scratch* advance to next buffer.
        next-buffer
        set-variable #l0 $buffer-fname
        set-variable #l2 $buffer-bname
        ; Why is this here?
        ; !force find-buffer #l0
        next-buffer
        !if &seq $buffer-bname "*scratch*"
        next-buffer
        set-variable #l1 $buffer-fname
        set-variable #l3 $buffer-bname
        !else
        set-variable #l1 $buffer-fname
        set-variable #l3 $buffer-bname
        next-buffer
        !endif
        next-buffer
        !if &or ¬ &seq $buffer-bname #l2 &seq #l2 #l3
        ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
        !else
        gdiff #l0 #l1
        !endif
        !emacro
        !endif




        >
        >
        >> Another minor problem is that if diff.exe (in Win32 of course!) does not exist in the PATH it will not complain and will think the files are equal :-)
        >>
        >
        > In the 20091011 windows installer then you can install the windows tools as an option.
        > These are placed in the "ME" directory so they should be found. Did you install these or are you using something else (possibly nothing)?
        >
        > Regards
        > Jon
        >
        >
        >> My 10c :P
        >> Pedro
        >>
        >>
        >>
        >>
        >>
        >> ------------------------------------
        >>
        >> __________________________________________________________________________
        >>
        >> This is an unmoderated list, but new members are moderated to ensure that there are no spam users. JASSPA is not responsible for the content of
        >> any material posted to this list.
        >>
        >> To un-subscribe, send a mail message to
        >>
        >> mailto:jasspa-unsubscribe@yahoogroups.com
        >>
        >> or visit http://groups.yahoo.com/group/jasspa and
        >> modify your account settings manually.
        >>
        >>
        >> Yahoo! Groups Links
        >>
        >>
        >>
        >>
        >
        >
        >
        > ------------------------------------
        >
        > __________________________________________________________________________
        >
        > This is an unmoderated list, but new members are moderated to ensure that there are no spam users. JASSPA is not responsible for the content of
        > any material posted to this list.
        >
        > To un-subscribe, send a mail message to
        >
        > mailto:jasspa-unsubscribe@yahoogroups.com
        >
        > or visit http://groups.yahoo.com/group/jasspa and
        > modify your account settings manually.
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
      • Jon Green
        ... Hi Pedro, I have placed all of the fixed macro files (and changes) in the following directory: http://www.jasspa.com/development/patches-20091017/ There is
        Message 3 of 14 , Oct 20, 2009
          azynheira wrote:
          > Hello All,
          > I've found some bug in gdiff :-)
          > If I execute gdiff as an independent tool via:
          > me "@gdiff" <old> <new>
          > and I have the toolbar enabled, gdiff will never diff anything and complain with the usual message "gdiff Error: usage <new> <old".
          >
          > If I disable the toolbar it will work perfectly. It seems gdiff and toolbar do not mix together.
          >
          > Another minor problem is that if diff.exe (in Win32 of course!) does not exist in the PATH it will not complain and will think the files are equal :-)
          >
          > My 10c :P
          > Pedro
          >

          Hi Pedro,

          I have placed all of the fixed macro files (and changes) in the following directory:

          http://www.jasspa.com/development/patches-20091017/

          There is also an update to the gdiff which should be the last.

          Regards
          Jon.
        • azynheira
          Hi Jon, I will give them a try and get back to you, Thanks, Pedro
          Message 4 of 14 , Oct 20, 2009
            Hi Jon,
            I will give them a try and get back to you,

            Thanks,
            Pedro

            --- In jasspa@yahoogroups.com, Jon Green <jon@...> wrote:
            >
            > azynheira wrote:
            > > Hello All,
            > > I've found some bug in gdiff :-)
            > > If I execute gdiff as an independent tool via:
            > > me "@gdiff" <old> <new>
            > > and I have the toolbar enabled, gdiff will never diff anything and complain with the usual message "gdiff Error: usage <new> <old".
            > >
            > > If I disable the toolbar it will work perfectly. It seems gdiff and toolbar do not mix together.
            > >
            > > Another minor problem is that if diff.exe (in Win32 of course!) does not exist in the PATH it will not complain and will think the files are equal :-)
            > >
            > > My 10c :P
            > > Pedro
            > >
            >
            > Hi Pedro,
            >
            > I have placed all of the fixed macro files (and changes) in the following directory:
            >
            > http://www.jasspa.com/development/patches-20091017/
            >
            > There is also an update to the gdiff which should be the last.
            >
            > Regards
            > Jon.
            >
          • azynheira
            Hi Jon, I tryed to use the gdiff from the command line with my huge toolbar and the problem stays the same (I used the version in the
            Message 5 of 14 , Oct 21, 2009
              Hi Jon,
              I tryed to use the gdiff from the command line with my huge toolbar and the problem stays the same (I used the version in the http://www.jasspa.com/development/patches-20091017/ directory.

              I'll try to debug the stuff and provide more accurate feedback.

              Regards,
              Pedro

              --- In jasspa@yahoogroups.com, "azynheira" <pedro.gomes@...> wrote:
              >
              > Hi Jon,
              > I will give them a try and get back to you,
              >
              > Thanks,
              > Pedro
              >
              > --- In jasspa@yahoogroups.com, Jon Green <jon@> wrote:
              > >
              > > azynheira wrote:
              > > > Hello All,
              > > > I've found some bug in gdiff :-)
              > > > If I execute gdiff as an independent tool via:
              > > > me "@gdiff" <old> <new>
              > > > and I have the toolbar enabled, gdiff will never diff anything and complain with the usual message "gdiff Error: usage <new> <old".
              > > >
              > > > If I disable the toolbar it will work perfectly. It seems gdiff and toolbar do not mix together.
              > > >
              > > > Another minor problem is that if diff.exe (in Win32 of course!) does not exist in the PATH it will not complain and will think the files are equal :-)
              > > >
              > > > My 10c :P
              > > > Pedro
              > > >
              > >
              > > Hi Pedro,
              > >
              > > I have placed all of the fixed macro files (and changes) in the following directory:
              > >
              > > http://www.jasspa.com/development/patches-20091017/
              > >
              > > There is also an update to the gdiff which should be the last.
              > >
              > > Regards
              > > Jon.
              > >
              >
            • Steven Phillips
              Pedro, Could you please try the attached version, I ve had a little hack... Steve
              Message 6 of 14 , Oct 21, 2009
              Pedro,

              Could you please try the attached version, I've had a little hack...

              Steve

              azynheira wrote:
               

              Hi Jon,
              I tryed to use the gdiff from the command line with my huge toolbar and the problem stays the same (I used the version in the http://www.jasspa. com/development/ patches-20091017 / directory.

              I'll try to debug the stuff and provide more accurate feedback.

              Regards,
              Pedro

              --- In jasspa@yahoogroups. com, "azynheira" <pedro.gomes@ ...> wrote:
              >
              > Hi Jon,
              > I will give them a try and get back to you,
              >
              > Thanks,
              > Pedro
              >
              > --- In jasspa@yahoogroups. com, Jon Green <jon@> wrote:
              > >
              > > azynheira wrote:
              > > > Hello All,
              > > > I've found some bug in gdiff :-)
              > > > If I execute gdiff as an independent tool via:
              > > > me "@gdiff" <old> <new>
              > > > and I have the toolbar enabled, gdiff will never diff anything and complain with the usual message "gdiff Error: usage <new> <old".
              > > >
              > > > If I disable the toolbar it will work perfectly. It seems gdiff and toolbar do not mix together.
              > > >
              > > > Another minor problem is that if diff.exe (in Win32 of course!) does not exist in the PATH it will not complain and will think the files are equal :-)
              > > >
              > > > My 10c :P
              > > > Pedro
              > > >
              > >
              > > Hi Pedro,
              > >
              > > I have placed all of the fixed macro files (and changes) in the following directory:
              > >
              > > http://www.jasspa. com/development/ patches-20091017 /
              > >
              > > There is also an update to the gdiff which should be the last.
              > >
              > > Regards
              > > Jon.
              > >
              >

            • azynheira
              Hi Steve, This one works ok :-). The only thing missing is some pause in case of error (the message in the modeline appears), instead of quick-exiting to the
              Message 7 of 14 , Oct 21, 2009
                Hi Steve,
                This one works ok :-). The only thing missing is some pause in case of error (the message in the modeline appears), instead of quick-exiting to the OS. But I think we can live with it ...

                Regards,
                Pedro



                --- In jasspa@yahoogroups.com, Steven Phillips <bill@...> wrote:
                >
                > Pedro,
                >
                > Could you please try the attached version, I've had a little hack...
                >
                > Steve
                >
                > azynheira wrote:
                > >
                > >
                > > Hi Jon,
                > > I tryed to use the gdiff from the command line with my huge toolbar
                > > and the problem stays the same (I used the version in the
                > > http://www.jasspa.com/development/patches-20091017/
                > > <http://www.jasspa.com/development/patches-20091017/> directory.
                > >
                > > I'll try to debug the stuff and provide more accurate feedback.
                > >
                > > Regards,
                > > Pedro
                > >
                > > --- In jasspa@yahoogroups.com <mailto:jasspa%40yahoogroups.com>,
                > > "azynheira" <pedro.gomes@> wrote:
                > > >
                > > > Hi Jon,
                > > > I will give them a try and get back to you,
                > > >
                > > > Thanks,
                > > > Pedro
                > > >
                > > > --- In jasspa@yahoogroups.com <mailto:jasspa%40yahoogroups.com>, Jon
                > > Green <jon@> wrote:
                > > > >
                > > > > azynheira wrote:
                > > > > > Hello All,
                > > > > > I've found some bug in gdiff :-)
                > > > > > If I execute gdiff as an independent tool via:
                > > > > > me "@gdiff" <old> <new>
                > > > > > and I have the toolbar enabled, gdiff will never diff anything
                > > and complain with the usual message "gdiff Error: usage <new> <old".
                > > > > >
                > > > > > If I disable the toolbar it will work perfectly. It seems gdiff
                > > and toolbar do not mix together.
                > > > > >
                > > > > > Another minor problem is that if diff.exe (in Win32 of course!)
                > > does not exist in the PATH it will not complain and will think the
                > > files are equal :-)
                > > > > >
                > > > > > My 10c :P
                > > > > > Pedro
                > > > > >
                > > > >
                > > > > Hi Pedro,
                > > > >
                > > > > I have placed all of the fixed macro files (and changes) in the
                > > following directory:
                > > > >
                > > > > http://www.jasspa.com/development/patches-20091017/
                > > <http://www.jasspa.com/development/patches-20091017/>
                > > > >
                > > > > There is also an update to the gdiff which should be the last.
                > > > >
                > > > > Regards
                > > > > Jon.
                > > > >
                > > >
                > >
                > >
                >
              • Steven Phillips
                What a simple solution! I had wondered how to get the error message visible on windows, a pause is just what we need. Please try the following change to get a
                Message 8 of 14 , Oct 21, 2009
                  What a simple solution! I had wondered how to get the error message visible on windows, a pause is just what we need. Please try the following change to get a 5sec pause:

                  *** d:\me\macros\gdiff.emf.~0~    Wed Oct 21 08:49:44 2009
                  --- d:\me\macros\gdiff.emf    Wed Oct 21 10:24:29 2009
                  ***************
                  *** 923,935 ****
                                set-variable #l1 $buffer-fname
                              !else
                                ; more than 2 files given - error
                  !             ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                                0 quick-exit
                              !endif
                              next-buffer
                            !until &seq $buffer-bname #l2
                            !if &seq #l1 ""
                  !           ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                            !else
                              gdiff #l0 #l1
                            !endif
                  --- 923,935 ----
                                set-variable #l1 $buffer-fname
                              !else
                                ; more than 2 files given - error
                  !             5000 ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                                0 quick-exit
                              !endif
                              next-buffer
                            !until &seq $buffer-bname #l2
                            !if &seq #l1 ""
                  !           5000 ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                            !else
                              gdiff #l0 #l1
                            !endif
                  [EXIT 1]


                  azynheira wrote:
                   

                  Hi Steve,
                  This one works ok :-). The only thing missing is some pause in case of error (the message in the modeline appears), instead of quick-exiting to the OS. But I think we can live with it ...

                  Regards,
                  Pedro

                  --- In jasspa@yahoogroups. com, Steven Phillips <bill@...> wrote:
                  >
                  > Pedro,
                  >
                  > Could you please try the attached version, I've had a little hack...
                  >
                  > Steve
                  >
                  > azynheira wrote:
                  > >
                  > >
                  > > Hi Jon,
                  > > I tryed to use the gdiff from the command line with my huge toolbar
                  > > and the problem stays the same (I used the version in the
                  > > http://www.jasspa. com/development/ patches-20091017 /
                  > > <http://www.jasspa. com/development/ patches-20091017 /> directory.
                  > >
                  > > I'll try to debug the stuff and provide more accurate feedback.
                  > >
                  > > Regards,
                  > > Pedro
                  > >
                  > > --- In jasspa@yahoogroups. com <mailto:jasspa% 40yahoogroups. com>,
                  > > "azynheira" <pedro.gomes@ > wrote:
                  > > >
                  > > > Hi Jon,
                  > > > I will give them a try and get back to you,
                  > > >
                  > > > Thanks,
                  > > > Pedro
                  > > >
                  > > > --- In jasspa@yahoogroups. com <mailto:jasspa% 40yahoogroups. com>, Jon
                  > > Green <jon@> wrote:
                  > > > >
                  > > > > azynheira wrote:
                  > > > > > Hello All,
                  > > > > > I've found some bug in gdiff :-)
                  > > > > > If I execute gdiff as an independent tool via:
                  > > > > > me "@gdiff" <old> <new>
                  > > > > > and I have the toolbar enabled, gdiff will never diff anything
                  > > and complain with the usual message "gdiff Error: usage <new> <old".
                  > > > > >
                  > > > > > If I disable the toolbar it will work perfectly. It seems gdiff
                  > > and toolbar do not mix together.
                  > > > > >
                  > > > > > Another minor problem is that if diff.exe (in Win32 of course!)
                  > > does not exist in the PATH it will not complain and will think the
                  > > files are equal :-)
                  > > > > >
                  > > > > > My 10c :P
                  > > > > > Pedro
                  > > > > >
                  > > > >
                  > > > > Hi Pedro,
                  > > > >
                  > > > > I have placed all of the fixed macro files (and changes) in the
                  > > following directory:
                  > > > >
                  > > > > http://www.jasspa. com/development/ patches-20091017 /
                  > > <http://www.jasspa. com/development/ patches-20091017 />
                  > > > >
                  > > > > There is also an update to the gdiff which should be the last.
                  > > > >
                  > > > > Regards
                  > > > > Jon.
                  > > > >
                  > > >
                  > >
                  > >
                  >

                • azynheira
                  That s perfect Steve! :-) Thanks All! Pedro
                  Message 9 of 14 , Oct 21, 2009
                    That's perfect Steve! :-)
                    Thanks All!
                    Pedro
                    --- In jasspa@yahoogroups.com, Steven Phillips <bill@...> wrote:
                    >
                    > What a simple solution! I had wondered how to get the error message
                    > visible on windows, a pause is just what we need. Please try the
                    > following change to get a 5sec pause:
                    >
                    > *** d:\me\macros\gdiff.emf.~0~ Wed Oct 21 08:49:44 2009
                    > --- d:\me\macros\gdiff.emf Wed Oct 21 10:24:29 2009
                    > ***************
                    > *** 923,935 ****
                    > set-variable #l1 $buffer-fname
                    > !else
                    > ; more than 2 files given - error
                    > ! ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                    > 0 quick-exit
                    > !endif
                    > next-buffer
                    > !until &seq $buffer-bname #l2
                    > !if &seq #l1 ""
                    > ! ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                    > !else
                    > gdiff #l0 #l1
                    > !endif
                    > --- 923,935 ----
                    > set-variable #l1 $buffer-fname
                    > !else
                    > ; more than 2 files given - error
                    > ! 5000 ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                    > 0 quick-exit
                    > !endif
                    > next-buffer
                    > !until &seq $buffer-bname #l2
                    > !if &seq #l1 ""
                    > ! 5000 ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                    > !else
                    > gdiff #l0 #l1
                    > !endif
                    > [EXIT 1]
                    >
                    >
                    > azynheira wrote:
                    > >
                    > >
                    > > Hi Steve,
                    > > This one works ok :-). The only thing missing is some pause in case of
                    > > error (the message in the modeline appears), instead of quick-exiting
                    > > to the OS. But I think we can live with it ...
                    > >
                    > > Regards,
                    > > Pedro
                    > >
                    > > --- In jasspa@yahoogroups.com <mailto:jasspa%40yahoogroups.com>,
                    > > Steven Phillips <bill@> wrote:
                    > > >
                    > > > Pedro,
                    > > >
                    > > > Could you please try the attached version, I've had a little hack...
                    > > >
                    > > > Steve
                    > > >
                    > > > azynheira wrote:
                    > > > >
                    > > > >
                    > > > > Hi Jon,
                    > > > > I tryed to use the gdiff from the command line with my huge toolbar
                    > > > > and the problem stays the same (I used the version in the
                    > > > > http://www.jasspa.com/development/patches-20091017/
                    > > <http://www.jasspa.com/development/patches-20091017/>
                    > > > > <http://www.jasspa.com/development/patches-20091017/
                    > > <http://www.jasspa.com/development/patches-20091017/>> directory.
                    > > > >
                    > > > > I'll try to debug the stuff and provide more accurate feedback.
                    > > > >
                    > > > > Regards,
                    > > > > Pedro
                    > > > >
                    > > > > --- In jasspa@yahoogroups.com <mailto:jasspa%40yahoogroups.com>
                    > > <mailto:jasspa%40yahoogroups.com>,
                    > > > > "azynheira" <pedro.gomes@> wrote:
                    > > > > >
                    > > > > > Hi Jon,
                    > > > > > I will give them a try and get back to you,
                    > > > > >
                    > > > > > Thanks,
                    > > > > > Pedro
                    > > > > >
                    > > > > > --- In jasspa@yahoogroups.com <mailto:jasspa%40yahoogroups.com>
                    > > <mailto:jasspa%40yahoogroups.com>, Jon
                    > > > > Green <jon@> wrote:
                    > > > > > >
                    > > > > > > azynheira wrote:
                    > > > > > > > Hello All,
                    > > > > > > > I've found some bug in gdiff :-)
                    > > > > > > > If I execute gdiff as an independent tool via:
                    > > > > > > > me "@gdiff" <old> <new>
                    > > > > > > > and I have the toolbar enabled, gdiff will never diff anything
                    > > > > and complain with the usual message "gdiff Error: usage <new> <old".
                    > > > > > > >
                    > > > > > > > If I disable the toolbar it will work perfectly. It seems gdiff
                    > > > > and toolbar do not mix together.
                    > > > > > > >
                    > > > > > > > Another minor problem is that if diff.exe (in Win32 of course!)
                    > > > > does not exist in the PATH it will not complain and will think the
                    > > > > files are equal :-)
                    > > > > > > >
                    > > > > > > > My 10c :P
                    > > > > > > > Pedro
                    > > > > > > >
                    > > > > > >
                    > > > > > > Hi Pedro,
                    > > > > > >
                    > > > > > > I have placed all of the fixed macro files (and changes) in the
                    > > > > following directory:
                    > > > > > >
                    > > > > > > http://www.jasspa.com/development/patches-20091017/
                    > > <http://www.jasspa.com/development/patches-20091017/>
                    > > > > <http://www.jasspa.com/development/patches-20091017/
                    > > <http://www.jasspa.com/development/patches-20091017/>>
                    > > > > > >
                    > > > > > > There is also an update to the gdiff which should be the last.
                    > > > > > >
                    > > > > > > Regards
                    > > > > > > Jon.
                    > > > > > >
                    > > > > >
                    > > > >
                    > > > >
                    > > >
                    > >
                    > >
                    >
                  • azynheira
                    Hi All, I was quite happy with the proposed solution, until I have tryed it in Linux. The old problem occurs - Tryed it with tcsh or bash, with or without
                    Message 10 of 14 , Oct 21, 2009
                      Hi All,
                      I was quite happy with the proposed solution, until I have tryed it in Linux.

                      The old problem occurs - Tryed it with tcsh or bash, with or without toolbar its exactly the same - No diff is possible.

                      I'm looking into it :-)

                      Regards,
                      Pedro

                      --- In jasspa@yahoogroups.com, "azynheira" <pedro.gomes@...> wrote:
                      >
                      > That's perfect Steve! :-)
                      > Thanks All!
                      > Pedro
                      > --- In jasspa@yahoogroups.com, Steven Phillips <bill@> wrote:
                      > >
                      > > What a simple solution! I had wondered how to get the error message
                      > > visible on windows, a pause is just what we need. Please try the
                      > > following change to get a 5sec pause:
                      > >
                      > > *** d:\me\macros\gdiff.emf.~0~ Wed Oct 21 08:49:44 2009
                      > > --- d:\me\macros\gdiff.emf Wed Oct 21 10:24:29 2009
                      > > ***************
                      > > *** 923,935 ****
                      > > set-variable #l1 $buffer-fname
                      > > !else
                      > > ; more than 2 files given - error
                      > > ! ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                      > > 0 quick-exit
                      > > !endif
                      > > next-buffer
                      > > !until &seq $buffer-bname #l2
                      > > !if &seq #l1 ""
                      > > ! ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                      > > !else
                      > > gdiff #l0 #l1
                      > > !endif
                      > > --- 923,935 ----
                      > > set-variable #l1 $buffer-fname
                      > > !else
                      > > ; more than 2 files given - error
                      > > ! 5000 ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                      > > 0 quick-exit
                      > > !endif
                      > > next-buffer
                      > > !until &seq $buffer-bname #l2
                      > > !if &seq #l1 ""
                      > > ! 5000 ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                      > > !else
                      > > gdiff #l0 #l1
                      > > !endif
                      > > [EXIT 1]
                      > >
                      > >
                      > > azynheira wrote:
                      > > >
                      > > >
                      > > > Hi Steve,
                      > > > This one works ok :-). The only thing missing is some pause in case of
                      > > > error (the message in the modeline appears), instead of quick-exiting
                      > > > to the OS. But I think we can live with it ...
                      > > >
                      > > > Regards,
                      > > > Pedro
                      > > >
                      > > > --- In jasspa@yahoogroups.com <mailto:jasspa%40yahoogroups.com>,
                      > > > Steven Phillips <bill@> wrote:
                      > > > >
                      > > > > Pedro,
                      > > > >
                      > > > > Could you please try the attached version, I've had a little hack...
                      > > > >
                      > > > > Steve
                      > > > >
                      > > > > azynheira wrote:
                      > > > > >
                      > > > > >
                      > > > > > Hi Jon,
                      > > > > > I tryed to use the gdiff from the command line with my huge toolbar
                      > > > > > and the problem stays the same (I used the version in the
                      > > > > > http://www.jasspa.com/development/patches-20091017/
                      > > > <http://www.jasspa.com/development/patches-20091017/>
                      > > > > > <http://www.jasspa.com/development/patches-20091017/
                      > > > <http://www.jasspa.com/development/patches-20091017/>> directory.
                      > > > > >
                      > > > > > I'll try to debug the stuff and provide more accurate feedback.
                      > > > > >
                      > > > > > Regards,
                      > > > > > Pedro
                      > > > > >
                      > > > > > --- In jasspa@yahoogroups.com <mailto:jasspa%40yahoogroups.com>
                      > > > <mailto:jasspa%40yahoogroups.com>,
                      > > > > > "azynheira" <pedro.gomes@> wrote:
                      > > > > > >
                      > > > > > > Hi Jon,
                      > > > > > > I will give them a try and get back to you,
                      > > > > > >
                      > > > > > > Thanks,
                      > > > > > > Pedro
                      > > > > > >
                      > > > > > > --- In jasspa@yahoogroups.com <mailto:jasspa%40yahoogroups.com>
                      > > > <mailto:jasspa%40yahoogroups.com>, Jon
                      > > > > > Green <jon@> wrote:
                      > > > > > > >
                      > > > > > > > azynheira wrote:
                      > > > > > > > > Hello All,
                      > > > > > > > > I've found some bug in gdiff :-)
                      > > > > > > > > If I execute gdiff as an independent tool via:
                      > > > > > > > > me "@gdiff" <old> <new>
                      > > > > > > > > and I have the toolbar enabled, gdiff will never diff anything
                      > > > > > and complain with the usual message "gdiff Error: usage <new> <old".
                      > > > > > > > >
                      > > > > > > > > If I disable the toolbar it will work perfectly. It seems gdiff
                      > > > > > and toolbar do not mix together.
                      > > > > > > > >
                      > > > > > > > > Another minor problem is that if diff.exe (in Win32 of course!)
                      > > > > > does not exist in the PATH it will not complain and will think the
                      > > > > > files are equal :-)
                      > > > > > > > >
                      > > > > > > > > My 10c :P
                      > > > > > > > > Pedro
                      > > > > > > > >
                      > > > > > > >
                      > > > > > > > Hi Pedro,
                      > > > > > > >
                      > > > > > > > I have placed all of the fixed macro files (and changes) in the
                      > > > > > following directory:
                      > > > > > > >
                      > > > > > > > http://www.jasspa.com/development/patches-20091017/
                      > > > <http://www.jasspa.com/development/patches-20091017/>
                      > > > > > <http://www.jasspa.com/development/patches-20091017/
                      > > > <http://www.jasspa.com/development/patches-20091017/>>
                      > > > > > > >
                      > > > > > > > There is also an update to the gdiff which should be the last.
                      > > > > > > >
                      > > > > > > > Regards
                      > > > > > > > Jon.
                      > > > > > > >
                      > > > > > >
                      > > > > >
                      > > > > >
                      > > > >
                      > > >
                      > > >
                      > >
                      >
                    • Steven Phillips
                      Can you try running your diff on the command-line, i.e. the gdiff command-line is diff -c -w (unless you have changed it via the %gdiff-com
                      Message 11 of 14 , Oct 22, 2009
                        Can you try running your diff on the command-line, i.e. the gdiff command-line is 'diff -c -w <file1> <file2>' (unless you have changed it via the %gdiff-com variable). Does this work on your Linux box? And is the output similar in format to your windows one (which works so must be a diff which supports -w -c)? If not this is the likely issue,

                        Steve

                        azynheira wrote:
                         

                        Hi All,
                        I was quite happy with the proposed solution, until I have tryed it in Linux.

                        The old problem occurs - Tryed it with tcsh or bash, with or without toolbar its exactly the same - No diff is possible.

                        I'm looking into it :-)

                        Regards,
                        Pedro

                        --- In jasspa@yahoogroups. com, "azynheira" <pedro.gomes@ ...> wrote:
                        >
                        > That's perfect Steve! :-)
                        > Thanks All!
                        > Pedro
                        > --- In jasspa@yahoogroups. com, Steven Phillips <bill@> wrote:
                        > >
                        > > What a simple solution! I had wondered how to get the error message
                        > > visible on windows, a pause is just what we need. Please try the
                        > > following change to get a 5sec pause:
                        > >
                        > > *** d:\me\macros\ gdiff.emf. ~0~ Wed Oct 21 08:49:44 2009
                        > > --- d:\me\macros\ gdiff.emf Wed Oct 21 10:24:29 2009
                        > > ************ ***
                        > > *** 923,935 ****
                        > > set-variable #l1 $buffer-fname
                        > > !else
                        > > ; more than 2 files given - error
                        > > ! ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                        > > 0 quick-exit
                        > > !endif
                        > > next-buffer
                        > > !until &seq $buffer-bname #l2
                        > > !if &seq #l1 ""
                        > > ! ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                        > > !else
                        > > gdiff #l0 #l1
                        > > !endif
                        > > --- 923,935 ----
                        > > set-variable #l1 $buffer-fname
                        > > !else
                        > > ; more than 2 files given - error
                        > > ! 5000 ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                        > > 0 quick-exit
                        > > !endif
                        > > next-buffer
                        > > !until &seq $buffer-bname #l2
                        > > !if &seq #l1 ""
                        > > ! 5000 ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                        > > !else
                        > > gdiff #l0 #l1
                        > > !endif
                        > > [EXIT 1]
                        > >
                        > >
                        > > azynheira wrote:
                        > > >
                        > > >
                        > > > Hi Steve,
                        > > > This one works ok :-). The only thing missing is some pause in case of
                        > > > error (the message in the modeline appears), instead of quick-exiting
                        > > > to the OS. But I think we can live with it ...
                        > > >
                        > > > Regards,
                        > > > Pedro
                        > > >
                        > > > --- In jasspa@yahoogroups. com <mailto:jasspa% 40yahoogroups. com>,
                        > > > Steven Phillips <bill@> wrote:
                        > > > >
                        > > > > Pedro,
                        > > > >
                        > > > > Could you please try the attached version, I've had a little hack...
                        > > > >
                        > > > > Steve
                        > > > >
                        > > > > azynheira wrote:
                        > > > > >
                        > > > > >
                        > > > > > Hi Jon,
                        > > > > > I tryed to use the gdiff from the command line with my huge toolbar
                        > > > > > and the problem stays the same (I used the version in the
                        > > > > > http://www.jasspa. com/development/ patches-20091017 /
                        > > > <http://www.jasspa. com/development/ patches-20091017 />
                        > > > > > <http://www.jasspa. com/development/ patches-20091017 /
                        > > > <http://www.jasspa. com/development/ patches-20091017 />> directory.
                        > > > > >
                        > > > > > I'll try to debug the stuff and provide more accurate feedback.
                        > > > > >
                        > > > > > Regards,
                        > > > > > Pedro
                        > > > > >
                        > > > > > --- In jasspa@yahoogroups. com <mailto:jasspa% 40yahoogroups. com>
                        > > > <mailto:jasspa% 40yahoogroups. com>,
                        > > > > > "azynheira" <pedro.gomes@ > wrote:
                        > > > > > >
                        > > > > > > Hi Jon,
                        > > > > > > I will give them a try and get back to you,
                        > > > > > >
                        > > > > > > Thanks,
                        > > > > > > Pedro
                        > > > > > >
                        > > > > > > --- In jasspa@yahoogroups. com <mailto:jasspa% 40yahoogroups. com>
                        > > > <mailto:jasspa% 40yahoogroups. com>, Jon
                        > > > > > Green <jon@> wrote:
                        > > > > > > >
                        > > > > > > > azynheira wrote:
                        > > > > > > > > Hello All,
                        > > > > > > > > I've found some bug in gdiff :-)
                        > > > > > > > > If I execute gdiff as an independent tool via:
                        > > > > > > > > me "@gdiff" <old> <new>
                        > > > > > > > > and I have the toolbar enabled, gdiff will never diff anything
                        > > > > > and complain with the usual message "gdiff Error: usage <new> <old".
                        > > > > > > > >
                        > > > > > > > > If I disable the toolbar it will work perfectly. It seems gdiff
                        > > > > > and toolbar do not mix together.
                        > > > > > > > >
                        > > > > > > > > Another minor problem is that if diff.exe (in Win32 of course!)
                        > > > > > does not exist in the PATH it will not complain and will think the
                        > > > > > files are equal :-)
                        > > > > > > > >
                        > > > > > > > > My 10c :P
                        > > > > > > > > Pedro
                        > > > > > > > >
                        > > > > > > >
                        > > > > > > > Hi Pedro,
                        > > > > > > >
                        > > > > > > > I have placed all of the fixed macro files (and changes) in the
                        > > > > > following directory:
                        > > > > > > >
                        > > > > > > > http://www.jasspa. com/development/ patches-20091017 /
                        > > > <http://www.jasspa. com/development/ patches-20091017 />
                        > > > > > <http://www.jasspa. com/development/ patches-20091017 /
                        > > > <http://www.jasspa. com/development/ patches-20091017 />>
                        > > > > > > >
                        > > > > > > > There is also an update to the gdiff which should be the last.
                        > > > > > > >
                        > > > > > > > Regards
                        > > > > > > > Jon.
                        > > > > > > >
                        > > > > > >
                        > > > > >
                        > > > > >
                        > > > >
                        > > >
                        > > >
                        > >
                        >

                      • azynheira
                        Hi Steve, I already did it. The format seems to be the same in Windows and Linux albeit the versions mismtach. It s version 2.8.1 for Linux and 2.7 for
                        Message 12 of 14 , Oct 22, 2009
                          Hi Steve,
                          I already did it. The format seems to be the same in Windows and Linux albeit the versions mismtach. It's version 2.8.1 for Linux and 2.7 for Windows.

                          I'll investigate and keep you postedg

                          Regards,
                          Pedro

                          --- In jasspa@yahoogroups.com, Steven Phillips <bill@...> wrote:
                          >
                          > Can you try running your diff on the command-line, i.e. the gdiff
                          > command-line is 'diff -c -w <file1> <file2>' (unless you have changed it
                          > via the %gdiff-com variable). Does this work on your Linux box? And is
                          > the output similar in format to your windows one (which works so must be
                          > a diff which supports -w -c)? If not this is the likely issue,
                          >
                          > Steve
                          >
                          > azynheira wrote:
                          > >
                          > >
                          > > Hi All,
                          > > I was quite happy with the proposed solution, until I have tryed it in
                          > > Linux.
                          > >
                          > > The old problem occurs - Tryed it with tcsh or bash, with or without
                          > > toolbar its exactly the same - No diff is possible.
                          > >
                          > > I'm looking into it :-)
                          > >
                          > > Regards,
                          > > Pedro
                          > >
                          > > --- In jasspa@yahoogroups.com <mailto:jasspa%40yahoogroups.com>,
                          > > "azynheira" <pedro.gomes@> wrote:
                          > > >
                          > > > That's perfect Steve! :-)
                          > > > Thanks All!
                          > > > Pedro
                          > > > --- In jasspa@yahoogroups.com <mailto:jasspa%40yahoogroups.com>,
                          > > Steven Phillips <bill@> wrote:
                          > > > >
                          > > > > What a simple solution! I had wondered how to get the error message
                          > > > > visible on windows, a pause is just what we need. Please try the
                          > > > > following change to get a 5sec pause:
                          > > > >
                          > > > > *** d:\me\macros\gdiff.emf.~0~ Wed Oct 21 08:49:44 2009
                          > > > > --- d:\me\macros\gdiff.emf Wed Oct 21 10:24:29 2009
                          > > > > ***************
                          > > > > *** 923,935 ****
                          > > > > set-variable #l1 $buffer-fname
                          > > > > !else
                          > > > > ; more than 2 files given - error
                          > > > > ! ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                          > > > > 0 quick-exit
                          > > > > !endif
                          > > > > next-buffer
                          > > > > !until &seq $buffer-bname #l2
                          > > > > !if &seq #l1 ""
                          > > > > ! ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                          > > > > !else
                          > > > > gdiff #l0 #l1
                          > > > > !endif
                          > > > > --- 923,935 ----
                          > > > > set-variable #l1 $buffer-fname
                          > > > > !else
                          > > > > ; more than 2 files given - error
                          > > > > ! 5000 ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                          > > > > 0 quick-exit
                          > > > > !endif
                          > > > > next-buffer
                          > > > > !until &seq $buffer-bname #l2
                          > > > > !if &seq #l1 ""
                          > > > > ! 5000 ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                          > > > > !else
                          > > > > gdiff #l0 #l1
                          > > > > !endif
                          > > > > [EXIT 1]
                          > > > >
                          > > > >
                          > > > > azynheira wrote:
                          > > > > >
                          > > > > >
                          > > > > > Hi Steve,
                          > > > > > This one works ok :-). The only thing missing is some pause in
                          > > case of
                          > > > > > error (the message in the modeline appears), instead of
                          > > quick-exiting
                          > > > > > to the OS. But I think we can live with it ...
                          > > > > >
                          > > > > > Regards,
                          > > > > > Pedro
                          > > > > >
                          > > > > > --- In jasspa@yahoogroups.com <mailto:jasspa%40yahoogroups.com>
                          > > <mailto:jasspa%40yahoogroups.com>,
                          > > > > > Steven Phillips <bill@> wrote:
                          > > > > > >
                          > > > > > > Pedro,
                          > > > > > >
                          > > > > > > Could you please try the attached version, I've had a little
                          > > hack...
                          > > > > > >
                          > > > > > > Steve
                          > > > > > >
                          > > > > > > azynheira wrote:
                          > > > > > > >
                          > > > > > > >
                          > > > > > > > Hi Jon,
                          > > > > > > > I tryed to use the gdiff from the command line with my huge
                          > > toolbar
                          > > > > > > > and the problem stays the same (I used the version in the
                          > > > > > > > http://www.jasspa.com/development/patches-20091017/
                          > > <http://www.jasspa.com/development/patches-20091017/>
                          > > > > > <http://www.jasspa.com/development/patches-20091017/
                          > > <http://www.jasspa.com/development/patches-20091017/>>
                          > > > > > > > <http://www.jasspa.com/development/patches-20091017/
                          > > <http://www.jasspa.com/development/patches-20091017/>
                          > > > > > <http://www.jasspa.com/development/patches-20091017/
                          > > <http://www.jasspa.com/development/patches-20091017/>>> directory.
                          > > > > > > >
                          > > > > > > > I'll try to debug the stuff and provide more accurate feedback.
                          > > > > > > >
                          > > > > > > > Regards,
                          > > > > > > > Pedro
                          > > > > > > >
                          > > > > > > > --- In jasspa@yahoogroups.com
                          > > <mailto:jasspa%40yahoogroups.com> <mailto:jasspa%40yahoogroups.com>
                          > > > > > <mailto:jasspa%40yahoogroups.com>,
                          > > > > > > > "azynheira" <pedro.gomes@> wrote:
                          > > > > > > > >
                          > > > > > > > > Hi Jon,
                          > > > > > > > > I will give them a try and get back to you,
                          > > > > > > > >
                          > > > > > > > > Thanks,
                          > > > > > > > > Pedro
                          > > > > > > > >
                          > > > > > > > > --- In jasspa@yahoogroups.com
                          > > <mailto:jasspa%40yahoogroups.com> <mailto:jasspa%40yahoogroups.com>
                          > > > > > <mailto:jasspa%40yahoogroups.com>, Jon
                          > > > > > > > Green <jon@> wrote:
                          > > > > > > > > >
                          > > > > > > > > > azynheira wrote:
                          > > > > > > > > > > Hello All,
                          > > > > > > > > > > I've found some bug in gdiff :-)
                          > > > > > > > > > > If I execute gdiff as an independent tool via:
                          > > > > > > > > > > me "@gdiff" <old> <new>
                          > > > > > > > > > > and I have the toolbar enabled, gdiff will never diff
                          > > anything
                          > > > > > > > and complain with the usual message "gdiff Error: usage
                          > > <new> <old".
                          > > > > > > > > > >
                          > > > > > > > > > > If I disable the toolbar it will work perfectly. It
                          > > seems gdiff
                          > > > > > > > and toolbar do not mix together.
                          > > > > > > > > > >
                          > > > > > > > > > > Another minor problem is that if diff.exe (in Win32 of
                          > > course!)
                          > > > > > > > does not exist in the PATH it will not complain and will
                          > > think the
                          > > > > > > > files are equal :-)
                          > > > > > > > > > >
                          > > > > > > > > > > My 10c :P
                          > > > > > > > > > > Pedro
                          > > > > > > > > > >
                          > > > > > > > > >
                          > > > > > > > > > Hi Pedro,
                          > > > > > > > > >
                          > > > > > > > > > I have placed all of the fixed macro files (and changes)
                          > > in the
                          > > > > > > > following directory:
                          > > > > > > > > >
                          > > > > > > > > > http://www.jasspa.com/development/patches-20091017/
                          > > <http://www.jasspa.com/development/patches-20091017/>
                          > > > > > <http://www.jasspa.com/development/patches-20091017/
                          > > <http://www.jasspa.com/development/patches-20091017/>>
                          > > > > > > > <http://www.jasspa.com/development/patches-20091017/
                          > > <http://www.jasspa.com/development/patches-20091017/>
                          > > > > > <http://www.jasspa.com/development/patches-20091017/
                          > > <http://www.jasspa.com/development/patches-20091017/>>>
                          > > > > > > > > >
                          > > > > > > > > > There is also an update to the gdiff which should be the
                          > > last.
                          > > > > > > > > >
                          > > > > > > > > > Regards
                          > > > > > > > > > Jon.
                          > > > > > > > > >
                          > > > > > > > >
                          > > > > > > >
                          > > > > > > >
                          > > > > > >
                          > > > > >
                          > > > > >
                          > > > >
                          > > >
                          > >
                          > >
                          >
                        • azynheira
                          Hi again, I humbly take back what I stated before. I tryed on my Ubuntu box at home and it seems to be ok. Dont really understand what s going in the office
                          Message 13 of 14 , Oct 22, 2009
                            Hi again,
                            I humbly take back what I stated before. I tryed on my Ubuntu box at home and it seems to be ok. Dont really understand what's going in the office machine.

                            I have not 10cents this time :P
                            Pedro


                            --- In jasspa@yahoogroups.com, "azynheira" <pedro.gomes@...> wrote:
                            >
                            > Hi Steve,
                            > I already did it. The format seems to be the same in Windows and Linux albeit the versions mismtach. It's version 2.8.1 for Linux and 2.7 for Windows.
                            >
                            > I'll investigate and keep you postedg
                            >
                            > Regards,
                            > Pedro
                            >
                            > --- In jasspa@yahoogroups.com, Steven Phillips <bill@> wrote:
                            > >
                            > > Can you try running your diff on the command-line, i.e. the gdiff
                            > > command-line is 'diff -c -w <file1> <file2>' (unless you have changed it
                            > > via the %gdiff-com variable). Does this work on your Linux box? And is
                            > > the output similar in format to your windows one (which works so must be
                            > > a diff which supports -w -c)? If not this is the likely issue,
                            > >
                            > > Steve
                            > >
                            > > azynheira wrote:
                            > > >
                            > > >
                            > > > Hi All,
                            > > > I was quite happy with the proposed solution, until I have tryed it in
                            > > > Linux.
                            > > >
                            > > > The old problem occurs - Tryed it with tcsh or bash, with or without
                            > > > toolbar its exactly the same - No diff is possible.
                            > > >
                            > > > I'm looking into it :-)
                            > > >
                            > > > Regards,
                            > > > Pedro
                            > > >
                            > > > --- In jasspa@yahoogroups.com <mailto:jasspa%40yahoogroups.com>,
                            > > > "azynheira" <pedro.gomes@> wrote:
                            > > > >
                            > > > > That's perfect Steve! :-)
                            > > > > Thanks All!
                            > > > > Pedro
                            > > > > --- In jasspa@yahoogroups.com <mailto:jasspa%40yahoogroups.com>,
                            > > > Steven Phillips <bill@> wrote:
                            > > > > >
                            > > > > > What a simple solution! I had wondered how to get the error message
                            > > > > > visible on windows, a pause is just what we need. Please try the
                            > > > > > following change to get a 5sec pause:
                            > > > > >
                            > > > > > *** d:\me\macros\gdiff.emf.~0~ Wed Oct 21 08:49:44 2009
                            > > > > > --- d:\me\macros\gdiff.emf Wed Oct 21 10:24:29 2009
                            > > > > > ***************
                            > > > > > *** 923,935 ****
                            > > > > > set-variable #l1 $buffer-fname
                            > > > > > !else
                            > > > > > ; more than 2 files given - error
                            > > > > > ! ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                            > > > > > 0 quick-exit
                            > > > > > !endif
                            > > > > > next-buffer
                            > > > > > !until &seq $buffer-bname #l2
                            > > > > > !if &seq #l1 ""
                            > > > > > ! ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                            > > > > > !else
                            > > > > > gdiff #l0 #l1
                            > > > > > !endif
                            > > > > > --- 923,935 ----
                            > > > > > set-variable #l1 $buffer-fname
                            > > > > > !else
                            > > > > > ; more than 2 files given - error
                            > > > > > ! 5000 ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                            > > > > > 0 quick-exit
                            > > > > > !endif
                            > > > > > next-buffer
                            > > > > > !until &seq $buffer-bname #l2
                            > > > > > !if &seq #l1 ""
                            > > > > > ! 5000 ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
                            > > > > > !else
                            > > > > > gdiff #l0 #l1
                            > > > > > !endif
                            > > > > > [EXIT 1]
                            > > > > >
                            > > > > >
                            > > > > > azynheira wrote:
                            > > > > > >
                            > > > > > >
                            > > > > > > Hi Steve,
                            > > > > > > This one works ok :-). The only thing missing is some pause in
                            > > > case of
                            > > > > > > error (the message in the modeline appears), instead of
                            > > > quick-exiting
                            > > > > > > to the OS. But I think we can live with it ...
                            > > > > > >
                            > > > > > > Regards,
                            > > > > > > Pedro
                            > > > > > >
                            > > > > > > --- In jasspa@yahoogroups.com <mailto:jasspa%40yahoogroups.com>
                            > > > <mailto:jasspa%40yahoogroups.com>,
                            > > > > > > Steven Phillips <bill@> wrote:
                            > > > > > > >
                            > > > > > > > Pedro,
                            > > > > > > >
                            > > > > > > > Could you please try the attached version, I've had a little
                            > > > hack...
                            > > > > > > >
                            > > > > > > > Steve
                            > > > > > > >
                            > > > > > > > azynheira wrote:
                            > > > > > > > >
                            > > > > > > > >
                            > > > > > > > > Hi Jon,
                            > > > > > > > > I tryed to use the gdiff from the command line with my huge
                            > > > toolbar
                            > > > > > > > > and the problem stays the same (I used the version in the
                            > > > > > > > > http://www.jasspa.com/development/patches-20091017/
                            > > > <http://www.jasspa.com/development/patches-20091017/>
                            > > > > > > <http://www.jasspa.com/development/patches-20091017/
                            > > > <http://www.jasspa.com/development/patches-20091017/>>
                            > > > > > > > > <http://www.jasspa.com/development/patches-20091017/
                            > > > <http://www.jasspa.com/development/patches-20091017/>
                            > > > > > > <http://www.jasspa.com/development/patches-20091017/
                            > > > <http://www.jasspa.com/development/patches-20091017/>>> directory.
                            > > > > > > > >
                            > > > > > > > > I'll try to debug the stuff and provide more accurate feedback.
                            > > > > > > > >
                            > > > > > > > > Regards,
                            > > > > > > > > Pedro
                            > > > > > > > >
                            > > > > > > > > --- In jasspa@yahoogroups.com
                            > > > <mailto:jasspa%40yahoogroups.com> <mailto:jasspa%40yahoogroups.com>
                            > > > > > > <mailto:jasspa%40yahoogroups.com>,
                            > > > > > > > > "azynheira" <pedro.gomes@> wrote:
                            > > > > > > > > >
                            > > > > > > > > > Hi Jon,
                            > > > > > > > > > I will give them a try and get back to you,
                            > > > > > > > > >
                            > > > > > > > > > Thanks,
                            > > > > > > > > > Pedro
                            > > > > > > > > >
                            > > > > > > > > > --- In jasspa@yahoogroups.com
                            > > > <mailto:jasspa%40yahoogroups.com> <mailto:jasspa%40yahoogroups.com>
                            > > > > > > <mailto:jasspa%40yahoogroups.com>, Jon
                            > > > > > > > > Green <jon@> wrote:
                            > > > > > > > > > >
                            > > > > > > > > > > azynheira wrote:
                            > > > > > > > > > > > Hello All,
                            > > > > > > > > > > > I've found some bug in gdiff :-)
                            > > > > > > > > > > > If I execute gdiff as an independent tool via:
                            > > > > > > > > > > > me "@gdiff" <old> <new>
                            > > > > > > > > > > > and I have the toolbar enabled, gdiff will never diff
                            > > > anything
                            > > > > > > > > and complain with the usual message "gdiff Error: usage
                            > > > <new> <old".
                            > > > > > > > > > > >
                            > > > > > > > > > > > If I disable the toolbar it will work perfectly. It
                            > > > seems gdiff
                            > > > > > > > > and toolbar do not mix together.
                            > > > > > > > > > > >
                            > > > > > > > > > > > Another minor problem is that if diff.exe (in Win32 of
                            > > > course!)
                            > > > > > > > > does not exist in the PATH it will not complain and will
                            > > > think the
                            > > > > > > > > files are equal :-)
                            > > > > > > > > > > >
                            > > > > > > > > > > > My 10c :P
                            > > > > > > > > > > > Pedro
                            > > > > > > > > > > >
                            > > > > > > > > > >
                            > > > > > > > > > > Hi Pedro,
                            > > > > > > > > > >
                            > > > > > > > > > > I have placed all of the fixed macro files (and changes)
                            > > > in the
                            > > > > > > > > following directory:
                            > > > > > > > > > >
                            > > > > > > > > > > http://www.jasspa.com/development/patches-20091017/
                            > > > <http://www.jasspa.com/development/patches-20091017/>
                            > > > > > > <http://www.jasspa.com/development/patches-20091017/
                            > > > <http://www.jasspa.com/development/patches-20091017/>>
                            > > > > > > > > <http://www.jasspa.com/development/patches-20091017/
                            > > > <http://www.jasspa.com/development/patches-20091017/>
                            > > > > > > <http://www.jasspa.com/development/patches-20091017/
                            > > > <http://www.jasspa.com/development/patches-20091017/>>>
                            > > > > > > > > > >
                            > > > > > > > > > > There is also an update to the gdiff which should be the
                            > > > last.
                            > > > > > > > > > >
                            > > > > > > > > > > Regards
                            > > > > > > > > > > Jon.
                            > > > > > > > > > >
                            > > > > > > > > >
                            > > > > > > > >
                            > > > > > > > >
                            > > > > > > >
                            > > > > > >
                            > > > > > >
                            > > > > >
                            > > > >
                            > > >
                            > > >
                            > >
                            >
                          Your message has been successfully submitted and would be delivered to recipients shortly.