Loading ...
Sorry, an error occurred while loading the content.

Re: [jasspa] 20090909 Linux, window height = entire screen

Expand Messages
  • Jon Green
    ... Hi Tom, Attached is a fix. Regards Jon.
    Message 1 of 7 , Sep 26, 2009
    • 1 Attachment
    • 4 KB
    Tom Hundt wrote:
    > Hi, I'm having the following issue running the 20090909 release on CentOS Linux.
    >
    > Upon running the X11 version of the program, the window height expands
    > to fill the entire screen, top to bottom. $frame-depth gets set
    > accordingly (79, in my case).
    >
    > And, even weirder, the width. The first time it might be at 80, then
    > when I exit and rerun it, it's 67, then like 30, then like 20, then
    > like 8, then goes back to 80. Strange!
    >
    > It also resets to a tall+skinny size when I switch color schemes. I
    > think it does a general "reset" of the display part of things when you
    > switch schemes. It's this resetting that is guessing the size
    > parameters wrong.
    >
    > It does it even without running company files. (I.e., just the
    > default macros.) But, if I run the binary from the build directory
    > (i.e., MEPATH not set, so it can't find *any* of the macro files), it
    > works okay (and complains it can't find "me" i.e., me.emf -- as
    > expected.). So, right now I'm guessing it's something in the macro
    > files and/or the registry that's causing the problem.
    >
    > Q. How do you find out what the current registry file is? (in my case
    > typically ~/.jasspa/thundt.erf -- but how to confirm?) This doesn't
    > seem to be in any variable.
    >
    > I've been grepping for "-depth" (window-depth and frame-depth) in the
    > macro files but haven't figured out which one it is. I'm wondering if
    > it could be the registry. If I wipe mine out, it comes up with a
    > window 30 x <screen-height> with the user-setup page in it.
    >
    > Workaround is to manually set the $frame-depth to something
    > reasonable, or move+resize the window. (Actually I have a macro that
    > cycles through a few common width x depth combinations for me.)
    >
    > The weird thing about my setup is that it's a 3 monitors wide desktop.
    >
    > X11 client is Cygwin/X X Server 1.5.3 (20090222), ultimately on top of
    > WinXP latest updates.
    >
    > Linux info is this:
    > Linux <hostname_removed> 2.6.18-128.1.10.el5xen #1 SMP Thu May 7
    > 11:07:18 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
    >
    > Any ideas?
    >
    > Thanks,
    >

    Hi Tom,

    Attached is a fix.

    Regards
    Jon.
  • Tom Hundt
    Thanks. I agree, I bet the x server is giving it a wrong value. It s almost like they were reversed, or something. -Tom ... -- Thomas Hundt
    Message 2 of 7 , Sep 26, 2009
    • 0 Attachment
      Thanks. I agree, I bet the x server is giving it a wrong value. It's
      almost like they were reversed, or something.

      -Tom

      On Saturday, September 26, 2009, Jon Green <jon@...> wrote:
      > Tom Hundt wrote:
      >> Hi, I'm having the following issue running the 20090909 release on CentOS Linux.
      >>
      >> Upon running the X11 version of the program, the window height expands
      >> to fill the entire screen, top to bottom.  $frame-depth gets set
      >> accordingly (79, in my case).
      >>
      >> And, even weirder, the width.  The first time it might be at 80, then
      >> when I exit and rerun it, it's 67, then like 30, then like 20, then
      >> like 8, then goes back to 80.  Strange!
      >>
      >> It also resets to a tall+skinny size when I switch color schemes.  I
      >> think it does a general "reset" of the display part of things when you
      >> switch schemes.  It's this resetting that is guessing the size
      >> parameters wrong.
      >>
      >> It does it even without running company files.  (I.e., just the
      >> default macros.)  But, if I run the binary from the build directory
      >> (i.e., MEPATH not set, so it can't find *any* of the macro files), it
      >> works okay (and complains it can't find "me" i.e., me.emf -- as
      >> expected.).  So, right now I'm guessing it's something in the macro
      >> files and/or the registry that's causing the problem.
      >>
      >> Q. How do you find out what the current registry file is?  (in my case
      >> typically ~/.jasspa/thundt.erf -- but how to confirm?)  This doesn't
      >> seem to be in any variable.
      >>
      >> I've been grepping for "-depth" (window-depth and frame-depth) in the
      >> macro files but haven't figured out which one it is.  I'm wondering if
      >> it could be the registry.  If I wipe mine out, it comes up with a
      >> window 30 x <screen-height> with the user-setup page in it.
      >>
      >> Workaround is to manually set the $frame-depth to something
      >> reasonable, or move+resize the window.  (Actually I have a macro that
      >> cycles through a few common width x depth combinations for me.)
      >>
      >> The weird thing about my setup is that it's a 3 monitors wide desktop.
      >>
      >> X11 client is Cygwin/X X Server 1.5.3 (20090222), ultimately on top of
      >> WinXP latest updates.
      >>
      >> Linux info is this:
      >> Linux <hostname_removed> 2.6.18-128.1.10.el5xen #1 SMP Thu May 7
      >> 11:07:18 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
      >>
      >> Any ideas?
      >>
      >> Thanks,
      >>
      >
      > Hi Tom,
      >
      > You are not alone. I have seen this on Ubuntu 9.04 as well and am trying
      > to figure out what it is. I don't think that there is a problem with
      > with the macros because I run on Solaris all of the time and never have
      > this problem. Solaris is well behaved, seems to be a new Linux thing.
      >
      > I have seen this problem on Linux even when I am using an .Xdefaults
      > file which should over-ride everything. However when I am running a ssh
      > -X session back to a Solaris X-Client then everything is fine again. Run
      > on native Linux then it can sometimes be fine and other times it can be
      > miss-behaved and like you say go full screen. Gut feeling is there is
      > something changed in Xorg which is causing a bad value to be returned
      > and messing things up.
      >
      > Will have to take this more seriously and see if I can track it down.
      > Glad to know it is not just me. Will keep you informed.
      >
      > Regards
      > Jon.
      >
      >
      >
      > ------------------------------------
      >
      > __________________________________________________________________________
      >
      > This is an unmoderated list, but new members are moderated to ensure that there are no spam users. JASSPA is not responsible for the content of
      > any material posted to this list.
      >
      > To un-subscribe, send a mail message to
      >
      >    mailto:jasspa-unsubscribe@yahoogroups.com
      >
      > or visit http://groups.yahoo.com/group/jasspa and
      > modify your account settings manually.
      >
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
      >

      --
      Thomas Hundt <tom@...> +1-415-867-6698
    • Jon Green
      ... Hi Tom, There is now a new source bundle on www.jasspa.com dated 20090926. The main fixes in this are: * Linux build fix with GCC 4.3.3 * Linux fix for
      Message 3 of 7 , Sep 26, 2009
      • 0 Attachment
        Tom Hundt wrote:
        > Thanks. I agree, I bet the x server is giving it a wrong value. It's
        > almost like they were reversed, or something.
        >
        > -Tom

        Hi Tom,

        There is now a new source bundle on www.jasspa.com dated 20090926. The
        main fixes in this are:

        * Linux build fix with GCC 4.3.3
        * Linux fix for X-Window size
        * Fix for ClearCase garbled data.

        I've also updated the Ubuntu 9.04 (Jaunty) package (guess where I was
        debugging).

        Regards
        Jon.
      • Tom Hundt
        Okay, re my strange resizing problem (super tall, super skinny windows) I ve figured it out. (It finally dawned on me to run me -v $debug=3 and just step
        Message 4 of 7 , Oct 6, 2009
        • 0 Attachment
          Okay, re my strange resizing problem (super tall, super skinny windows) I've figured it out.  (It finally dawned on me to run 'me -v\$debug=3' and just step through all the macros.)

          Line 391 of me.emf has this
              4 popup-window

          about which the manpage says

                  When  n is 4 then both the frame position and frame size on the Desktop
                  Window is adjusted, this is the same as  3 except the frame size may
                  also be adjusted to fit on the desktop. The  name argument is not
                  required.

          If I comment out the line, everything works great. :-)

          -Th


          On Sat, Sep 26, 2009 at 11:39 AM, Jon Green <jon@...> wrote:
          Tom Hundt wrote:
          > Thanks. I agree, I bet the x server is giving it a wrong value. It's
          > almost like they were reversed, or something.
          >
          > -Tom

          Hi Tom,

          There is now a new source bundle on www.jasspa.com dated 20090926. The
          main fixes in this are:

          * Linux build fix with GCC 4.3.3
          * Linux fix for X-Window size
          * Fix for ClearCase garbled data.

          I've also updated the Ubuntu 9.04 (Jaunty) package (guess where I was
          debugging).

          Regards
          Jon.


          ------------------------------------
          __
        • Jon Green
          ... Did you still have this problem with 20090926? Thanks Jon
          Message 5 of 7 , Oct 6, 2009
          • 0 Attachment
            On Tue 06/10/09 8:03 PM , "Tom Hundt" thundt@... sent:
            > Okay, re my strange resizing problem (super tall, super skinny
            > windows) I've figured it out.  (It finally dawned on me to run
            > 'me -v$debug=3' and just step through all the macros.)
            > Line 391 of me.emf has this     4 popup-window
            >
            > about which the manpage says
            >         When  n is 4 then both the frame position and frame
            > size on the Desktop        Window is adjusted, this is the same
            > as  3 except the frame size may         also be adjusted to fit
            > on the desktop. The  name argument is not        required.
            > If I comment out the line, everything works great. :-)
            > -Th
            >

            Did you still have this problem with 20090926?

            Thanks
            Jon

            > On Sat, Sep 26, 2009 at 11:39 AM, Jon Green wrote:
            > Tom Hundt wrote:
            > > Thanks. I agree, I bet the x server is giving it a wrong value.
            > It's
            > > almost like they were reversed, or something.
            > >
            > > -Tom
            > Hi Tom,
            > There is now a new source bundle on www.jasspa.com [2] dated
            > 20090926. The
            > main fixes in this are:
            > * Linux build fix with GCC 4.3.3
            > * Linux fix for X-Window size
            > * Fix for ClearCase garbled data.
            > I've also updated the Ubuntu 9.04 (Jaunty) package (guess where
            > I was
            > debugging).
            > Regards
            > Jon.
            > ------------------------------------
            > __
            >
            >
            > Links:
            > ------
            > [2] http://www.jasspa.com
            > [3] http://groups.yahoo.com/group/jasspa
            > [4]
            > http://groups.yahoo.com/group/jasspa/join;_ylc=X3oDMTJmaDcwZzY2BF9TAzk3NDc2
            > NTkwBGdycElkAzExODgwMzcEZ3Jwc3BJZAMxNzA1MDA0OTI0BHNlYwNmdHIEc2xrA3N0bmdzBHN
            > 0aW1lAzEyNTQ4NTIyMjc-[6]
            > http://groups.yahoo.com/group/jasspa;_ylc=X3oDMTJkamViNnZpBF9TAzk3NDc2NTkwB
            > GdycElkAzExODgwMzcEZ3Jwc3BJZAMxNzA1MDA0OTI0BHNlYwNmdHIEc2xrA2hwZgRzdGltZQMx
            > MjU0ODUyMjI3[7] http://docs.yahoo.com/info/terms/
            >
            >
            ---- Message sent via KC WebMail - http://webmail.mistral.net/
          Your message has been successfully submitted and would be delivered to recipients shortly.