Loading ...
Sorry, an error occurred while loading the content.

Re: [jasspa] HELP: Need some help from Debian packaging expert

Expand Messages
  • Jon Green
    ... I think I have sorted this out now and have uploaded some new images if somebody can give them a try. i.e. for me to install on my machine with the
    Message 1 of 2 , Sep 13, 2009
    • 0 Attachment
      Jon Green wrote:
      > Hi Christof (or anybody else)
      >
      > I've created set of Ubuntu 9.04 packages based on your original Debian
      > source script that I downloaded from your site.
      >
      > I have changed these to 20090909 (obviously) and fixed the rules for
      > jasspa-me which did not include Xpm in the build. I have also
      > restructured both of the packages so that they use /use/share/jasspa by
      > default and then there is no requirement to patch (also this is where
      > they should be). In addition I have added a jasspa-microemacs.desktop.
      > The problem I have at the moment I do not understand the .menu items and
      > am concerned that the .desktop installation will conflict with the .menu
      > item. Do you understand this enough to know if this is correct or
      > whether I need to change it further?
      >
      > Also I have changed me-jasspa-data so that it installs into
      > /usr/share/jasspa and is a multi-package and will also install the
      > spelling dictionaries (i.e. the package name is "me-jasspa-enus" for the
      > American dictionary etc.)
      >
      > For all packages there is now a
      >
      > make -f debian/rules get-orig-source
      >
      > which gets the original source bundle using wget.
      >
      > Because I am not an expert the basic commands I am using are:
      >
      > dpkg -i me-jasspa_0.0.20090909.deb # Install package
      > dpkg -r me-jasspa # Remove package
      > dpkg-buildpackage -rfakeroot -tc # Build
      > dpkg-deb -c me-jasspa_0.0.20090909.deb # Check
      >
      > The packages that I have built are available here for testing/comment.
      > DO NOT USE AT THE MOMENT UNTIL THEY ARE CONFIRMED.
      >
      > http://www.jasspa.com/release_20090909/debian/
      >
      > Also are you (Christof) able to continue to host them from your site or
      > do I need to set up a APT repository?
      >
      > Thanks
      > Jon
      >
      >

      I think I have sorted this out now and have uploaded some new images if
      somebody can give them a try. i.e. for me to install on my machine with
      the American + British spelling I need to download and install with:

      dpkg -i me-jasspa_0.0.20090909_i386.deb
      dpkg -i me-jasspa-data_0.0.20090909_all.deb
      dpkg -i me-jasspa-engb_0.0.20090909_all.deb
      dpkg -i me-jasspa-enus_0.0.20090909_all.deb

      Regards
      Jon
    Your message has been successfully submitted and would be delivered to recipients shortly.