Loading ...
Sorry, an error occurred while loading the content.

Re: [jasspa] problems with window size

Expand Messages
  • Jon Green
    ... Hi Christof, OK edit the *.erf and delete the lines frame-depth = 86 frame-width = 168 I think these are set when you right click on the toolbar
    Message 1 of 9 , May 16, 2009
    • 0 Attachment
      Christof Boeckler wrote:
      > Jon,
      >
      > thanks for your reply!
      > I tried your settings but they did not solve my problem although it has
      > some effect.
      > The problem seems to be at a different level because the settings in
      > .Xdefaults only have an effect if I start ME from a terminal. If I start
      > it through a keyboard shortcut it looks different (size, position).
      > I need to explore this further ...
      >
      > Christof

      Hi Christof,

      OK edit the *.erf and delete the lines

      "frame-depth" = "86"
      "frame-width" = "168"

      I think these are set when you right click on the toolbar line and there
      is an option called "Store Frame Size". I never use this so my values
      are not set in my .erf.

      Best to shut down all instances of "me" and then use gedit, ne or
      something to hack the .erf file to delete the lines. Then when you run
      up again the .Xdefaults will have priority.

      Hope that helps
      Jon.


      >
      > Jon Green schrieb:
      >> I use a .Xdefaults file when running on Sun Solaris as follows and have
      >> no problems as below.
      >>
      >> Jon.
      >>
      >> Dtwm*VCLSalFrame* secondariesOnTop : True
      >> !########### ######### ######### ######### ######### ######### #########
      >> #####
      >> !# #
      >> !# Defaults for MicroEmacs startup #
      >> !# #
      >> !########### ######### ######### ######### ######### ######### #########
      >> #####
      >> !# MicroEmacs.font: <fontname>
      >> !# Set the default font.
      >> !# MicroEmacs.font: -*-lucidatypewriter -medium-r- *-*-*-120- *-*-m-*-* -*
      >> MicroEmacs.font: -*-clean-medium- r-*-*-*-130- *-*-*-*-* -*
      >>
      >> !# MicroEmacs.geometry : <char-width> x<char-height> {+/-}<xoffset>
      >> {+-}<yoffset>
      >> !# Set up the default screen size and position.
      >> !# 102x65 characters please, 30 pixels from top left
      >> MicroEmacs.geometry : 102x65 30 30
      >>
      >> !# MicroEmacs.name: <name>
      >> !# The name displayed in the title bar format is <name>: <file>
      >> MicroEmacs.name: JASSPAs MicroEmacs
      >>
      >> !# MicroEmacs: <icon-name>
      >> !# The name displayed when MicroEmacs is iconized
      >> MicroEmacs.iconname : JASSPAs MicroEmacs
      >
      >
      > ------------------------------------
      >
      > __________________________________________________________________________
      >
      > This is an unmoderated list, but new members are moderated to ensure that there are no spam users. JASSPA is not responsible for the content of
      > any material posted to this list.
      >
      > To un-subscribe, send a mail message to
      >
      > mailto:jasspa-unsubscribe@yahoogroups.com
      >
      > or visit http://groups.yahoo.com/group/jasspa and
      > modify your account settings manually.
      >
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
    • Christof Boeckler
      ... Hi Jon, ... I deleted those now. ... I tried to narrow down the cause of my problems systematically and found out that settings in .Xdefaults have no
      Message 2 of 9 , May 17, 2009
      • 0 Attachment
        Jon Green schrieb:
        > Christof Boeckler wrote:
        >> Jon,
        >>
        >> thanks for your reply!
        >> I tried your settings but they did not solve my problem although it has
        >> some effect.
        >> The problem seems to be at a different level because the settings in
        >> .Xdefaults only have an effect if I start ME from a terminal. If I start
        >> it through a keyboard shortcut it looks different (size, position).
        >> I need to explore this further ...
        >>
        >> Christof
        >
        > Hi Christof,

        Hi Jon,

        > OK edit the *.erf and delete the lines
        >
        > "frame-depth" = "86"
        > "frame-width" = "168"

        I deleted those now.

        > Best to shut down all instances of "me" and then use gedit, ne or
        > something to hack the .erf file to delete the lines. Then when you run
        > up again the .Xdefaults will have priority.

        I tried to narrow down the cause of my problems systematically and found
        out that settings in .Xdefaults have no effect.
        Actually on my system the file .Xdefaults isn't even touched by ME (as
        strace tells me), only a file .Xdefaults-thinkpad (thinkpad is my
        hostname) is tried to be read (in accordance with X(7)). Setting up a
        symlink .Xdefaults-thinkpad -> .Xdefaults doesn't change the behaviour,
        although the file is read. (Your settings give me a 73x14+287+210 window.)

        I wonder what the interface for setting windows sizes is (in regard to
        the X server and/or window manager). With other applications (e.g.
        Mozilla Thunderbird) I can perfectly set up geometry properties through
        my window manager's configuration (similar to .Xdefaults). With ME it
        does not work.

        Is ME making any attempts to set its "window size" or is this totally up
        to the window manager? Who is responsible for placing and sizing the ME
        window? I really want this to be fixed.

        >
        > Hope that helps
        > Jon.

        Sorry, not yet.

        Christof
      • Jon Green
        ... The size is controlled by X-Windows via the X-Window resource management and the size hints. My guess is that the likes of Thunderbird etc. are controlled
        Message 3 of 9 , May 17, 2009
        • 0 Attachment
          Christof Boeckler wrote:
          > Jon Green schrieb:
          >> Christof Boeckler wrote:
          >>> Jon,
          >>>
          >>> thanks for your reply!
          >>> I tried your settings but they did not solve my problem although it has
          >>> some effect.
          >>> The problem seems to be at a different level because the settings in
          >>> .Xdefaults only have an effect if I start ME from a terminal. If I start
          >>> it through a keyboard shortcut it looks different (size, position).
          >>> I need to explore this further ...
          >>>
          >>> Christof
          >> Hi Christof,
          >
          > Hi Jon,
          >
          >> OK edit the *.erf and delete the lines
          >>
          >> "frame-depth" = "86"
          >> "frame-width" = "168"
          >
          > I deleted those now.
          >
          >> Best to shut down all instances of "me" and then use gedit, ne or
          >> something to hack the .erf file to delete the lines. Then when you run
          >> up again the .Xdefaults will have priority.
          >
          > I tried to narrow down the cause of my problems systematically and found
          > out that settings in .Xdefaults have no effect.
          > Actually on my system the file .Xdefaults isn't even touched by ME (as
          > strace tells me), only a file .Xdefaults-thinkpad (thinkpad is my
          > hostname) is tried to be read (in accordance with X(7)). Setting up a
          > symlink .Xdefaults-thinkpad -> .Xdefaults doesn't change the behaviour,
          > although the file is read. (Your settings give me a 73x14+287+210 window.)
          >
          > I wonder what the interface for setting windows sizes is (in regard to
          > the X server and/or window manager). With other applications (e.g.
          > Mozilla Thunderbird) I can perfectly set up geometry properties through
          > my window manager's configuration (similar to .Xdefaults). With ME it
          > does not work.
          >
          > Is ME making any attempts to set its "window size" or is this totally up
          > to the window manager? Who is responsible for placing and sizing the ME
          > window? I really want this to be fixed.

          The size is controlled by X-Windows via the X-Window resource management
          and the size hints. My guess is that the likes of Thunderbird etc. are
          controlled through some Gtk configuration rather than X-Windows.

          The code that does this is in unixterm.c in function XTERMstart(). me
          does not read the file directly, it is up to the window manager to
          retrieve this information and then return it.

          I cannot say that I have ever had a problem with this it has always
          worked for me on Solaris, HP-UX and SGI. Cannot recall for Linux because
          I do not use Linux much as a general working environment (I assume you
          are on Linux) but cannot recall a problem.

          For you to be using .Xdefaults-thinkpad then you must be running a
          remote desktop.

          I think you are going to have to trace this through, build a debug image
          and then break from XTERMstart tracing it through to see what X returns
          and how it is set up. Or use a few well chosen printf's temporarily to
          see what is going on.

          Regards
          Jon.

          >
          >> Hope that helps
          >> Jon.
          >
          > Sorry, not yet.
          >
          > Christof
          >
          >
          > ------------------------------------
          >
          > __________________________________________________________________________
          >
          > This is an unmoderated list, but new members are moderated to ensure that there are no spam users. JASSPA is not responsible for the content of
          > any material posted to this list.
          >
          > To un-subscribe, send a mail message to
          >
          > mailto:jasspa-unsubscribe@yahoogroups.com
          >
          > or visit http://groups.yahoo.com/group/jasspa and
          > modify your account settings manually.
          >
          >
          > Yahoo! Groups Links
          >
          >
          >
          >
        • Steven Phillips
          The X function call used to get the start-up geometry info is: XrmGetResource(rdb, MicroEmacs.geometry , MicroEmacs.Geometry ,&retType,&retVal) As Jon says,
          Message 4 of 9 , May 17, 2009
          • 0 Attachment
            The X function call used to get the start-up geometry info is:

                XrmGetResource(rdb,"MicroEmacs.geometry","MicroEmacs.Geometry",&retType,&retVal)

            As Jon says, the most likely cause is that Gtk is not honouring this original way of configuring X applications, have things moved on in the Linux world? So another possible way of resolving this is to find out what config files your Window manager does read and put a suitable configuration in one of those...

            Steve

            Jon Green wrote:

            Christof Boeckler wrote:
            > Jon Green schrieb:
            >> Christof Boeckler wrote:
            >>> Jon,
            >>>
            >>> thanks for your reply!
            >>> I tried your settings but they did not solve my problem although it has
            >>> some effect.
            >>> The problem seems to be at a different level because the settings in
            >>> .Xdefaults only have an effect if I start ME from a terminal. If I start
            >>> it through a keyboard shortcut it looks different (size, position).
            >>> I need to explore this further ...
            >>>
            >>> Christof
            >> Hi Christof,
            >
            > Hi Jon,
            >
            >> OK edit the *.erf and delete the lines
            >>
            >> "frame-depth" = "86"
            >> "frame-width" = "168"
            >
            > I deleted those now.
            >
            >> Best to shut down all instances of "me" and then use gedit, ne or
            >> something to hack the .erf file to delete the lines. Then when you run
            >> up again the .Xdefaults will have priority.
            >
            > I tried to narrow down the cause of my problems systematically and found
            > out that settings in .Xdefaults have no effect.
            > Actually on my system the file .Xdefaults isn't even touched by ME (as
            > strace tells me), only a file .Xdefaults-thinkpad (thinkpad is my
            > hostname) is tried to be read (in accordance with X(7)). Setting up a
            > symlink .Xdefaults-thinkpad -> .Xdefaults doesn't change the behaviour,
            > although the file is read. (Your settings give me a 73x14+287+210 window.)
            >
            > I wonder what the interface for setting windows sizes is (in regard to
            > the X server and/or window manager). With other applications (e.g.
            > Mozilla Thunderbird) I can perfectly set up geometry properties through
            > my window manager's configuration (similar to .Xdefaults). With ME it
            > does not work.
            >
            > Is ME making any attempts to set its "window size" or is this totally up
            > to the window manager? Who is responsible for placing and sizing the ME
            > window? I really want this to be fixed.

            The size is controlled by X-Windows via the X-Window resource management
            and the size hints. My guess is that the likes of Thunderbird etc. are
            controlled through some Gtk configuration rather than X-Windows.

            The code that does this is in unixterm.c in function XTERMstart() . me
            does not read the file directly, it is up to the window manager to
            retrieve this information and then return it.

            I cannot say that I have ever had a problem with this it has always
            worked for me on Solaris, HP-UX and SGI. Cannot recall for Linux because
            I do not use Linux much as a general working environment (I assume you
            are on Linux) but cannot recall a problem.

            For you to be using .Xdefaults-thinkpad then you must be running a
            remote desktop.

            I think you are going to have to trace this through, build a debug image
            and then break from XTERMstart tracing it through to see what X returns
            and how it is set up. Or use a few well chosen printf's temporarily to
            see what is going on.

            Regards
            Jon.

            >
            >> Hope that helps
            >> Jon.
            >
            > Sorry, not yet.
            >
            > Christof
            >
            >
            > ------------ --------- --------- ------
            >
            > ____________ _________ _________ _________ _________ _________ _
            >
            > This is an unmoderated list, but new members are moderated to ensure that there are no spam users. JASSPA is not responsible for the content of
            > any material posted to this list.
            >
            > To un-subscribe, send a mail message to
            >
            > mailto:jasspa-unsubscribe@ yahoogroups. com
            >
            > or visit http://groups. yahoo.com/ group/jasspa and
            > modify your account settings manually.
            >
            >
            > Yahoo! Groups Links
            >
            >
            >
            >

          • Christof Boeckler
            ... This function call returns 0. This means the requested resource was not found, although I put exactly Jon s resource line in my .Xdefaults file ( and that
            Message 5 of 9 , May 17, 2009
            • 0 Attachment
              Steven Phillips schrieb:
              > The X function call used to get the start-up geometry info is:
              >
              > XrmGetResource( rdb,"MicroEmacs. geometry" ,"MicroEmacs. Geometry"
              > ,&retType,&retVal)

              This function call returns 0. This means the requested resource was not
              found, although I put exactly Jon's resource line in my .Xdefaults file (
              and that was read through the symlink I created earlier today).

              > As Jon says, the most likely cause is that Gtk is not honouring this
              > original way of configuring X applications, have things moved on in the
              > Linux world? So another possible way of resolving this is to find out
              > what config files your Window manager does read and put a suitable
              > configuration in one of those...

              I tried to put the setting in such a file but no effect. In fact I
              started doing this and stumbled upon this problem.

              I will now try to find out, why IceWM is not honouring my settings.

              > Steve

              Thank you both for your help!

              Christof
            Your message has been successfully submitted and would be delivered to recipients shortly.