Loading ...
Sorry, an error occurred while loading the content.

RE: [jasspa] Re: appending to "kill ring"

Expand Messages
  • Phillips, Steven
    How are you selecting text? If you are using the mouse or you have option user-setup - Start-Up - MS Shift Region enabled then this is probably to be
    Message 1 of 5 , Oct 18, 2007
    • 0 Attachment
      How are you selecting text? If you are using the mouse or you have option user-setup -> Start-Up -> MS Shift Region enabled then this is probably to be expected...
       

      From: jasspa@yahoogroups.com [mailto:jasspa@yahoogroups.com] On Behalf Of reza_rob2
      Sent: 17 October 2007 22:20
      To: jasspa@yahoogroups.com
      Subject: [jasspa] Re: appending to "kill ring"

      --- In jasspa@yahoogroups. com, "Phillips, Steven" <sphillips@. ..> wrote:
      >
      > This works fine for me, so:
      > - Are you using a reasonable version of ME?

      jasspa-mecd- full-20060909. iso

      > - Are you sure the key is bound correctly and not being overridden?
      > (i.e. that this macro is being called - try using esc-x
      > append-region)

      Yes. (describe-key returns fine)

      > - Could something else be trashing the kill buffer before you do a
      > yank?

      Yes! Apparently, whenever I select any text, the kill buffer
      automatically becomes equal to it! What's the deal?

      Thanks so much.

      Reza.

      >
      > Steve
      >

      >
      > ____________ _________ _________ __
      >
      > From: jasspa@yahoogroups. com [mailto:jasspa@yahoogroups. com] On
      > Behalf Of Reza Roboubi
      > Sent: 16 October 2007 11:53
      > To: jasspa@yahoogroups. com
      > Subject: [jasspa] appending to "kill ring"
      >
      >
      >
      > Hi,
      >
      > I'm trying to do something like this, but it's not working:
      > ########
      > define-macro append-region
      > set-variable @cl copy-region
      > copy-region
      > !emacro
      > global-bind- key append-region "C-a"
      > #########
      >
      > What's the best way to achieve what I need? I need to "grab"
      > several items and copy them
      > elsewhere all at once.
      >
      > Thanks for any help in advance.
      >
      > Reza.
      >
      > ____________ _________ _________ _________ _________ _________ _
      > Moody friends. Drama queens. Your life? Nope! - their life, your
      > story. Play Sims Stories at Yahoo! Games.
      > http://sims. yahoo.com/ <http://sims. yahoo.com/>
      >

    • reza_rob2
      ... Indeed, when I use the set-mark command it works! Out of curiosity, how come the shift-* stuff fails anyway? And thanks a lot :-) Reza.
      Message 2 of 5 , Oct 18, 2007
      • 0 Attachment
        --- In jasspa@yahoogroups.com, "Phillips, Steven" <sphillips@...> wrote:
        >
        > How are you selecting text? If you are using the mouse or you have
        > option user-setup -> Start-Up -> MS Shift Region enabled then this is
        > probably to be expected...

        Indeed, when I use the set-mark command it works! Out of curiosity,
        how come the shift-* stuff fails anyway?

        And thanks a lot :-)

        Reza.
      Your message has been successfully submitted and would be delivered to recipients shortly.