Loading ...
Sorry, an error occurred while loading the content.

[jasspa] Re: Solaris & IRIX

Expand Messages
  • Jon Green
    ... As me -n operates correctly I would guess that it is not finding the X-Windows shared library (.so) object libX11.so.?. Try adding the appropriate path
    Message 1 of 3 , Mar 10 2:57 AM
    • 0 Attachment
      Howie Solomon wrote:
      >
      > Suspect something in my environment is not
      > set up properly for Solaris or IRIX. Any ideas?
      >
      > Using the Golden Distribution:
      >
      > "melinux55_99 -n" works.
      > "mesunos55_99 -n" works.
      > "meirix55_99 -n" works.
      >
      > "melinux55_99" works.
      > "mesunos55_99" just exits, no error msg, no core dump.
      > "meirix55_99" just exist, no error msg, no core dump.
      >
      > Perhaps a LD_LIBRARY_PATH thing?
      >

      As "me -n" operates correctly I would guess that
      it is not finding the X-Windows shared library (.so)
      object libX11.so.?.

      Try adding the appropriate path of the library to
      the LD_LIBRARY_PATH variable. If this does not
      work then the executable may have been linked against
      a different version of the library - in this instance
      you typically get an error telling you whats not
      been found. The version of the shared library
      may be corrected by creating a symbolic link of
      the expected .so version to an existing shared
      library of a different version. (Naughty but
      does work).

      Alternatively rebuild a new executable from the
      source. For your platforms a simple ./build
      in the source directory should build you an
      executable which will be then fully compatible
      with your system.

      Hope this helps.

      Regards
      Jon.
    • Thomas Hundt
      [Howie Solomon 04:56 PM 3/9/00 -0800] ... Mine says Date 99/11/05 in Help About. Don t remember which distribution this is. ... This tanks for me. ... This
      Message 2 of 3 , Mar 14 12:18 PM
      • 0 Attachment
        [Howie Solomon 04:56 PM 3/9/00 -0800]
        |Suspect something in my environment is not
        |set up properly for Solaris or IRIX. Any ideas?
        |
        |Using the Golden Distribution:

        Mine says Date 99/11/05 in Help>About.
        Don't remember which distribution this is.

        |"mesunos55_99 -n" works.

        This tanks for me.

        |"mesunos55_99" just exits, no error msg, no core dump.

        This runs for me.


        Here are the file sizes and libs it wants to load:

        gsdev$ ls -l
        total 7042
        lrwxrwxrwx 1 thundt sybadmin 6 Dec 3 08:58 Macros -> macros/
        drwxr-xr-x 2 thundt sybadmin 4096 Mar 10 12:49 macros/
        -rw-r--r-- 1 thundt sybadmin 8475 Sep 8 1998 me.xpm
        -rw-r--r-- 1 thundt sybadmin 20480 Dec 3 08:56 meicons_99.tar
        -rw-r--r-- 1 thundt sybadmin 3051520 Dec 3 08:56 memacros_99.tar
        -rwxr-xr-x 1 thundt sybadmin 489408 Dec 3 08:56 mesunos55_99*
        -rw-r--r-- 1 thundt sybadmin 6304 Sep 8 1998 mini-me.xpm
        gsdev$ ldd mesunos55_99
        libX11.so.4 => /usr/openwin/lib/libX11.so.4
        libnsl.so.1 => /usr/lib/libnsl.so.1
        libsocket.so.1 => /usr/lib/libsocket.so.1
        libintl.so.1 => /usr/lib/libintl.so.1
        libc.so.1 => /usr/lib/libc.so.1
        libXext.so.0 => /usr/openwin/lib/libXext.so.0
        libdl.so.1 => /usr/lib/libdl.so.1
        libmp.so.2 => /usr/lib/libmp.so.2
        gsdev$


        -Th
      Your message has been successfully submitted and would be delivered to recipients shortly.