Loading ...
Sorry, an error occurred while loading the content.

Re: [jasspa] (how-to) prevent unbinding of RETURN ?

Expand Messages
  • Jon Green
    ... Hi Ian, I know you are transitioning across (I saw your subscribe message) - it will take a little while to get familiar, but not long. Hopefully you have
    Message 1 of 2 , Mar 31 12:38 PM
    • 0 Attachment
      Ian wrote:
      > Hi,
      > while using 20060909 for 10.3 MacOS....
      >
      > ... accidentially managed to unbind the RETURN terminator, then had to
      > force-quit the shell entirely, as no amount of fiddling allowed me to
      > recover it.
      >
      > How do I prevent that from happening in the future?
      >
      > (in other words: what is the prescribed way of exiting the potentially
      > destructive global-unbind-key op ["esc C-k"] ?)
      >
      > Also, sorry if that's an RTFM question: is there an equivalent to
      > ME3.9 emacs.rc file in the distribution, one executed by default upon
      > launch?
      >
      > Thanks in advance.
      >
      > Ian
      > this post <http://tech.groups.yahoo.com/group/jasspa/message/2247>
      >

      Hi Ian,

      I know you are transitioning across (I saw your subscribe message) - it
      will take a little while to get familiar, but not long.

      Hopefully you have found <user>.emf file - not sure where this lives on
      a Mac, but it is in your home directory. This is equivalent to your old
      ue emacs.rc (You should find it here $home/.jasspa/<user>.emf). esc-x
      user-setup tells you where it is.

      In the distribution macros i.e. /opt/jasspa/contrib or
      /usr/share/jasspa/contrib or c:\program files\jasspa\microemacs\contrib
      etc. then there is a file called "user.emf". This has lots of stuff in
      it that may be useful for new users. You can copy this into your
      <user>.emf in full or take bits from it and add.

      Right at the bottom of this file you will see how to disable the unbind
      key which is as follows:

      ; If you loose the C-k kill-line key then you are miss-typing and unbinding.
      ; Remove the global-unbind-key binding so this cannot happen.
      !force global-unbind-key "esc C-k"

      So add this to your <user>.emf and then restart (or do esc-x
      execute-buffer to load it in).

      Hope that helps.

      Regards
      Jon.
    Your message has been successfully submitted and would be delivered to recipients shortly.