Loading ...
Sorry, an error occurred while loading the content.

Re: [jasspa] system wide font size

Expand Messages
  • Jon Green
    ... Sounds like you are sysadmin on this - why not edit me.emf and add a little start-up macro that: a) Sets the font to new default. b) Checks the users
    Message 1 of 3 , Mar 25, 2007
    • 0 Attachment
      Christof Boeckler wrote:
      > Hi all,
      >
      > I would like to enlarge the system wide font size for ME on Solaris.
      > The new 19 inch TFTs in our computer lab make the default font size (15
      > pt) look very tiny.
      > According to change-font(2) I could set thing up in my personal
      > .Xdefaults file, but I see no way to do that in a system wide ME global
      > setup file (I installed ME there) for all users. Otherwise most people
      > will refuse to consider ME a useful tool.
      >
      > Gruß / Regards
      > Christof
      >

      Sounds like you are sysadmin on this - why not edit me.emf and add a
      little start-up macro that:

      a) Sets the font to new default.
      b) Checks the users .Xdefaults file for a "MicroEmacs.font" entry, if it
      does not exist then adds one (or creates the file if it does not exist).

      I like option b) better than a) because it will not cause any re-sizze
      anomalies and allows the user to change it themselves and not get your
      default as part of the start-up.

      Now I'm sure that writing a macro for b) is going to be fairly easy -
      but a little late for me at the moment.

      i.e.
      find-file ~/.Xdefaults
      search-forward "^MicroEmacs.font"
      if it does not exist
      end-of-buffer
      insert-string "MicroEmacs.font ..."
      save the file
      endif
      kill-buffer ".Xdefault"


      Regards
      Jon.
    • Jon Green
      ... A good place to start is newuser.emf this is the start up that configures the environment for a new user. You can probably just change the font and force
      Message 2 of 3 , Mar 25, 2007
      • 0 Attachment
        Jon Green wrote:
        > Christof Boeckler wrote:
        >> Hi all,
        >>
        >> I would like to enlarge the system wide font size for ME on Solaris.
        >> The new 19 inch TFTs in our computer lab make the default font size (15
        >> pt) look very tiny.
        >> According to change-font(2) I could set thing up in my personal
        >> .Xdefaults file, but I see no way to do that in a system wide ME global
        >> setup file (I installed ME there) for all users. Otherwise most people
        >> will refuse to consider ME a useful tool.
        >>
        >> Gruß / Regards
        >> Christof
        >>
        >
        > Sounds like you are sysadmin on this - why not edit me.emf and add a
        > little start-up macro that:
        >
        > a) Sets the font to new default.
        > b) Checks the users .Xdefaults file for a "MicroEmacs.font" entry, if it
        > does not exist then adds one (or creates the file if it does not exist).
        >
        > I like option b) better than a) because it will not cause any re-sizze
        > anomalies and allows the user to change it themselves and not get your
        > default as part of the start-up.
        >
        > Now I'm sure that writing a macro for b) is going to be fairly easy -
        > but a little late for me at the moment.
        >
        > i.e.
        > find-file ~/.Xdefaults
        > search-forward "^MicroEmacs.font"
        > if it does not exist
        > end-of-buffer
        > insert-string "MicroEmacs.font ..."
        > save the file
        > endif
        > kill-buffer ".Xdefault"
        >
        >
        > Regards
        > Jon.
        >

        A good place to start is newuser.emf this is the start up that
        configures the environment for a new user. You can probably just change
        the font and force it into the session - probably easier than above.

        Jon.
      Your message has been successfully submitted and would be delivered to recipients shortly.