Loading ...
Sorry, an error occurred while loading the content.

[jasspa] UNIX Termcap problems and solutions

Expand Messages
  • Jon
    UNIX Termcap problems with the current release and suggested work arounds. The problems only manifest themselves on non-VT100 terminals, VT100 terminals
    Message 1 of 1 , Mar 8, 2000
    View Source
    • 0 Attachment
      UNIX Termcap problems with the current release and suggested work
      arounds. The problems only manifest themselves on non-VT100
      terminals, VT100 terminals would appear to be the most robust.

      Scrolling Problem (Solaris/2.6/x86/Console)

      The Termcap settings in the current beta (00/01/26) are
      not being read and interpreted correctly. The net effect
      is that screen scrolls upwards. A work around is to
      modify the screen depth by -1 (i.e. 24 lines). This
      disables the scrolling effect. i.e.

      24 change-screen-depth

      The cause is the auto margins (attribute "am") kicking in
      while writing to the last line in the last column. There
      is no way to disable this feature on an AT386 terminal.

      This technique may be used to fix any termcap display
      that suffers the same problem. A fix for this will appear
      in the next release.

      Underline Problems (Solaris/2.6/x86/Console+dtterm)

      Running a dtterm or console with underline enabled causes
      problems because it is not disabled correctly. A work
      around is to disable the Termcap font setting
      (user-setup) or change the DISPLAY to "vt100". This fixes
      the problem.

      This has been fixed and will appear in the next release.

      Reverse Video Problems (Solaris/2.6/x86/Console+dtterm)

      The vertical separator for a horizontally split screen is
      not visible under Solaris. (It would also not be visible
      under Linux running an xterm, but an incorrect patch has
      been placed in the code that fixes the problem).

      Work around change the DISPLAY to "vt100".

      Problem has been fixed and will appear in the next
      release.

      No "C-x" or "C-t" on Solaris/2.6/x86/Console

      This took me a while to track down. The Intel Solaris
      console runs a background utility called "pcmapkeys" that
      allows the key mappings to be extended for the ISO-8859
      extended characters. This utility kills the C-x and C-t
      keys before they reach the input of "me", hence they are
      never seen. The key mapper may be disabled by running:-

      pcmapkeys -n

      This kills off the translation and the keyboard functions
      correctly. The `magic` keys may be modified by editing
      the key map - this is described in the manual page for
      the same utility. For US keyboards/users then the C-@ key
      is disabled. Each locale would appear to be slightly
      different, however the continental ones seemed to be
      using C-x - bad news for Emacs keystrokes !!

      Regards
      Jon.
    Your message has been successfully submitted and would be delivered to recipients shortly.