Loading ...
Sorry, an error occurred while loading the content.
 

ME ignores $MEUSERPATH under *NIX?

Expand Messages
  • dsjkvf
    hello, first, here s an output: ~ echo $MEUSERPATH /home/dsjkvf/usr/local/bin/me/libs/ ~ ls -la /home/dsjkvf/usr/local/bin/me/libs/ total 60 drwxr-xr-x 4 s
    Message 1 of 9 , Nov 7 12:11 AM
      hello,


      first, here's an output:

      ~> echo $MEUSERPATH
      /home/dsjkvf/usr/local/bin/me/libs/
      ~> ls -la /home/dsjkvf/usr/local/bin/me/libs/
      total 60
      drwxr-xr-x 4 s users 512 Nov 7 09:57 .
      drwxr-xr-x 8 s users 512 Nov 7 09:57 ..
      -rw-r--r-- 1 s users 99 Nov 6 23:05 doc.etf
      drwxr-xr-x 2 s users 512 Nov 7 09:52 notes
      -rw-r--r-- 1 s users 6046 Nov 7 09:56 s.emf
      -rw-r--r-- 1 s users 4693 Nov 4 19:26 s.emf.old
      -rw-r--r-- 1 s users 28352 Nov 7 09:31 s.enf
      -rw-r--r-- 1 s users 4329 Nov 3 13:09 s.erf
      -rw-r--r-- 1 s users 2777 Nov 7 09:56 s.esf
      drwxr-xr-x 2 s users 512 Nov 7 09:35 texts

      however, ME after launch does not see those config files, but creates
      new ones in /home/dsjkvf/.jasspa. so, what am i doing wrong? is there
      any way to fix it?


      thank you.


      --
      dsjkvf
    • Phillips, Steven
      Do you have other variables like MEPATH set? Once you start ME, execute list-variables and look at the values of $user-path and $search-path, do their values
      Message 2 of 9 , Nov 7 12:17 AM
        Do you have other variables like MEPATH set?

        Once you start ME, execute list-variables and look at the values of
        $user-path and $search-path, do their values make sense?

        Steve

        > -----Original Message-----
        > From: jasspa@yahoogroups.com [mailto:jasspa@yahoogroups.com]
        > On Behalf Of dsjkvf
        > Sent: Tuesday, November 07, 2006 8:12 AM
        > To: JASSPA mailing list
        > Subject: [jasspa] ME ignores $MEUSERPATH under *NIX?
        >
        > hello,
        >
        >
        > first, here's an output:
        >
        > ~> echo $MEUSERPATH
        > /home/dsjkvf/usr/local/bin/me/libs/
        > ~> ls -la /home/dsjkvf/usr/local/bin/me/libs/
        > total 60
        > drwxr-xr-x 4 s users 512 Nov 7 09:57 .
        > drwxr-xr-x 8 s users 512 Nov 7 09:57 ..
        > -rw-r--r-- 1 s users 99 Nov 6 23:05 doc.etf
        > drwxr-xr-x 2 s users 512 Nov 7 09:52 notes
        > -rw-r--r-- 1 s users 6046 Nov 7 09:56 s.emf
        > -rw-r--r-- 1 s users 4693 Nov 4 19:26 s.emf.old
        > -rw-r--r-- 1 s users 28352 Nov 7 09:31 s.enf
        > -rw-r--r-- 1 s users 4329 Nov 3 13:09 s.erf
        > -rw-r--r-- 1 s users 2777 Nov 7 09:56 s.esf
        > drwxr-xr-x 2 s users 512 Nov 7 09:35 texts
        >
        > however, ME after launch does not see those config files, but
        > creates new ones in /home/dsjkvf/.jasspa. so, what am i doing
        > wrong? is there any way to fix it?
        >
        >
        > thank you.
        >
        >
        > --
        > dsjkvf
        >
        >
        > ______________________________________________________________
        > ____________
        >
        > This is an unmoderated list. JASSPA is not responsible for
        > the content of
        > any material posted to this list.
        >
        > To unsubscribe, send a mail message to
        >
        > mailto:jasspa-unsubscribe@yahoogroups.com
        >
        > or visit http://groups.yahoo.com/group/jasspa and
        > modify your account settings manually.
        >
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
      • Christof Boeckler
        ... Hi! ... from the shell, right. ... First of all check whether ME knows about that variable at all: esc x describe-variable $MEUSERPATH If not, then you
        Message 3 of 9 , Nov 7 12:20 AM
          dsjkvf schrieb:
          > hello,

          Hi!

          > first, here's an output:

          from the shell, right.

          > ~> echo $MEUSERPATH
          > /home/dsjkvf/usr/local/bin/me/libs/
          > ~> ls -la /home/dsjkvf/usr/local/bin/me/libs/
          > [...]
          > however, ME after launch does not see those config files, but creates
          > new ones in /home/dsjkvf/.jasspa. so, what am i doing wrong? is there
          > any way to fix it?

          First of all check whether ME knows about that variable at all:

          esc x describe-variable $MEUSERPATH

          If not, then you have to fix it in your shell/desktop environment.

          > thank you.

          Gruß / Regards
          Christof

          --
          Da sie sich für weise hielten, sind sie zu Narren geworden. Rö 1,22
        • dsjkvf
          ... in fact, i tried to set to it also to the same value as MEUSERPATH -- /home/dsjvkf/usr/local/bin/me/libs/ -- but see below ... user-path is set to
          Message 4 of 9 , Nov 7 12:30 AM
            On 11/7/06, Phillips, Steven <sphillips@...> wrote:

            > Do you have other variables like MEPATH set?

            in fact, i tried to set to it also to 'the same value as MEUSERPATH --
            /home/dsjvkf/usr/local/bin/me/libs/ -- but see below

            > Once you start ME, execute list-variables and look at the values of
            > $user-path and $search-path, do their values make sense?

            user-path is set to /home/dsjkvf/.jasspa/
            same is search-path -- it is set to /home/dsjkvf/.jasspa/ plus usual
            directories, such as /home/dsjvkf/usr/local/bin/me/macroses, etc.

            so, ME just ignores my seetings, but why?

            i use GNU bash, version 2.05b.0(1)-release (i386-portbld-freebsd5.3) and i have
            MEUSERPATH='/home/dsjkvf/usr/local/bin/me/libs/'
            in my .bash_profile



            --
            dsjkvf
          • Phillips, Steven
            Dsjkvf, Can you run export in the bash shell and send me the output, then run ME in that shell, list-variables and send me the setting of $user-path and
            Message 5 of 9 , Nov 7 1:18 AM
              Dsjkvf,

              Can you run 'export' in the bash shell and send me the output, then run
              ME in that shell, list-variables and send me the setting of $user-path
              and $search-path.

              Thanks,

              Steve

              > -----Original Message-----
              > From: jasspa@yahoogroups.com [mailto:jasspa@yahoogroups.com]
              > On Behalf Of dsjkvf
              > Sent: Tuesday, November 07, 2006 8:30 AM
              > To: jasspa@yahoogroups.com
              > Subject: Re: [jasspa] ME ignores $MEUSERPATH under *NIX?
              >
              > On 11/7/06, Phillips, Steven <sphillips@...> wrote:
              >
              > > Do you have other variables like MEPATH set?
              >
              > in fact, i tried to set to it also to 'the same value as
              > MEUSERPATH -- /home/dsjvkf/usr/local/bin/me/libs/ -- but see below
              >
              > > Once you start ME, execute list-variables and look at the
              > values of
              > > $user-path and $search-path, do their values make sense?
              >
              > user-path is set to /home/dsjkvf/.jasspa/ same is search-path
              > -- it is set to /home/dsjkvf/.jasspa/ plus usual directories,
              > such as /home/dsjvkf/usr/local/bin/me/macroses, etc.
              >
              > so, ME just ignores my seetings, but why?
              >
              > i use GNU bash, version 2.05b.0(1)-release
              > (i386-portbld-freebsd5.3) and i have
              > MEUSERPATH='/home/dsjkvf/usr/local/bin/me/libs/'
              > in my .bash_profile
              >
              >
              >
              > --
              > dsjkvf
              >
              >
              > ______________________________________________________________
              > ____________
              >
              > This is an unmoderated list. JASSPA is not responsible for
              > the content of
              > any material posted to this list.
              >
              > To unsubscribe, send a mail message to
              >
              > mailto:jasspa-unsubscribe@yahoogroups.com
              >
              > or visit http://groups.yahoo.com/group/jasspa and
              > modify your account settings manually.
              >
              >
              >
              > Yahoo! Groups Links
              >
              >
              >
              >
            • Christof Boeckler
              ... That seems to be not correct, but anyways make sure you export your $MEUSERPATH variable instead of only declaring it. (Shell variable vs. environment
              Message 6 of 9 , Nov 7 1:25 AM
                Christof Boeckler schrieb:
                > First of all check whether ME knows about that variable at all:
                >
                > esc x describe-variable $MEUSERPATH
                >
                > If not, then you have to fix it in your shell/desktop environment.

                That seems to be not correct, but anyways make sure you export your
                $MEUSERPATH variable instead of only declaring it. (Shell variable vs.
                environment variable).

                Gruß / Regards
                Christof

                --
                Da sie sich für weise hielten, sind sie zu Narren geworden. Rö 1,22
              • dsjkvf
                ... so, as it was expected :), it tells that Current setting is ERROR but why? and how can i fix it? as i ve mentioned already, i set $MEUSERPATH in my
                Message 7 of 9 , Nov 7 1:30 AM
                  On 11/7/06, Christof Boeckler <cb@...> wrote:
                  > First of all check whether ME knows about that variable at all:
                  >
                  > esc x describe-variable $MEUSERPATH
                  >
                  > If not, then you have to fix it in your shell/desktop environment.

                  so, as it was expected :), it tells that 'Current setting is "ERROR"'
                  but why? and how can i fix it?

                  as i've mentioned already, i set $MEUSERPATH in my .bash_profile this
                  way (with or without quotes):
                  MEUSERPATH=home/s/usr/local/bin/me/libs/



                  --
                  dsjkvf
                • dsjkvf
                  Steven, i m very sorry :). ... i ve just forgot to export after setting a variable, you were absolutely right. thank you for this hint and sorry for the mess.
                  Message 8 of 9 , Nov 7 1:44 AM
                    Steven, i'm very sorry :).

                    > Can you run 'export'

                    i've just forgot to export after setting a variable, you were
                    absolutely right. thank you for this hint and sorry for the mess.



                    --
                    dsjkvf
                  • dsjkvf
                    ... yes, Christof, that was exactly the problem -- i have remembered about the export just after Steven has mentioned this magic word :). however, thank you
                    Message 9 of 9 , Nov 7 1:51 AM
                      On 11/7/06, Christof Boeckler <cb@...> wrote:

                      > That seems to be not correct, but anyways make sure you export your
                      > $MEUSERPATH variable instead of only declaring it. (Shell variable vs.
                      > environment variable).

                      yes, Christof, that was exactly the problem -- i have remembered about
                      the export just after Steven has mentioned this magic word :).

                      however, thank you very for your help. now the "problem" is solved.



                      --
                      dsjvkf
                    Your message has been successfully submitted and would be delivered to recipients shortly.