Loading ...
Sorry, an error occurred while loading the content.

Re: [jasspa] C-fx (was: macro for close / exit)

Expand Messages
  • dsjkvf
    ... Thomas, thank you -- your macros above has somehow helped me :). btw, does anybody know why C-functional key shortcut does not work for me when ME is
    Message 1 of 16 , Oct 25, 2006
    • 0 Attachment
      On 10/25/06, Thomas Hundt <thundt@...> wrote:

      > ;----------------------------------------------------------
      > ; delete-current-buffer: kills buffer w/o confirming the name
      > ;----------------------------------------------------------
      > define-macro delete-current-buffer
      > 1 delete-buffer $buffer-bname
      > !emacro
      > !force 1 global-bind-key delete-current-buffer "C-f4"

      Thomas, thank you -- your macros above has somehow helped me :).

      btw, does anybody know why "C-functional key" shortcut does not work
      for me when ME is running on a remote machine, and i'm using it via
      putty or any other ssh-client?

      remote terminal is xterm
      remote system is 5.4-RELEASE FreeBSD 5.4-RELEASE #0
      ME is MicroEmacs 06 - Date 2006/09/09 - freebsd




      dsjkvf



      Five is a sufficiently close approximation to infinity.
      -- Robert Firth
    • Jon Green
      ... I can ssh between Solaris machines no problem and the C-Fx keys are OK. Will try a BSD system later. Jon
      Message 2 of 16 , Oct 26, 2006
      • 0 Attachment
        dsjkvf wrote:
        > On 10/25/06, Thomas Hundt <thundt@...> wrote:
        >
        >> ;----------------------------------------------------------
        >> ; delete-current-buffer: kills buffer w/o confirming the name
        >> ;----------------------------------------------------------
        >> define-macro delete-current-buffer
        >> 1 delete-buffer $buffer-bname
        >> !emacro
        >> !force 1 global-bind-key delete-current-buffer "C-f4"
        >
        > Thomas, thank you -- your macros above has somehow helped me :).
        >
        > btw, does anybody know why "C-functional key" shortcut does not work
        > for me when ME is running on a remote machine, and i'm using it via
        > putty or any other ssh-client?
        >
        > remote terminal is xterm
        > remote system is 5.4-RELEASE FreeBSD 5.4-RELEASE #0
        > ME is MicroEmacs 06 - Date 2006/09/09 - freebsd
        >

        I can ssh between Solaris machines no problem and the C-Fx keys are OK.
        Will try a BSD system later.

        Jon
      • dsjkvf
        hello, Jon, thank you. in fact, it s quite strange... and i really don t think that OS could be here an issue... i d rather say it sounds like some kind of
        Message 3 of 16 , Oct 26, 2006
        • 0 Attachment
          hello,

          Jon, thank you.

          in fact, it's quite strange... and i really don't think that OS could
          be here an issue... i'd rather say it sounds like some kind of local
          problems / settings... but what exactly?

          also, i haven't mentioned it in first letter: C-fN seems to act just
          like fN without Ctrl modifier -- e.g., i press C-f10 and see a usual
          warning: [Key not bound "f10"]
          and even more: i have in my personal .emf something like that:
          8 global-bind-key exit-emacs "C-f10"

          but it does exactly tha same (force ME to exit) when pressing f10
          wthout Ctrl (it's not just some "f10 / exit issue", of course --
          exactly the same situation is with other function keys / commands).


          On 10/26/06, Jon Green <jon@...> wrote:
          > I can ssh between Solaris machines no problem and the C-Fx keys are OK.
          > Will try a BSD system later.




          dsjkvf


          All true wisdom is found on T-shirts.
        • jon@jasspa.com
          ... I have just tried ME 06/09/09 with OpenBSD 3.3 using SSH with Exceed 11. Again no problems distinguishes F1, C-F1, S-F1, esc-F1 but Alt-F1 does not work.
          Message 4 of 16 , Oct 26, 2006
          • 0 Attachment
            > hello,
            >
            > Jon, thank you.
            >
            > in fact, it's quite strange... and i really don't think that OS could
            > be here an issue... i'd rather say it sounds like some kind of local
            > problems / settings... but what exactly?
            >
            > also, i haven't mentioned it in first letter: C-fN seems to act just
            > like fN without Ctrl modifier -- e.g., i press C-f10 and see a usual
            > warning: [Key not bound "f10"]
            > and even more: i have in my personal .emf something like that:
            > 8 global-bind-key exit-emacs "C-f10"
            >
            > but it does exactly tha same (force ME to exit) when pressing f10
            > wthout Ctrl (it's not just some "f10 / exit issue", of course --
            > exactly the same situation is with other function keys / commands).
            >
            >
            > On 10/26/06, Jon Green <jon@...> wrote:
            >> I can ssh between Solaris machines no problem and the C-Fx keys are OK.
            >> Will try a BSD system later.
            >
            >

            I have just tried ME 06/09/09 with OpenBSD 3.3 using SSH with Exceed 11.
            Again no problems distinguishes F1, C-F1, S-F1, esc-F1 but Alt-F1 does not
            work.

            Possibly issue with your local x-client or configuration?

            Jon.
          • jon@jasspa.com
            ... This is because the control modifier is not coming through with F1. If it works on the remote machine when logged in on the console then the issue is with
            Message 5 of 16 , Oct 26, 2006
            • 0 Attachment
              >> hello,
              >>
              >> Jon, thank you.
              >>
              >> in fact, it's quite strange... and i really don't think that OS could
              >> be here an issue... i'd rather say it sounds like some kind of local
              >> problems / settings... but what exactly?
              >>
              >> also, i haven't mentioned it in first letter: C-fN seems to act just
              >> like fN without Ctrl modifier -- e.g., i press C-f10 and see a usual
              >> warning: [Key not bound "f10"]
              >> and even more: i have in my personal .emf something like that:
              >> 8 global-bind-key exit-emacs "C-f10"

              This is because the control modifier is not coming through with F1.
              If it works on the remote machine when logged in on the console then the
              issue is with your x-client. If it does not work on the console then it
              must server side.

              Best guess is your client side and the local X configuration. You do not
              say what you X-client is. If you are running putty then I assume it is
              Windoze possibly X-cygwin?

              Jon

              >>
              >> but it does exactly tha same (force ME to exit) when pressing f10
              >> wthout Ctrl (it's not just some "f10 / exit issue", of course --
              >> exactly the same situation is with other function keys / commands).
              >>
              >>
              >> On 10/26/06, Jon Green <jon@...> wrote:
              >>> I can ssh between Solaris machines no problem and the C-Fx keys are
              >>> OK.
              >>> Will try a BSD system later.
              >>
              >>
              >
              > I have just tried ME 06/09/09 with OpenBSD 3.3 using SSH with Exceed 11.
              > Again no problems distinguishes F1, C-F1, S-F1, esc-F1 but Alt-F1 does not
              > work.
              >
              > Possibly issue with your local x-client or configuration?
              >
              > Jon.
              >
              >
              >
              >
              > __________________________________________________________________________
              >
              > This is an unmoderated list. JASSPA is not responsible for the content of
              > any material posted to this list.
              >
              > To unsubscribe, send a mail message to
              >
              > mailto:jasspa-unsubscribe@yahoogroups.com
              >
              > or visit http://groups.yahoo.com/group/jasspa and
              > modify your account settings manually.
              >
              >
              >
              > Yahoo! Groups Links
              >
              >
              >
              >
              >
            • dsjkvf
              ... sorry, i also forgot to mention that i don t use X, but only a console version (with no mouse, yes :)). so, you re saying that it must be server-side...
              Message 6 of 16 , Oct 26, 2006
              • 0 Attachment
                On 10/26/06, jon@... <jon@...> wrote:

                > This is because the control modifier is not coming through with F1.
                > If it works on the remote machine when logged in on the console then the
                > issue is with your x-client. If it does not work on the console then it
                > must server side.
                > Best guess is your client side and the local X configuration. You do not
                > say what you X-client is. If you are running putty then I assume it is
                > Windoze possibly X-cygwin?

                sorry, i also forgot to mention that i don't use X, but only a console
                version (with no mouse, yes :)).

                so, you're saying that it must be server-side... could you suggest
                what should i look at first? probably $TERM... but what exacly and
                how?

                (of course, all C-x, etc., S-letter, etc. work perfect -- the problem
                appears only with functional keys).



                dsjkvf


                Earth is a beta site.
              • Sabin, Bruno
                If you are dealing with a Windows X server, then be aware that certain implementations (Exceed is one) map the left side Ctrl and Alt keys to Windows land and
                Message 7 of 16 , Oct 26, 2006
                • 0 Attachment
                  If you are dealing with a Windows X server, then be aware that certain
                  implementations (Exceed is one) map the left side Ctrl and Alt keys to
                  Windows land and the right side Ctrl and Alt to the X server realm.

                  So could dsjkvf try his Ctrl bindings using the right-hand side
                  modifiers and tell us how he fares?
                  --
                  bruno


                  -----Original Message-----
                  From: jasspa@yahoogroups.com [mailto:jasspa@yahoogroups.com] On Behalf
                  Of jon@...
                  Sent: Thursday, October 26, 2006 12:58 PM
                  To: jasspa@yahoogroups.com
                  Subject: Re: [jasspa] C-fx (was: macro for close / exit)

                  >> hello,
                  >>
                  >> Jon, thank you.
                  >>
                  >> in fact, it's quite strange... and i really don't think that OS could
                  >> be here an issue... i'd rather say it sounds like some kind of local
                  >> problems / settings... but what exactly?
                  >>
                  >> also, i haven't mentioned it in first letter: C-fN seems to act just
                  >> like fN without Ctrl modifier -- e.g., i press C-f10 and see a usual
                  >> warning: [Key not bound "f10"]
                  >> and even more: i have in my personal .emf something like that:
                  >> 8 global-bind-key exit-emacs "C-f10"

                  This is because the control modifier is not coming through with F1.
                  If it works on the remote machine when logged in on the console then the
                  issue is with your x-client. If it does not work on the console then it
                  must server side.

                  Best guess is your client side and the local X configuration. You do not
                  say what you X-client is. If you are running putty then I assume it is
                  Windoze possibly X-cygwin?

                  Jon

                  >>
                  >> but it does exactly tha same (force ME to exit) when pressing f10
                  >> wthout Ctrl (it's not just some "f10 / exit issue", of course --
                  >> exactly the same situation is with other function keys / commands).
                  >>
                  >>
                  >> On 10/26/06, Jon Green <jon@...> wrote:
                  >>> I can ssh between Solaris machines no problem and the C-Fx keys are
                  >>> OK.
                  >>> Will try a BSD system later.
                  >>
                  >>
                  >
                  > I have just tried ME 06/09/09 with OpenBSD 3.3 using SSH with Exceed
                  11.
                  > Again no problems distinguishes F1, C-F1, S-F1, esc-F1 but Alt-F1 does
                  not
                  > work.
                  >
                  > Possibly issue with your local x-client or configuration?
                  >
                  > Jon.
                  >
                  >
                  >
                  >
                  >
                  ________________________________________________________________________
                  __
                  >
                  > This is an unmoderated list. JASSPA is not responsible for the content
                  of
                  > any material posted to this list.
                  >
                  > To unsubscribe, send a mail message to
                  >
                  > mailto:jasspa-unsubscribe@yahoogroups.com
                  >
                  > or visit http://groups.yahoo.com/group/jasspa and
                  > modify your account settings manually.
                  >
                  >
                  >
                  > Yahoo! Groups Links
                  >
                  >
                  >
                  >
                  >




                  ________________________________________________________________________
                  __

                  This is an unmoderated list. JASSPA is not responsible for the content
                  of
                  any material posted to this list.

                  To unsubscribe, send a mail message to

                  mailto:jasspa-unsubscribe@yahoogroups.com

                  or visit http://groups.yahoo.com/group/jasspa and
                  modify your account settings manually.



                  Yahoo! Groups Links
                • jon@jasspa.com
                  ... OK this is different if it is a console. This will depend on the the terminal emulation and what the client does. With Exceed again and OpenBSD then I get
                  Message 8 of 16 , Oct 26, 2006
                  • 0 Attachment
                    > On 10/26/06, jon@... <jon@...> wrote:
                    >
                    >> This is because the control modifier is not coming through with F1.
                    >> If it works on the remote machine when logged in on the console then the
                    >> issue is with your x-client. If it does not work on the console then it
                    >> must server side.
                    >> Best guess is your client side and the local X configuration. You do not
                    >> say what you X-client is. If you are running putty then I assume it is
                    >> Windoze possibly X-cygwin?
                    >
                    > sorry, i also forgot to mention that i don't use X, but only a console
                    > version (with no mouse, yes :)).
                    >
                    > so, you're saying that it must be server-side... could you suggest
                    > what should i look at first? probably $TERM... but what exacly and
                    > how?
                    >

                    OK this is different if it is a console. This will depend on the the
                    terminal emulation and what the client does.

                    With Exceed again and OpenBSD then I get "esc o P" for F1 and "esc o 5 P"
                    for C-f1 these are not mapped. Interestingly F5 works. To fix this then I
                    would play around with the terminal configuration client side and use
                    translate-key in ME to find a conbination that worked.

                    Regards
                    Jon.

                    F1 = esc P

                    > (of course, all C-x, etc., S-letter, etc. work perfect -- the problem
                    > appears only with functional keys).
                    >
                    >
                    >
                    > dsjkvf
                    >
                    >
                    > Earth is a beta site.
                    >
                    >
                    > __________________________________________________________________________
                    >
                    > This is an unmoderated list. JASSPA is not responsible for the content of
                    > any material posted to this list.
                    >
                    > To unsubscribe, send a mail message to
                    >
                    > mailto:jasspa-unsubscribe@yahoogroups.com
                    >
                    > or visit http://groups.yahoo.com/group/jasspa and
                    > modify your account settings manually.
                    >
                    >
                    >
                    > Yahoo! Groups Links
                    >
                    >
                    >
                    >
                    >
                  • Thomas Hundt
                    If you re getting SOMEthing but just not the sequence you expect, you might have to use code like that below. But sometimes they can t be fixed. For example,
                    Message 9 of 16 , Oct 26, 2006
                    • 0 Attachment
                      If you're getting SOMEthing but just not the sequence you expect, you
                      might have to use code like that below. But sometimes they can't be
                      fixed. For example, my setup generates the Ctrl-Fxx keys properly under
                      X -- I'm using Putty 0.58 and Cygwin X/Server -- but not under just
                      Putty in non-GUI mode (with 'me -n'). The Ctrl-Fxx come out as just
                      Fxx. (I think it's a limitation in Putty.)


                      ; fix Backspace using Putty
                      -1 translate-key "C-h" ; remove translation to "backspace"
                      translate-key "\x7F" "backspace" ; Backspace key

                      ; fix del, home keys termcap/Putty/Solaris ME20040403
                      translate-key "C-[ [ 3 ~" "delete" ; ^[[3~ ('cat' output)
                      translate-key "C-[ [ 1 ~" "home" ; ^[[1~

                      ; add support for termcap/Putty/Solaris
                      translate-key "C-[ O A" "C-up" ; ctrl up ^[OA
                      translate-key "C-[ O B" "C-down" ; ctrl down ^[OB
                      translate-key "C-[ O D" "C-left" ; ctrl left ^[OD
                      translate-key "C-[ O C" "C-right" ; ctrl right ^[OC

                      ;-----
                      ; SuSE xterm console mode ('me -n')
                      ; 12-Jan-06 SuSE10/kde/gnome
                      ;-----
                      translate-key "C-[ [ 1 ; 5 A" "C-up"
                      translate-key "C-[ [ 1 ; 5 B" "C-down"
                      translate-key "C-[ [ 1 ; 5 C" "C-right"
                      translate-key "C-[ [ 1 ; 5 D" "C-left"

                      translate-key "C-[ [ 1 ; 2 A" "S-up"
                      translate-key "C-[ [ 1 ; 2 B" "S-down"
                      translate-key "C-[ [ 1 ; 2 C" "S-right"
                      translate-key "C-[ [ 1 ; 2 D" "S-left"

                      translate-key "C-[ [ H" "home"
                      translate-key "C-[ [ F" "end"
                      translate-key "C-[ [ 1 ; 5 H" "c-home"
                      translate-key "C-[ [ 1 ; 5 F" "c-end"

                      translate-key "C-[ [ 5 ; 5 ~" "C-page-up"
                      translate-key "C-[ [ 6 ; 5 ~" "C-page-down"
                      translate-key "C-[ [ 2 9 ~" "menu" ; context menu key



                      dsjkvf wrote, On 10/25/2006 10:09 PM:
                      > btw, does anybody know why "C-functional key" shortcut does not work
                      > for me when ME is running on a remote machine, and i'm using it via
                      > putty or any other ssh-client?
                      >
                      > remote terminal is xterm
                      > remote system is 5.4-RELEASE FreeBSD 5.4-RELEASE #0
                      > ME is MicroEmacs 06 - Date 2006/09/09 - freebsd
                      >
                      > dsjkvf
                    • dsjkvf
                      ... Thomas, thank you really very much for your input. in fact, i was almost about to think the same -- that it could be just a limitation of PuTTY... i ll try
                      Message 10 of 16 , Oct 27, 2006
                      • 0 Attachment
                        On 10/26/06, Thomas Hundt <thundt@...> wrote:

                        > If you're getting SOMEthing but just not the sequence you expect, you
                        > might have to use code like that below. But sometimes they can't be
                        > fixed. For example, my setup generates the Ctrl-Fxx keys properly under
                        > X -- I'm using Putty 0.58 and Cygwin X/Server -- but not under just
                        > Putty in non-GUI mode (with 'me -n'). The Ctrl-Fxx come out as just
                        > Fxx. (I think it's a limitation in Putty.)

                        Thomas, thank you really very much for your input. in fact, i was
                        almost about to think the same -- that it could be just a limitation
                        of PuTTY... i'll try to look in this direction (and may be change my
                        ssh-client after all :)).

                        could you please also confirm if S-Fxx sequences do work for you in
                        PuTTY (non-GUI mode)?

                        and also thank you for a part of your .emf-file with translations --
                        i'll give it a try, thanks!



                        dsjkvf



                        Drive defensively. Buy a tank.
                      • dsjkvf
                        ... Jon, thank you once again for your support. i ll try to play with client s configuration or even with different clients (as Thomas has mentioned here, it
                        Message 11 of 16 , Oct 27, 2006
                        • 0 Attachment
                          On 10/26/06, jon@... <jon@...> wrote:
                          > OK this is different if it is a console. This will depend on the the
                          > terminal emulation and what the client does.
                          >
                          > With Exceed again and OpenBSD then I get "esc o P" for F1 and "esc o 5 P"
                          > for C-f1 these are not mapped. Interestingly F5 works. To fix this then I
                          > would play around with the terminal configuration client side and use
                          > translate-key in ME to find a conbination that worked.

                          Jon, thank you once again for your support. i'll try to play with
                          client's configuration or even with different clients (as Thomas has
                          mentioned here, it could be just a limitation of PuTTY).




                          dsjkvf
                        • Thomas Hundt
                          Hello again dsjkvf (that s not your real name, is it?? :-) How do you pronounce it?? :-) ) Okay, looking at PuTTY console mode: (I m just doing C-h k here,
                          Message 12 of 16 , Oct 27, 2006
                          • 0 Attachment
                            Hello again dsjkvf (that's not your real name, is it?? :-) How do you
                            pronounce it?? :-) )

                            Okay, looking at PuTTY console mode:
                            (I'm just doing C-h k here, "tell me what's bound to this key")
                            F1 says f1 65535 osd [okay]
                            Shift-F1 f11 display-white-chars
                            F2 f2 goto-matching-fence [I may have bound this]
                            Shift-F2 does something weird, I think it sends Escape ~24
                            F3 f3 cycle-size [my binding]
                            Shift-F3 does something weird, I think it sends Escape ~25

                            The Alt key plus Fx comes up as Meta-Fx, so that works correctly.
                            Ctrl plus Fx comes up as just plain Fx, so it's losing the Ctrl.

                            So in trying to decode these Ctrl-Fx keys, I tried just doing a 'cat'
                            and here is what it says for them:

                            ^[[11~ [this is Ctrl-F1 -- same as plain F1]
                            ^[[12~ [Ctrl-F2, etc.]
                            ^[[13~
                            ^[[14~

                            ^[[23~ [this is Shift-F1]
                            ^[[24~ [Shift-F2]

                            ^[^[[11~ [this is Alt-F1]
                            ^[^[[12~ [Alt-F2, etc.]
                            ^[^[[13~

                            So I was curious as to why the Alt-Fx comes up as Esc plus the regular
                            Fx... (almost as if it was set up to run Emacs...) I don't know if I
                            found it.
                            There is a Keyboard setting that says "The Function keys and keypad:
                            ESC[n~" There are other possible values (Linux, Xterm R6, VT400, etc.)
                            to play with. You can probably have some fun with that. Maybe you can
                            find a setting that works better for you.

                            -Tom


                            dsjkvf wrot
                            e:
                            > On 10/26/06, Thomas Hundt <thundt@...> wrote:
                            >
                            >> If you're getting SOMEthing but just not the sequence you expect, you
                            >> might have to use code like that below. But sometimes they can't be
                            >> fixed. For example, my setup generates the Ctrl-Fxx keys properly under
                            >> X -- I'm using Putty 0.58 and Cygwin X/Server -- but not under just
                            >> Putty in non-GUI mode (with 'me -n'). The Ctrl-Fxx come out as just
                            >> Fxx. (I think it's a limitation in Putty.)
                            >
                            > Thomas, thank you really very much for your input. in fact, i was
                            > almost about to think the same -- that it could be just a limitation
                            > of PuTTY... i'll try to look in this direction (and may be change my
                            > ssh-client after all :)).
                            >
                            > could you please also confirm if S-Fxx sequences do work for you in
                            > PuTTY (non-GUI mode)?
                            >
                            > and also thank you for a part of your .emf-file with translations --
                            > i'll give it a try, thanks!
                            >
                            >
                            >
                            > dsjkvf
                            >
                            >
                            >
                            > Drive defensively. Buy a tank.
                            >
                            >
                            > __________________________________________________________________________
                            >
                            > This is an unmoderated list. JASSPA is not responsible for the content of
                            > any material posted to this list.
                            >
                            > To unsubscribe, send a mail message to
                            >
                            > mailto:jasspa-unsubscribe@yahoogroups.com
                            >
                            > or visit http://groups.yahoo.com/group/jasspa and
                            > modify your account settings manually.
                            >
                            >
                            >
                            > Yahoo! Groups Links
                            >
                            >
                            >

                            --
                            Thomas Hundt <tom@...> +1-415-867-6698
                          • Jon Green
                            ... Hi Thomas, This is a nice list. Can we gain your permission to add this to the translate-key help page? Thanks Jon.
                            Message 13 of 16 , Oct 27, 2006
                            • 0 Attachment
                              Thomas Hundt wrote:
                              > If you're getting SOMEthing but just not the sequence you expect, you
                              > might have to use code like that below. But sometimes they can't be
                              > fixed. For example, my setup generates the Ctrl-Fxx keys properly under
                              > X -- I'm using Putty 0.58 and Cygwin X/Server -- but not under just
                              > Putty in non-GUI mode (with 'me -n'). The Ctrl-Fxx come out as just
                              > Fxx. (I think it's a limitation in Putty.)
                              >
                              >
                              > ; fix Backspace using Putty
                              > -1 translate-key "C-h" ; remove translation to "backspace"
                              > translate-key "\x7F" "backspace" ; Backspace key
                              >
                              > ; fix del, home keys termcap/Putty/Solaris ME20040403
                              > translate-key "C-[ [ 3 ~" "delete" ; ^[[3~ ('cat' output)
                              > translate-key "C-[ [ 1 ~" "home" ; ^[[1~
                              >
                              > ; add support for termcap/Putty/Solaris
                              > translate-key "C-[ O A" "C-up" ; ctrl up ^[OA
                              > translate-key "C-[ O B" "C-down" ; ctrl down ^[OB
                              > translate-key "C-[ O D" "C-left" ; ctrl left ^[OD
                              > translate-key "C-[ O C" "C-right" ; ctrl right ^[OC
                              >
                              > ;-----
                              > ; SuSE xterm console mode ('me -n')
                              > ; 12-Jan-06 SuSE10/kde/gnome
                              > ;-----
                              > translate-key "C-[ [ 1 ; 5 A" "C-up"
                              > translate-key "C-[ [ 1 ; 5 B" "C-down"
                              > translate-key "C-[ [ 1 ; 5 C" "C-right"
                              > translate-key "C-[ [ 1 ; 5 D" "C-left"
                              >
                              > translate-key "C-[ [ 1 ; 2 A" "S-up"
                              > translate-key "C-[ [ 1 ; 2 B" "S-down"
                              > translate-key "C-[ [ 1 ; 2 C" "S-right"
                              > translate-key "C-[ [ 1 ; 2 D" "S-left"
                              >
                              > translate-key "C-[ [ H" "home"
                              > translate-key "C-[ [ F" "end"
                              > translate-key "C-[ [ 1 ; 5 H" "c-home"
                              > translate-key "C-[ [ 1 ; 5 F" "c-end"
                              >
                              > translate-key "C-[ [ 5 ; 5 ~" "C-page-up"
                              > translate-key "C-[ [ 6 ; 5 ~" "C-page-down"
                              > translate-key "C-[ [ 2 9 ~" "menu" ; context menu key
                              >
                              >

                              Hi Thomas,

                              This is a nice list. Can we gain your permission to add this to the
                              translate-key help page?

                              Thanks
                              Jon.
                            • dsjkvf
                              ... in fact, dsjkvf is a result of random keypresses :). ... exactly: i ve also tried another ssh-client (MindTerm), and it sends different sequences (^[[11~
                              Message 14 of 16 , Oct 28, 2006
                              • 0 Attachment
                                On 10/27/06, Thomas Hundt <thundt@...> wrote:

                                > Hello again dsjkvf (that's not your real name, is it?? :-) How do you
                                > pronounce it?? :-) )

                                in fact, "dsjkvf" is a result of random keypresses :).

                                > The Alt key plus Fx comes up as Meta-Fx, so that works correctly.
                                > Ctrl plus Fx comes up as just plain Fx, so it's losing the Ctrl.

                                exactly: i've also tried another ssh-client (MindTerm), and it sends
                                different sequences (^[[11~ and ^[[11^ for F1 and C-F1 respectevly).

                                so, the problem seems to be in PuTTY itself :(. however, i do not know
                                any other free SSH-client for windows with such a set of functions :(.

                                > There is a Keyboard setting that says "The Function keys and keypad:
                                > ESC[n~" There are other possible values (Linux, Xterm R6, VT400, etc.)
                                > to play with. You can probably have some fun with that. Maybe you can
                                > find a setting that works better for you.

                                yes, Tom, i''ve tried that earlier -- with no positive results. now,
                                i've also tried to find out what exactly it sends with these settings
                                -- and the only setting which sends different strings is a SCO one,
                                which, however, seems to be quite incompatible with other software (i
                                mean, even if i could adopt it for ME via translate-key).

                                also, while we are here on topic, could you please explain me a bit:
                                with S-F1 you say you receive ^[[23~ (which is exactly the same that i
                                receive). but isn't it a sequence for F11? should it be this way?



                                dsjkvf
                              • Thomas Hundt
                                ... Yes!! I know!! It s screwy!! I suspect there were, once upon a time, keyboards which had F1-F10 and, if you hit them with Shift, F11-F20. And then
                                Message 15 of 16 , Oct 29, 2006
                                • 0 Attachment
                                  > also, while we are here on topic, could you please explain me a bit:
                                  > with S-F1 you say you receive ^[[23~ (which is exactly the same that i
                                  > receive). but isn't it a sequence for F11? should it be this way?

                                  Yes!! I know!! It's screwy!!

                                  I suspect there were, once upon a time, keyboards which had F1-F10 and,
                                  if you hit them with Shift, F11-F20. And then somebody decided to put
                                  F11 and F12 off there to the right. So now we are left with two ways to
                                  generate those keys.

                                  So then the interesting trivia question becomes: What happens when you
                                  hit Shift-F11 and Shift-F12? Does the keyboard explode? (No, it merely
                                  sends F11 and F12. Disappointing.)

                                  -Th
                                • Bryan Schofield
                                  If this is of help to anyone, these are the key translations I use to get ME working properly in console mode on Solaris 8.
                                  Message 16 of 16 , Oct 30, 2006
                                  • 0 Attachment
                                    If this is of help to anyone, these are the key translations I use to
                                    get ME working properly in console mode on Solaris 8.

                                    ;======================================================================
                                    ; Translations and Key bindings
                                    ;======================================================================
                                    ; Translation table for solaris 8
                                    ;
                                    ; F-Key translations
                                    ; f1 f2 f3 f4 f5 f6 f7 f8 f9 f10
                                    ; ^[OP ^[OQ ^[OR ^[OS ^[[15~ ^[[17~ ^[[18~ ^[[19~ ^[[20~ ^[[21~
                                    ; Shift ^[[23~ ^[[24~ ^[[25~ ^[[26~ ^[[28~ ^[[29~ ^[[31~ ^[[32~ ^[[33~ ^[[34~
                                    ; Control ^[[11^ ^[[12^ ^[[13^ ^[[14^ ^[[15^ ^[[17^ ^[[18^ ^[[19^ ^[[20^ ^[[21^
                                    ;
                                    ; Navigation Keys
                                    ; ins del home end pgup pgdn up down left right
                                    ; ^[[2~ ^[[3~ ^[[1~ ^[[4~ ^[[5~ ^[[6~ ^[[A ^[[B ^[[D ^[[C
                                    ; Shift ^[[2$ ^[[3$ ^[[1$ ^[[4$ ^[[5$ ^[[6$ ^[[a ^[[b ^[[d ^[[c
                                    ; Control ^[[2^ ^[[3^ ^[[1^ ^[[4^ ^[[5^ ^[[6^ ^[Oa ^[Ob ^[Od ^[Oc

                                    !if &band $system 0x001
                                    ; Apply key translations if in Terminal Mode

                                    translate-key "C-[ O P" "f1"
                                    translate-key "C-[ O Q" "f2"
                                    translate-key "C-[ O R" "f3"
                                    translate-key "C-[ O S" "f4"
                                    translate-key "C-[ [ 2 3 ~" "S-f1"
                                    translate-key "C-[ [ 2 4 ~" "S-f2"
                                    translate-key "C-[ [ 2 5 ~" "S-f3"
                                    translate-key "C-[ [ 2 6 ~" "S-f4"
                                    translate-key "C-[ [ 2 8 ~" "S-f5"
                                    translate-key "C-[ [ 2 9 ~" "S-f6"
                                    translate-key "C-[ [ 3 1 ~" "S-f7"
                                    translate-key "C-[ [ 3 2 ~" "S-f8"
                                    translate-key "C-[ [ 3 3 ~" "S-f9"
                                    translate-key "C-[ [ 3 4 ~" "S-f10"
                                    translate-key "C-[ [ 1 1 ^" "C-f1"
                                    translate-key "C-[ [ 1 2 ^" "C-f2"
                                    translate-key "C-[ [ 1 3 ^" "C-f3"
                                    translate-key "C-[ [ 1 4 ^" "C-f4"
                                    translate-key "C-[ [ 1 5 ^" "C-f5"
                                    translate-key "C-[ [ 1 7 ^" "C-f6"
                                    translate-key "C-[ [ 1 8 ^" "C-f7"
                                    translate-key "C-[ [ 1 9 ^" "C-f8"
                                    translate-key "C-[ [ 2 0 ^" "C-f9"
                                    translate-key "C-[ [ 2 1 ^" "C-f10"
                                    translate-key "C-[ [ 1 ~" "home"
                                    translate-key "C-[ [ 2 $" "S-insert"
                                    translate-key "C-[ [ 3 $" "S-delete"
                                    translate-key "C-[ [ 1 $" "S-home"
                                    translate-key "C-[ [ 4 $" "S-end"
                                    translate-key "C-[ [ 5 $" "S-page-up"
                                    translate-key "C-[ [ 6 $" "S-page-down"
                                    translate-key "C-[ [ a" "S-up"
                                    translate-key "C-[ [ b" "S-down"
                                    translate-key "C-[ [ d" "S-left"
                                    translate-key "C-[ [ c" "S-right"
                                    translate-key "C-[ [ 2 ^" "C-insert"
                                    translate-key "C-[ [ 3 ^" "C-delete"
                                    translate-key "C-[ [ 1 ^" "C-home"
                                    translate-key "C-[ [ 4 ^" "C-end"
                                    translate-key "C-[ [ 5 ^" "C-page-up"
                                    translate-key "C-[ [ 6 ^" "C-page-down"
                                    translate-key "C-[ O a" "C-up"
                                    translate-key "C-[ O b" "C-down"
                                    translate-key "C-[ O d" "C-left"
                                    translate-key "C-[ O c" "C-right"
                                    translate-key "\x7F" "backspace"
                                    translate-key "C-[ [ Z" "S-tab"
                                    !end
                                    ; End if terminal mode
                                  Your message has been successfully submitted and would be delivered to recipients shortly.