Loading ...
Sorry, an error occurred while loading the content.
 

Syntax highlight for ColdFusion -- minor problem

Expand Messages
  • Rick Owen
    I normally use a color scheme that made this difficult to notice. I changed to the default color scheme and it popped right out at me. The closing for a
    Message 1 of 5 , Sep 4, 2006
      I normally use a color scheme that made this difficult to notice.  I changed to the default color scheme and it popped right out at me.  The closing '>' for a CF tag is not being colored correctly.  If you look at the attached screen snippet, you can clearly see the difference between the CF coloring and the HTML coloring on the close in '>'.

      Thanks,
      Rick.

       


    • Jon Green
      ... Fix as attached. Jon. cd /home/jon/merep/me/macros/ gdiff --context --minimal --ignore-space-change --recursive /home/jon/merep/me/macros/hkcfms.emf~
      Message 2 of 5 , Sep 4, 2006
        Rick Owen wrote:
        > I normally use a color scheme that made this difficult to notice. I
        > changed to the default color scheme and it popped right out at me. The
        > closing '>' for a CF tag is not being colored correctly. If you look at
        > the attached screen snippet, you can clearly see the difference between
        > the CF coloring and the HTML coloring on the close in '>'.
        >
        > Thanks,
        > Rick.
        >
        >

        Fix as attached.
        Jon.
      • Rick Owen
        Thanks. It took me a minute to slip out of my Windows persona and drop back a decade to remember how to interpret diff output, but it was a good exercise. Now
        Message 3 of 5 , Sep 4, 2006
          Thanks. It took me a minute to slip out of my Windows persona and drop back a decade to remember how to interpret diff output, but it was a good exercise.

          Now I have a different problem.  When I do a restore session the file that is visible does not get syntax highlighted and in the case of a .cfm file as the visible file me reports an error with the hkcfm.emf file.  That was apparently the source of the problem that I encountered when I very first try session restore.  I've attached a screen capture of the message that I get, although there is no error in the file because if I exit and then restart ME without restoring my session and then open a .cfm file there is no error.

          Again, the error only occurs on the file type of the file that is visible.  If I have a .cfm file open and a .emf file, and the .emf file is the one that is visible when I exit, when I restore my session the .emf has *no* syntax highlighting while the .cfm is highlighted just fine.

          Thanks,
          Rick.

        • Steven Phillips
          I think this problem is caused by your setup rather than a general problem, in an earlier email you made reference to a problem in mysql.emf and I believe
          Message 4 of 5 , Sep 4, 2006
            I think this problem is caused by your setup rather than a general problem, in
            an earlier email you made reference to 'a problem in mysql.emf' and I believe
            this is the cause of the hilighting & -c issues.

            To prove this try moving all your my*.emf files out of the way and testing
            again, if it now works the problem lies in your customerisation files being
            incompatible with the new release.

            To fix start a clean (empty) me session, load in an SQL file (which will
            execute hksql.emf & mysql.emf) and get the line number from the error message.
            Hopefully when you load mysql.emf and go to the line you will be able to work
            out what is wrong.

            If none of the above is right, try starting a clean me session, load 2 emf
            files *only* exit and restart, does this still reproduce the issue? Try the
            same thing for 2 cfm files etc until you manage to reproduce the issue (it is
            unlikely to happen for all files otherwise I would be able to reproduce it :)

            Steve


            > Subject: [jasspa] Another session restore problem...
            > From: Rick Owen <rickowen@...>
            > Date: Tuesday, September 5, 2006, 1:36:11 AM
            > To: jasspa@yahoogroups.com
            >
            > Thanks. It took me a minute to slip out of my Windows persona and drop back
            > a decade to remember how to interpret diff output, but it was a good exercise.

            > Now I have a different problem.  When I do a restore session the file that
            > is visible does not get syntax highlighted and in the case of a .cfm file as
            > the visible file me reports an error with the hkcfm.emf file.  That was
            > apparently the source of the problem that I encountered when I very first
            > try session restore.  I've attached a screen capture of the message that I
            > get, although there is no error in the file because if I exit and then
            > restart ME without restoring my session and then open a .cfm file there is no error.

            > Again, the error only occurs on the file type of the file that is visible. 
            > If I have a .cfm file open and a .emf file, and the .emf file is the one
            > that is visible when I exit, when I restore my session the .emf has *no*
            > syntax highlighting while the .cfm is highlighted just fine.

            > Thanks,
            > Rick.

            >
            >
          • Rick Owen
            Steve, I did try this and the results were the same as I reported before. I don t think it s an issue with my myxxx.emf files because it only affects the
            Message 5 of 5 , Sep 5, 2006

               Steve,

              I did try this and the results were the same as I reported before. I don't think it's an issue with my "myxxx.emf" files because it only affects the file that is visible when ME starts up, regardless of the type of file that it is.  For example, I just edited the hkcfms.emf file to add the fix that Jon sent to me.  I exited with hkcfms.emf as the buffer that was being displayed.  I exited and then restored my session and now there is no syntax highlighting for .emf files.  Even if I load an .emf file that I've never edited before, it will not syntax highlight.

              The only time I get the error message to which you refer is if a .cfm file is restored as the visible file.

              I did try this with none of my ".emf" in the startup directory: started up ME with no session restore and only loaded hkcfms.emf and hkperl.emf and then exited.  Started ME again, this time with session restore.  Neither hkperl.emf, nor hkcfms.emf is syntax highlighted and any other .emf loaded during that session will not be syntax highlighted either.

              Let me know what other information you need.  I'll be glad to help however I can.

              Rick.

              ----- Original Message ----
              From: Steven Phillips <bill@...>
              To: Rick Owen <jasspa@yahoogroups.com>
              Sent: Monday, September 4, 2006 11:02:13 PM
              Subject: Re: [jasspa] Another session restore problem...

              I think this problem is caused by your setup rather than a general problem, in
              an earlier email you made reference to 'a problem in mysql.emf' and I believe
              this is the cause of the hilighting & -c issues.

              To prove this try moving all your my*.emf files out of the way and testing
              again, if it now works the problem lies in your customerisation files being
              incompatible with the new release.

              To fix start a clean (empty) me session, load in an SQL file (which will
              execute hksql.emf & mysql.emf) and get the line number from the error message.
              Hopefully when you load mysql.emf and go to the line you will be able to work
              out what is wrong.

              If none of the above is right, try starting a clean me session, load 2 emf
              files *only* exit and restart, does this still reproduce the issue? Try the
              same thing for 2 cfm files etc until you manage to reproduce the issue (it is
              unlikely to happen for all files otherwise I would be able to reproduce it :)

              Steve


              > Subject: [jasspa] Another session restore problem...
              > From: Rick Owen <rickowen@...>
              > Date:
              Tuesday, September 5, 2006, 1:36:11 AM
              > To: jasspa@yahoogroups.com
              >  
              > Thanks. It took me a minute to slip out of my Windows persona and drop back
              > a decade to remember how to interpret diff output, but it was a good exercise.

              > Now I have a different problem.  When I do a restore session the file that
              > is visible does not get syntax highlighted and in the case of a .cfm file as
              > the visible file me reports an error with the hkcfm.emf file.  That was
              > apparently the source of the problem that I encountered when I very first
              > try session restore.  I've attached a screen capture of the message that I
              > get, although there is no error in the file because if I exit and then
              > restart ME without restoring my session and then open a .cfm file there is no error.

              > Again, the error only occurs on the file type of the file that is visible. 
              > If I have a .cfm
              file open and a .emf file,  and the .emf file is the one
              > that is visible when I exit, when I restore my session the .emf has *no*
              > syntax highlighting while the .cfm is highlighted just fine.

              > Thanks,
              > Rick.

              >  
              >  




              __________________________________________________________________________

              This is an unmoderated list. JASSPA is not responsible for the content of
              any material posted to this list.

              To unsubscribe, send a mail message to

                  mailto:jasspa-unsubscribe@yahoogroups.com

              or visit http://groups.yahoo.com/group/jasspa and
              modify your account settings manually.



              Yahoo! Groups Links

              <*> To visit your group on the web, go to:
                  http://groups.yahoo.com/group/jasspa/

              <*> To unsubscribe from this group, send an email to:
                  jasspa-unsubscribe@yahoogroups.com

              <*> Your use of Yahoo! Groups is subject to:
                  http://docs.yahoo.com/info/terms/





            Your message has been successfully submitted and would be delivered to recipients shortly.