Loading ...
Sorry, an error occurred while loading the content.

-t c build problem on solaris and freebsd?

Expand Messages
  • Paul Holbrook
    I tried to build me from sourch on both a Solaris 8 and a FreeBSD 4.11 box. I used gcc in both cases, and on both boxes, I got the same error from my build.
    Message 1 of 5 , Jul 12, 2006
    • 0 Attachment
      I tried to build me from sourch on both a Solaris 8 and a FreeBSD 4.11
      box.

      I used gcc in both cases, and on both boxes, I got the same error from
      my build. Here's the freebsd version:

      ./build -t c
      make -f freebsd.mak mec

      <build lines excluded - no errors>

      cc -O2 -DNDEBUG=1 -D_FREEBSD -I. -D_ME_CONSOLE -o next.oc -c next.c
      cc -O2 -DNDEBUG=1 -D_FREEBSD -I. -D_ME_CONSOLE -o osd.oc -c osd.c
      osd.c:5752: macro `TTallKeysFlush' used without args
      *** Error code 1


      I found a reference to TTallKeysFlush on this group back in May 05,
      but that was building the ne version; I can build -ne with no problem.

      Any idea what this might be?

      -- Paul
    • Phillips, Steven
      Paul, I do not know the cause and will look into this problem, however as a temporary fix please remove the one use of this function from osd.c (simply remove
      Message 2 of 5 , Jul 12, 2006
      • 0 Attachment
        Paul,

        I do not know the cause and will look into this problem, however as a
        temporary fix please remove the one use of this function from osd.c
        (simply remove the line) and build. Please put the line back if you
        build a version with mouse support (i.e. '-t w*' or any windows
        version).

        Steve

        > -----Original Message-----
        > From: jasspa@yahoogroups.com [mailto:jasspa@yahoogroups.com]
        > On Behalf Of Paul Holbrook
        > Sent: 12 July 2006 15:38
        > To: jasspa@yahoogroups.com
        > Subject: [jasspa] -t c build problem on solaris and freebsd?
        >
        > I tried to build me from sourch on both a Solaris 8 and a
        > FreeBSD 4.11 box.
        >
        > I used gcc in both cases, and on both boxes, I got the same
        > error from my build. Here's the freebsd version:
        >
        > ./build -t c
        > make -f freebsd.mak mec
        >
        > <build lines excluded - no errors>
        >
        > cc -O2 -DNDEBUG=1 -D_FREEBSD -I. -D_ME_CONSOLE -o next.oc
        > -c next.c cc -O2 -DNDEBUG=1 -D_FREEBSD -I. -D_ME_CONSOLE -o
        > osd.oc -c osd.c
        > osd.c:5752: macro `TTallKeysFlush' used without args
        > *** Error code 1
        >
        >
        > I found a reference to TTallKeysFlush on this group back in
        > May 05, but that was building the ne version; I can build -ne
        > with no problem.
        >
        > Any idea what this might be?
        >
        > -- Paul
        >
        >
        >
        >
        >
        >
        > ------------------------ Yahoo! Groups Sponsor
        > --------------------~--> Check out the new improvements in
        > Yahoo! Groups email.
        > http://us.click.yahoo.com/6pRQfA/fOaOAA/yQLSAA/89EolB/TM
        > --------------------------------------------------------------
        > ------~->
        >
        > ______________________________________________________________
        > ____________
        >
        > This is an unmoderated list. JASSPA is not responsible for
        > the content of any material posted to this list.
        >
        > To unsubscribe, send a mail message to
        >
        > mailto:jasspa-unsubscribe@yahoogroups.com
        >
        > or visit http://groups.yahoo.com/group/jasspa and modify your
        > account settings manually.
        >
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
        >
        >
      • Phillips, Steven
        Looking a little more closely at your printout, there is an obvious contradiction. The use of freebsd.mak and cc as the compile means that you are not
        Message 3 of 5 , Jul 12, 2006
        • 0 Attachment
          Looking a little more closely at your printout, there is an obvious
          contradiction. The use of 'freebsd.mak' and 'cc' as the compile means
          that you are not actually using gcc so the problem may be cause by the
          use of a duff compiler. Can you please send me the output of running 'cc
          -V', also try running 'build -t c -m freebsd.gmk' to force it to use the
          gcc compiler.

          Thanks,

          Steve

          > -----Original Message-----
          > From: jasspa@yahoogroups.com [mailto:jasspa@yahoogroups.com]
          > On Behalf Of Paul Holbrook
          > Sent: 12 July 2006 15:38
          > To: jasspa@yahoogroups.com
          > Subject: [jasspa] -t c build problem on solaris and freebsd?
          >
          > I tried to build me from sourch on both a Solaris 8 and a
          > FreeBSD 4.11 box.
          >
          > I used gcc in both cases, and on both boxes, I got the same
          > error from my build. Here's the freebsd version:
          >
          > ./build -t c
          > make -f freebsd.mak mec
          >
          > <build lines excluded - no errors>
          >
          > cc -O2 -DNDEBUG=1 -D_FREEBSD -I. -D_ME_CONSOLE -o next.oc
          > -c next.c cc -O2 -DNDEBUG=1 -D_FREEBSD -I. -D_ME_CONSOLE -o
          > osd.oc -c osd.c
          > osd.c:5752: macro `TTallKeysFlush' used without args
          > *** Error code 1
          >
          >
          > I found a reference to TTallKeysFlush on this group back in
          > May 05, but that was building the ne version; I can build -ne
          > with no problem.
          >
          > Any idea what this might be?
          >
          > -- Paul
          >
          >
          >
          >
          >
          >
          > ------------------------ Yahoo! Groups Sponsor
          > --------------------~--> Check out the new improvements in
          > Yahoo! Groups email.
          > http://us.click.yahoo.com/6pRQfA/fOaOAA/yQLSAA/89EolB/TM
          > --------------------------------------------------------------
          > ------~->
          >
          > ______________________________________________________________
          > ____________
          >
          > This is an unmoderated list. JASSPA is not responsible for
          > the content of any material posted to this list.
          >
          > To unsubscribe, send a mail message to
          >
          > mailto:jasspa-unsubscribe@yahoogroups.com
          >
          > or visit http://groups.yahoo.com/group/jasspa and modify your
          > account settings manually.
          >
          >
          >
          > Yahoo! Groups Links
          >
          >
          >
          >
          >
          >
        • Jon Green
          ... The same applies to Solaris if you are using Sun compiler (which I assume you are because it is much better). If I recall this might have been patched
          Message 4 of 5 , Jul 12, 2006
          • 0 Attachment
            Phillips, Steven wrote:
            > Looking a little more closely at your printout, there is an obvious
            > contradiction. The use of 'freebsd.mak' and 'cc' as the compile means
            > that you are not actually using gcc so the problem may be cause by the
            > use of a duff compiler. Can you please send me the output of running 'cc
            > -V', also try running 'build -t c -m freebsd.gmk' to force it to use the
            > gcc compiler.
            >
            > Thanks,
            >
            > Steve

            The same applies to Solaris if you are using Sun compiler (which I
            assume you are because it is much better). If I recall this might have
            been patched after the 05/05 release. Could try the later source:

            http://www.jasspa.com/development/

            Jon.
          • Paul Holbrook
            Removing that line allowed it to compile osd.c. I found one more gotcha -- compiling either -t c or -ne, I get the following error: D_NANOEMACS -D_ME_CONSOLE
            Message 5 of 5 , Jul 12, 2006
            • 0 Attachment
              Removing that line allowed it to compile osd.c.

              I found one more gotcha -- compiling either -t c or -ne, I get the
              following error:

              D_NANOEMACS -D_ME_CONSOLE -o unixterm.on -c unixterm.c
              unixterm.c:54: X11/Sunkeysym.h: No such file or directory
              make: *** [unixterm.on] Error 1

              This is because the machine I'm building on has no X sources or
              headers - a deliberate choice. It's admittedly an odd case. But if
              you're building -ne or -t c, you shouldn't require anything from X.

              Using the same suggestion, commenting out the include allowed the
              compile to finish.

              --- In jasspa@yahoogroups.com, "Phillips, Steven" <sphillips@...> wrote:
              >
              > Paul,
              >
              > I do not know the cause and will look into this problem, however as a
              > temporary fix please remove the one use of this function from osd.c
              > (simply remove the line) and build. Please put the line back if you
              > build a version with mouse support (i.e. '-t w*' or any windows
              > version).
              >
              > Steve
              >
              > D_NANOEMACS -D_ME_CONSOLE -o unixterm.on -c unixterm.c
              unixterm.c:54: X11/Sunkeysym.h: No such file or directory
              make: *** [unixterm.on] Error 1
            Your message has been successfully submitted and would be delivered to recipients shortly.