Loading ...
Sorry, an error occurred while loading the content.

Suppress EOF trailing newline?

Expand Messages
  • Thomas Hundt
    ME insists that all text files shall end with a newline. To the point of adding one, free of charge, even when the file didn t come with one. Unfortunately,
    Message 1 of 2 , Jun 11, 2006
    • 0 Attachment
      ME insists that all text files shall end with a newline. To the point
      of adding one, free of charge, even when the file didn't come with one.

      Unfortunately, this screws up many programs that import data into a
      database. (Today's example is Intellisync for BlackBerry.) It sees the
      newline and thinks, "Oh, there's another line". And promptly complains
      because it can't find any fields.

      Often, I can fudge things by manually inserting a ^Z before that newline
      (this works for Windows programs). But I don't feel like I should have
      to do this every time.

      Is there any way to turn this behavior off?
      (If not, I'd like to request it.)

      Cheers

      -Th
    • Phillips, Steven
      Tom, ME does not insist, it is simply the default behaviour to terminate a line created in ME with a n (as per any editor), you should find that for any text
      Message 2 of 2 , Jun 12, 2006
      • 0 Attachment
        Tom,

        ME does not insist, it is simply the default behaviour to terminate a
        line created in ME with a \n (as per any editor), you should find that
        for any text file (i.e. does not contain nasty chars) loading it into ME
        and saving will produce the same file and if not I would be interested
        in the file as it may be a bug.

        You can disable the writing of the new-line char for any line by setting
        bit 0x10 of variable $line-flags, i.e. try loading this file, go to the
        last but one line (the last line is always an empty place holder line
        which is not written) and execute the following macro code:

        set-variable $line-flags &bor 0x10 $line-flags

        Steve

        > -----Original Message-----
        > From: jasspa@yahoogroups.com [mailto:jasspa@yahoogroups.com]
        > On Behalf Of Thomas Hundt
        > Sent: 12 June 2006 02:37
        > To: JASSPA MicroEmacs Mailing List (W)
        > Subject: [jasspa] Suppress EOF trailing newline?
        >
        > ME insists that all text files shall end with a newline. To
        > the point of adding one, free of charge, even when the file
        > didn't come with one.
        >
        > Unfortunately, this screws up many programs that import data
        > into a database. (Today's example is Intellisync for
        > BlackBerry.) It sees the newline and thinks, "Oh, there's
        > another line". And promptly complains because it can't find
        > any fields.
        >
        > Often, I can fudge things by manually inserting a ^Z before
        > that newline (this works for Windows programs). But I don't
        > feel like I should have to do this every time.
        >
        > Is there any way to turn this behavior off?
        > (If not, I'd like to request it.)
        >
        > Cheers
        >
        > -Th
        >
        >
        > ------------------------ Yahoo! Groups Sponsor
        > --------------------~--> Get to your groups with one click.
        > Know instantly when new email arrives
        > http://us.click.yahoo.com/.7bhrC/MGxNAA/yQLSAA/89EolB/TM
        > --------------------------------------------------------------
        > ------~->
        >
        > ______________________________________________________________
        > ____________
        >
        > This is an unmoderated list. JASSPA is not responsible for
        > the content of any material posted to this list.
        >
        > To unsubscribe, send a mail message to
        >
        > mailto:jasspa-unsubscribe@yahoogroups.com
        >
        > or visit http://groups.yahoo.com/group/jasspa and modify your
        > account settings manually.
        >
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
        >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.