Loading ...
Sorry, an error occurred while loading the content.

[jasspa] Re: Suse-Linux and ME-Linux

Expand Messages
  • Jon
    Concerning KDE colors and fonts. Look at www.kde.org in the FAQ s 11.2, and I quote from that page the following. Regards Jon. ... 11.2 My non-KDE apps like
    Message 1 of 3 , Jan 30, 2000
    • 0 Attachment
      Concerning KDE colors and fonts.

      Look at www.kde.org in the FAQ's 11.2, and I quote from
      that page the following.

      Regards
      Jon.

      ----------- Copied from www.kde.org/FAQ/11.2 -------------

      11.2 My non-KDE apps like emacs and kterm are running amok with large
      windows and strange fonts!

      It probably has to do with KDE trying to "apply KDE defaults to non-KDE apps",
      which means it uses xrdb to apply X defaults that are supposed to mimic the
      color, font and other settings that you have set for KDE. However, experience
      tells us that this usually breaks things, particularly if you have carefully
      tuned the X resources of your non-KDE apps.

      The official solution is to bring up the Settings->Desktop->Style config panel
      and disable the "apply KDE settings to non-KDE apps" checkbox. If the new
      setting does not seem to stick, make sure you have clicked 'ok' directly without
      clicking 'apply' after making the change. If it still refuses to work, there's a
      brute-force solution: rename or delete the
      $KDEDIR/share/apps/kdisplay/app-defaults directory. This will prevent KDE from
      finding the X resource files it applies, and solve the problem. You have to exit
      your session and log back in for everything to return to normal.

      If you don't want to, or can't rename or delete the system-wide app-defaults
      directory, you can always copy it to your personal kde directory (eg.
      $HOME/.kde/share/apps/kdisplay/app-defaults) and then edit/add/remove
      files to taste.

      The Settings->Desktop->Style panel exists in 1.1pre2, I am not sure of its
      location in previous versions (it exists since around 1.0).

      Detlef Groth wrote:
      >
      > Hello Jon, hello all the others,
      >
      > 27.01.2000
      > The problem was the KDE-window-manager. If I changed to fvwm95, ME comes up
      > properly. If I was switching on the fly to KDE with an open ME-session ME is
      > imported properly into the KDE-session, but I can't start a new ME-session
      > correctly inside KDE. I will try to configure it properly in KDE also.
      >
      > By the way:
      > Which is a good font for Linux. Courier New from Win is the only one I
      > really like. Courier in Linux looks somewhat ugly.
      >
      > However, I will compile the new sources in the way described below again.
      >
      > 29.1.2000
      >
      > I switched from Suse-Linux 6.1 to 6.2. Now ME was starting properly in all
      > 4 Window-Managers (fvwm, fvwm2, fvwm95, KDE). In KDE then I tried several
      > fonts and many of them were showing these behaviour of disturbed colors.
      > The standard-fonts as described in the manual were working properly.
      > (-*-fixed-medium-r-normal--15-*-*-*-c-90-iso8859-1). There is only a last
      > thing with KDE, I can't close the KDE-session if ME remains open. So I
      > must close ME or KDE hangs. It's a pitty, there will be no ME-session
      > inside a KDE-session.
      >
      > I was further trying to adjust the MEPATH-variables in the .bashrc but
      > it get it not work, finally I end up with a shell script, a one liner:
      >
      > #!/bin/sh
      > MEPATH=/root/microemacs me -c
      >
      > An alias is also working, but it blocks the Bash.
      >
      > The other PATH(/usr/local/microemacs) seems to be inbuild into ME.
      >
      > finally: I could compile the stuff on Suse 6.1 and later also on 6.2 with:
      >
      > LDFLAGS = -L/usr/X11R6/lib -L/usr/lib/termcap
      >
      > as proposed by John. The new melinux22_20000128 executable is working
      > properly.
      >
      > So on monday I can start MEing with Linux.
      >
      > Thank you very much,
      > Have a nice weekend,
      >
      > Detlef
      > <snip>
      >
      > > >
      > > > for work I need a running ME on SUSE 6.1 Kernel 2.2.7.
      > > > I tried the melinux20, and it seems to work properly but I can't work
      > > > because the screen is worse handled. The colors of the OSD are not
      > > > refreshed and all is very coloured. So I can't handle the setup. May be a
      > > > correct erf-file could help. I also tried to compile a new version but
      > > > the following errors were observed:
      > >
      >
      > > Note that all of the work that I do on Linux is on Slackware 4.0,
      > > my preferred distribution. In the very first instance before trying
      > > to guess if anything is wrong I would suggest getting the build
      > > working. If this exhibits the same behaviour then try the following:-
      > >
      > > Bad colours would tend to indicate that "me" cannot get all of
      > > the colours it wants. However, since it only requires 20 or
      > > so I would guess that you are running a 256 colour
      > > system only ?? At the moment we do not do any palette switching on X.
      > > instead we find the nearest colour. I suggest shuting down any
      > > hungry colour applications such as Netscape etc. and see what it
      > > does then. If the screen comes up correctly then we will have
      > > to address the palette issue further. Alternatively try
      > > increasing the colour depth of the X server.
      >
      > >
      > > As for your build errors. I would expect you to have a
      > >
      > > /usr/lib/libtermcap.a
      > > OR /usr/lib/libtermcap.so
      > >
      > > or both. From below, try adding a "-L/usr/lib/termcap" to
      > > the LDFLAGS, this should then find the static termcap library
      > > and link it in. I cannot tell you if this is a good termcap
      > > library to use because I'm not familer with the SUSE
      > > distribution.
      > >
      > > If this works then we may need to consider shipping a
      > > "linuxsuse.gmk"
      >
      > <snip>
      > > Jon
      >
      > ------------------------------------------------------------------------
      > __________________________________________________________________________
      >
      > This is an unmoderated list. JASSPA is not responsible for the content of
      > any material posted to this list.
      >
      > ------------------------------------------------------------------------
      > Want to send money instantly to anyone, anywhere, anytime?
      > You can today at X.com - and we'll give you $20 to try it! Sign
      > up today at X.com. It's quick, free, & there's no obligation!
      > http://click.egroups.com/1/332/4/_/6009/_/949106589/
      >
      > -- Check out your group's private Chat room
      > -- http://www.egroups.com/ChatPage?listName=jasspa&m=1
    Your message has been successfully submitted and would be delivered to recipients shortly.