Loading ...
Sorry, an error occurred while loading the content.

Re: [jasspa] mode selection based on extension / contents

Expand Messages
  • Thomas Hundt
    Upon further investigation, I think the specific issue here is this bug in me.emf (line 294): -1 add-file-hook
    Message 1 of 3 , Jun 6, 2006
    • 0 Attachment
      Upon further investigation, I think the specific issue here is this bug
      in me.emf (line 294):

      -1 add-file-hook "<?xml" fhook-xml ;...

      and the '?' is being picked up as a regexp expression ("match zero or
      one '<'"), which is fixed when I change it to

      -1 add-file-hook "<\\?xml" fhook-xml ;...

      (Two backslashes seem to be needed here. Not sure why. It correctly
      matches "<?xml" only with two of them.)

      -Th


      Thomas Hundt wrote:
      > While we're on the subject of "modes", I'm having a little issue:
      > Apparently the mode selection by contents (tag inside the file)
      > overrides the filename extension.
      >
      > For example, when I open a file named XMLMessage.java which starts with
      > package com.covaluate.xmlmessage;
      > import java.io.IOException;
      > ME thinks it is xml. Not helpful.
      >
      > Similarly, if I have a text file that starts with
      > i wish this would open as text, not xml
      > i wish this would open as text, not xml
      > i wish this would open as text, not xml
      > i wish this would open as text, not xml
      > i wish this would open as text, not xml
      > it gets opened in XML mode. Again, not helpful.
      >
      > IMO the file extension should override any tags.
      >
      > And, since there isn't a way to switch modes once a file is loaded (a
      > feature I would vote for in the redesign -- or maybe it exists already
      > and, as usual, I don't know about it? ;-) ), the only workaround is to
      > add a couple of bogus lines at the beginning of a file.
      >
      > -Th
      >
    • Phillips, Steven
      Tom, Thanks for reporting your findings, this will be fixed in the next release. You need 2 s because the macro parser requires s in strings to be
      Message 2 of 3 , Jun 6, 2006
      • 0 Attachment
        Tom,

        Thanks for reporting your findings, this will be fixed in the next
        release. You need 2 '\'s because the macro parser requires '\'s in
        strings to be backslash quoted (so '\"' can be used to include a '"'
        char - standard C format), i.e. "F\\O\"O" is parsed to the string F\O"O

        Steve

        > -----Original Message-----
        > From: jasspa@yahoogroups.com [mailto:jasspa@yahoogroups.com]
        > On Behalf Of Thomas Hundt
        > Sent: 06 June 2006 23:18
        > To: jasspa@yahoogroups.com
        > Subject: Re: [jasspa] mode selection based on extension / contents
        >
        > Upon further investigation, I think the specific issue here
        > is this bug in me.emf (line 294):
        >
        > -1 add-file-hook "<?xml" fhook-xml ;...
        >
        > and the '?' is being picked up as a regexp expression ("match
        > zero or one '<'"), which is fixed when I change it to
        >
        > -1 add-file-hook "<\\?xml" fhook-xml ;...
        >
        > (Two backslashes seem to be needed here. Not sure why. It
        > correctly matches "<?xml" only with two of them.)
        >
        > -Th
        >
        >
        > Thomas Hundt wrote:
        > > While we're on the subject of "modes", I'm having a little issue:
        > > Apparently the mode selection by contents (tag inside the file)
        > > overrides the filename extension.
        > >
        > > For example, when I open a file named XMLMessage.java which
        > starts with
        > > package com.covaluate.xmlmessage;
        > > import java.io.IOException;
        > > ME thinks it is xml. Not helpful.
        > >
        > > Similarly, if I have a text file that starts with
        > > i wish this would open as text, not xml
        > > i wish this would open as text, not xml
        > > i wish this would open as text, not xml
        > > i wish this would open as text, not xml
        > > i wish this would open as text, not xml it gets opened
        > in XML mode.
        > > Again, not helpful.
        > >
        > > IMO the file extension should override any tags.
        > >
        > > And, since there isn't a way to switch modes once a file is
        > loaded (a
        > > feature I would vote for in the redesign -- or maybe it
        > exists already
        > > and, as usual, I don't know about it? ;-) ), the only
        > workaround is to
        > > add a couple of bogus lines at the beginning of a file.
        > >
        > > -Th
        > >
        >
        >
        > ------------------------ Yahoo! Groups Sponsor
        > --------------------~--> You can search right from your
        > browser? It's easy and it's free. See how.
        > http://us.click.yahoo.com/_7bhrC/NGxNAA/yQLSAA/89EolB/TM
        > --------------------------------------------------------------
        > ------~->
        >
        > ______________________________________________________________
        > ____________
        >
        > This is an unmoderated list. JASSPA is not responsible for
        > the content of any material posted to this list.
        >
        > To unsubscribe, send a mail message to
        >
        > mailto:jasspa-unsubscribe@yahoogroups.com
        >
        > or visit http://groups.yahoo.com/group/jasspa and modify your
        > account settings manually.
        >
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
        >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.