Loading ...
Sorry, an error occurred while loading the content.

RE: [jasspa] ME and FreeBSD

Expand Messages
  • Phillips, Steven
    as 1. Mouse support in termcap has not been implemented although I think I have the code to do it somewhere so if this is required it could be done. 2. Do you
    Message 1 of 4 , Apr 26, 2006
    • 0 Attachment
      as

      1. Mouse support in termcap has not been implemented although I think I
      have the code to do it somewhere so if this is required it could be
      done.

      2. Do you have the same problem when you split the main window
      vertically (C-x 3)? I think you will.

      I think the problem is caused by the scroll bar scheme which becomes
      invisible when restricted to only 8 colors, the trick is coming up with
      a scheme the is visible and not repulsive :) Can you please try the
      attached version of the default white on black and let me know if this
      fixes the problem. You can use the scheme-editor to edit the current
      scheme, the scheme to change is Standard/Scroll Bar, but without mouse
      support using this dialog is a little tricky:)

      Steve

      > -----Original Message-----
      > From: jasspa@yahoogroups.com [mailto:jasspa@yahoogroups.com]
      > On Behalf Of Alex Sa
      > Sent: 26 April 2006 09:10
      > To: jasspa@yahoogroups.com
      > Subject: [jasspa] ME and FreeBSD
      >
      > hello,
      >
      > i've just downloaded and installed ME for FreeBSD
      > (http://www.jasspa.com/downfreebsd.html), but now i've got a
      > few questions and would be very grateful if you could help me:
      >
      > 0. i'm using 5.4-RELEASE and echo $TERM reports xterm-color
      > 1. i cannot select User Setup -> Mouse -> Enable Mouse
      > checkbox (mouse does work in termninal -- e.g., in midnight
      > commander) 2. when i select User Setup -> Platform -> Termcap
      > Color i do have a coloured ME, but while using Default White
      > on Black scheme in Notes i have no separator between tree and
      > notes panes (i assume, it's black, as screen itself) -- how
      > can i fix the color of this separator?
      >
      > thank you :).
      >
      >
      > --
      > as
      >
      >
      > ______________________________________________________________
      > ____________
      >
      > This is an unmoderated list. JASSPA is not responsible for
      > the content of any material posted to this list.
      >
      > To unsubscribe, send a mail message to
      >
      > mailto:jasspa-unsubscribe@yahoogroups.com
      >
      > or visit http://groups.yahoo.com/group/jasspa and modify your
      > account settings manually.
      >
      >
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      >
    • Thomas Hundt
      I can replicate this. The schemed.emf you sent works. Also, color schemes termcap and basic black on creme work. (It looks like a blank space character
      Message 2 of 4 , Apr 26, 2006
      • 0 Attachment
        I can replicate this.

        The schemed.emf you sent works. Also, color schemes "termcap" and
        "basic black on creme" work. (It looks like a blank space character is
        being displayed. Could that have something to do with it? I tried to
        find it in $window-chars but could not.)

        I have had problems with colors in termcap, when the terminal emulator
        (putty) doesn't distinguish the bold from the regular colors. I've had
        to go in and redefine the bold colors. This still means that things
        like highlighting a region or the current line don't work.

        I'd be very interested in mouse support for termcap. I use termcap mode
        all the time (such as when going through a slow network connection, or
        when committing something in version control -- I set my EDITOR to 'me
        -n' so that things like that don't pop up a full GUI version).

        (BTW, the scheme editor is next to impossible to use without the mouse.
        And all the setup stuff is a pain, until you figure out that the arrow
        keys work, if you're lucky enough to have some and a decent terminal
        emulator to send them. In my case this took years. So, I learned to
        write really elaborate company setup files... ;-) )

        Cheers

        -Th



        Phillips, Steven wrote, On 4/26/2006 4:11 AM:
        > as
        >
        > 1. Mouse support in termcap has not been implemented although I think I
        > have the code to do it somewhere so if this is required it could be
        > done.
        >
        > 2. Do you have the same problem when you split the main window
        > vertically (C-x 3)? I think you will.
        >
        > I think the problem is caused by the scroll bar scheme which becomes
        > invisible when restricted to only 8 colors, the trick is coming up with
        > a scheme the is visible and not repulsive :) Can you please try the
        > attached version of the default white on black and let me know if this
        > fixes the problem. You can use the scheme-editor to edit the current
        > scheme, the scheme to change is Standard/Scroll Bar, but without mouse
        > support using this dialog is a little tricky:)
        >
        > Steve
        >
        >> -----Original Message-----
        >> From: jasspa@yahoogroups.com [mailto:jasspa@yahoogroups.com]
        >> On Behalf Of Alex Sa
        >> Sent: 26 April 2006 09:10
        >> To: jasspa@yahoogroups.com
        >> Subject: [jasspa] ME and FreeBSD
        >>
        >> hello,
        >>
        >> i've just downloaded and installed ME for FreeBSD
        >> (http://www.jasspa.com/downfreebsd.html), but now i've got a
        >> few questions and would be very grateful if you could help me:
        >>
        >> 0. i'm using 5.4-RELEASE and echo $TERM reports xterm-color
        >> 1. i cannot select User Setup -> Mouse -> Enable Mouse
        >> checkbox (mouse does work in termninal -- e.g., in midnight
        >> commander) 2. when i select User Setup -> Platform -> Termcap
        >> Color i do have a coloured ME, but while using Default White
        >> on Black scheme in Notes i have no separator between tree and
        >> notes panes (i assume, it's black, as screen itself) -- how
        >> can i fix the color of this separator?
        >>
        >> thank you :).
        >>
        >>
        >> --
        >> as
      • Alex Sa
        ... Steven, thank you for help and interest :) mouse support surely would be very helpful, i think ... your updated scheme indeed fixes it, thank you. -- as
        Message 3 of 4 , Apr 26, 2006
        • 0 Attachment
          On 4/26/06, Phillips, Steven <sphillips@...> wrote:

          > 1. Mouse support in termcap has not been implemented although I think I
          > have the code to do it somewhere so if this is required it could be
          > done.

          Steven, thank you for help and interest :)
          mouse support surely would be very helpful, i think

          > 2. Do you have the same problem when you split the main window
          > vertically (C-x 3)? I think you will.

          your updated scheme indeed fixes it, thank you.



          --
          as
        Your message has been successfully submitted and would be delivered to recipients shortly.