Loading ...
Sorry, an error occurred while loading the content.

Re: [jasspa] Auto indention is driving me crazy!!!!

Expand Messages
  • Steven Phillips
    999, You are not alone but you will be please to know that it is easily fixed (assuming you are using me0505 :). Try the following: - Make sure you have only
    Message 1 of 4 , Apr 7, 2006
    • 0 Attachment
      999,

      You are not alone but you will be please to know that it is easily fixed
      (assuming you are using me0505 :). Try the following:

      - Make sure you have only one session of ME running.

      - Load a Perl file

      - execute buffer-setup (Help -> Buffer Setup)

      - Disable 'Setup Auto Indent' and enable 'Indent' Buffer mode

      - Click on Current

      - Sigh in relief

      - Repeat for all other file types that are causing grief

      - Exit ME to ensure these setting are saved to your history file.

      Auto-indent will never bother you again!

      Steve

      > Subject: [jasspa] Auto indention is driving me crazy!!!!
      > From: smithno999 <smithno@...>
      > Date: Friday, April 7, 2006, 8:56:48 PM
      > To: jasspa@yahoogroups.com
      > At this point, I use ME for everything EXCEPT code. The only thing
      > stopping me from using it as my only editor is auto indention! When I
      > type a return on a indented line, it re-indents the current line to
      > match the prvious line, then inserts the new line indented to the new
      > indention. I read the FAQ and the help files and I can't come up with
      > a combination of settings that will just indent the NEXT line to match
      > the CURRENT line!

      > I even decided that I could live with no auto indents. I can't get
      > that to work either. I can get ME to not indent the next line, but it
      > reformatts the current line back to the margin.

      > I am experiencing this with Java and Perl files. Any ideas?

      > Based on this I would like to make an enhancement request to have a
      > checkbox in the user setup to make a TAB just put in a TAB character
      > with NO reformatting of lines!!!







      > __________________________________________________________________________

      > This is an unmoderated list. JASSPA is not responsible for the content of
      > any material posted to this list.

      > To unsubscribe, send a mail message to

      > mailto:jasspa-unsubscribe@yahoogroups.com

      > or visit http://groups.yahoo.com/group/jasspa and
      > modify your account settings manually.


      >
      > Yahoo! Groups Links



      >
    • Steven Phillips
      Ho, I should have also said... ... user-setup - General - Tab to Indent - set to Never Indent, however this only changes the behaviour of TAB so the
      Message 2 of 4 , Apr 7, 2006
      • 0 Attachment
        Ho, I should have also said...

        > Based on this I would like to make an enhancement request to have a
        > checkbox in the user setup to make a TAB just put in a TAB character
        > with NO reformatting of lines!!!

        user-setup -> General -> Tab to Indent - set to Never Indent, however this
        only changes the behaviour of TAB so the auto-indent on Enter would still get
        you!

        Steve



        > __________________________________________________________________________

        > This is an unmoderated list. JASSPA is not responsible for the content of
        > any material posted to this list.

        > To unsubscribe, send a mail message to

        > mailto:jasspa-unsubscribe@yahoogroups.com

        > or visit http://groups.yahoo.com/group/jasspa and
        > modify your account settings manually.


        >
        > Yahoo! Groups Links



        >
      • Jon Green
        ... In a java or perl buffer do the following: M-x buffer-setup OR Help- Buffer setup Uncheck Setup Auto Indent This turns off auto indent. Check Buffer
        Message 3 of 4 , Apr 7, 2006
        • 0 Attachment
          smithno999 wrote:
          > At this point, I use ME for everything EXCEPT code. The only thing
          > stopping me from using it as my only editor is auto indention! When I
          > type a return on a indented line, it re-indents the current line to
          > match the prvious line, then inserts the new line indented to the new
          > indention. I read the FAQ and the help files and I can't come up with
          > a combination of settings that will just indent the NEXT line to match
          > the CURRENT line!
          >
          > I even decided that I could live with no auto indents. I can't get
          > that to work either. I can get ME to not indent the next line, but it
          > reformatts the current line back to the margin.
          >
          > I am experiencing this with Java and Perl files. Any ideas?
          >
          > Based on this I would like to make an enhancement request to have a
          > checkbox in the user setup to make a TAB just put in a TAB character
          > with NO reformatting of lines!!!
          >
          >

          In a java or perl buffer do the following:

          M-x buffer-setup OR Help->Buffer setup

          Uncheck "Setup Auto Indent"

          This turns off auto indent.

          Check Buffer Modes "Indent"

          You need the buffer mode Indent on because when you do a CR then it
          drops to the next line and leaves the cursor aligned with the start of
          the text of the previous line. When this is off then it leaves the
          cursor at the start of the line.

          You say that you want literal TABs in the file, if this really is the
          case then set Buffer Modes "Tab" to 'off'. The default behaviour is to
          insert spaces and convert tabs to spaces using the indent width. (The
          advantage of this is that any file, irrespective of the indent width
          used will ALWAYS look the same in any editor even Microsoft notepad).
          You can set up your indent and TAB size in here.

          Once you have done this then all java/perl files will exhibit the
          behaviour that you require.

          I will update the documentation to make this explicitly clear, it
          certainly is not at the moment - sorry.

          Jon.
        Your message has been successfully submitted and would be delivered to recipients shortly.