Loading ...
Sorry, an error occurred while loading the content.

Re[2]: [jasspa] Execution of macro right before save of file

Expand Messages
  • Steven Phillips
    You noeed to only do the clean if the buffer is edited, i.e. check that the edit mode is enabled, i.e. try something like: define-macro my-save-buffer !if
    Message 1 of 7 , Nov 7, 2005
    • 0 Attachment
      You noeed to only do the clean if the buffer is edited, i.e. check that the
      edit mode is enabled, i.e. try something like:

      define-macro my-save-buffer
      !if &bmod "edit"
      !force clean
      !endif
      @# save-buffer @mna
      !emacro

      Similarly you should check whether "binary" (or "rbin") mode is NOT set.

      WRT. string-rectangle, is it possible you did not have a multiple lined region
      defined?

      Steve

      > Subject: [jasspa] Execution of macro right before save of file
      > From: Meino Christian Cramer <Meino.Cramer@...>
      > Date: Monday, November 7, 2005, 4:38:38 AM
      > To: jasspa@yahoogroups.com, bill@...
      > From: Steven Phillips <bill@...>
      > Subject: Re: [jasspa] Execution of macro right before save of file
      > Date: Tue, 1 Nov 2005 23:01:00 +0000

      > Hi Steve,

      > I have "tuned" your macro and wrote a similiar piece of code
      > to be executed when pressing "C-x C-c" -- unfortunately I got "problems" ;)

      > These are my current definitions

      > define-macro my-save-buffer
      > !force clean
      > @# save-buffer @mna
      > !emacro
      > global-bind-key my-save-buffer "C-x C-s"
      >
      > define-macro my-save-buffers-exit-emacs
      > !force clean
      > @# save-buffers-exit-emacs @mna
      > !emacro
      > global-bind-key my-save-buffers-exit-emacs "C-x C-c"


      > 1.) When loading a file, which has blanks before $, I get asked "save
      > buffer?" even when nothing was changed myself. It would
      > be nice, if this question could be skipped when the "clean"
      > command was the only one, which changes the buffer...
      > 2.) When loading binary files by accident or intentionally, the macro
      > should *not* clean anything...

      > I would be very happy for any hint to achieve this...

      > Happy MicroEmacsing!
      > Meino


      >> There is no built in mechanism at present although I can see a need of one.
      >> With the current release the best (and only) solution I can think of is to
      >> rebind the keys you use to save the buffer to a macro which first cleans the
      >> buffer, e.g.:
      >>
      >> define-macro my-save-buffer
      >> clean
      >> @# save-buffer @mna
      >> !emacro
      >> global-bind-key my-save-buffer "C-x C-s"
      >>
      >> (Note I have not tested this macro!)
      >>
      >> Steve
      >>



      > __________________________________________________________________________

      > This is an unmoderated list. JASSPA is not responsible for the content of
      > any material posted to this list.

      > To unsubscribe, send a mail message to

      > mailto:jasspa-unsubscribe@yahoogroups.com

      > or visit http://groups.yahoo.com/group/jasspa and
      > modify your account settings manually.


      >
      > Yahoo! Groups Links



      >
    Your message has been successfully submitted and would be delivered to recipients shortly.