Loading ...
Sorry, an error occurred while loading the content.

Indentation/Formatting Question

Expand Messages
  • Gadrin
    I m editing a .txt file that contains code on how to create an XML document. Despite this, ME thinks that the document is an XML file and is indenting some
    Message 1 of 5 , Oct 1, 2005
    • 0 Attachment
      I'm editing a .txt file that contains code on how to create an XML
      document.

      Despite this, ME thinks that the document is an XML file and is
      indenting some lines to the indent level of the previous line.

      I have code cut & pasted into the buffer and I'm documenting it line
      by line so some of it is indented heavily.

      I describe-variables and found:

      $fill-mode = "L"

      and indent isn't on (my buffer modes are: AaBMTtU) and like I said
      it's a .txt file extension.

      When I go up to TOOLS, the first option is XML TOOLS instead of text
      tools, which I'd normally use to left justify a block of text.

      Can you point me in the direction of where I need to go to eliminate
      this behavior ?

      I'd like to "turn off XML mode" and activate "text mode" if possible.
    • Thomas Hundt
      It obviously thinks this is an XML file. Perhaps something at the beginning of the file? Not just the extension ( .txt etc.) determines what ME thinks the
      Message 2 of 5 , Oct 1, 2005
      • 0 Attachment
        It obviously thinks this is an XML file.

        Perhaps something at the beginning of the file?

        Not just the extension (".txt" etc.) determines what ME thinks the file is!

        Did you read the manual about file hooks?
        Did you read the me.emf file?
        Did you do something like 'grep *.emf add-file-hook | grep -i xml' ?
        These are what I would try.

        -Th


        Gadrin wrote:
        > I'm editing a .txt file that contains code on how to create an XML
        > document.
        >
        > Despite this, ME thinks that the document is an XML file and is
        > indenting some lines to the indent level of the previous line.
        >
        > I have code cut & pasted into the buffer and I'm documenting it line
        > by line so some of it is indented heavily.
        >
        > I describe-variables and found:
        >
        > $fill-mode = "L"
        >
        > and indent isn't on (my buffer modes are: AaBMTtU) and like I said
        > it's a .txt file extension.
        >
        > When I go up to TOOLS, the first option is XML TOOLS instead of text
        > tools, which I'd normally use to left justify a block of text.
        >
        > Can you point me in the direction of where I need to go to eliminate
        > this behavior ?
        >
        > I'd like to "turn off XML mode" and activate "text mode" if possible.
        >
      • Gadrin
        so the string XML somewhere in the file will trigger this ? yuck. ok, I ll scope out the suggestions you made and see about cleaning up the .emf files.
        Message 3 of 5 , Oct 1, 2005
        • 0 Attachment
          so the string "XML" somewhere in the file will trigger this ?

          yuck.

          ok, I'll scope out the suggestions you made and see about cleaning
          up the .emf files.

          Gadrin

          --- In jasspa@yahoogroups.com, Thomas Hundt <thundt@s...> wrote:
          > It obviously thinks this is an XML file.
          >
          > Perhaps something at the beginning of the file?
          >
          > Not just the extension (".txt" etc.) determines what ME thinks the
          file is!
          >
          > Did you read the manual about file hooks?
          > Did you read the me.emf file?
          > Did you do something like 'grep *.emf add-file-hook | grep -i
          xml' ?
          > These are what I would try.
          >
          > -Th
        • Thomas Hundt
          I take it you refer to the grep command. Note that this is intended to print out any references to fhook-xml -- which is what you re looking for. -Th
          Message 4 of 5 , Oct 1, 2005
          • 0 Attachment
            I take it you refer to the grep command. Note that this is intended to
            print out any references to fhook-xml -- which is what you're looking for.

            -Th



            Gadrin wrote:
            > so the string "XML" somewhere in the file will trigger this ?
            >
            > yuck.
            >
            > ok, I'll scope out the suggestions you made and see about cleaning
            > up the .emf files.
            >
            > Gadrin
            >
            > --- In jasspa@yahoogroups.com, Thomas Hundt <thundt@s...> wrote:
            >
            >>It obviously thinks this is an XML file.
            >>
            >>Perhaps something at the beginning of the file?
            >>
            >>Not just the extension (".txt" etc.) determines what ME thinks the
            >
            > file is!
            >
            >>Did you read the manual about file hooks?
            >>Did you read the me.emf file?
            >>Did you do something like 'grep *.emf add-file-hook | grep -i
            >
            > xml' ?
            >
            >>These are what I would try.
            >>
            >>-Th
          • Gadrin
            ... intended to ... looking for. ... Yes, I have another editor that has a GREP utility (does more or less the same thing as ME) that I m a bit more used to.
            Message 5 of 5 , Oct 2, 2005
            • 0 Attachment
              --- In jasspa@yahoogroups.com, Thomas Hundt <thundt@s...> wrote:
              > I take it you refer to the grep command. Note that this is
              intended to
              > print out any references to fhook-xml -- which is what you're
              looking for.
              >
              > -Th
              >

              Yes, I have another editor that has a GREP utility (does more or
              less the same thing as ME) that I'm a bit more used to. ME has
              problems with filenames with spaces in them from the GREP output. (I
              have instructions to fix that, but haven't gotten to it yet).

              The file has no XML Declaration/Processing Instruction. However it
              does have the string "<HTML/>" in it. On the first line is the
              filename of XMLStarlet.txt.

              I think what I'll do is just place a !return in the .emf files and
              have it so that I call hkxml.emf explicitly when I need it.
              While I do work with XML files periodically, it's mostly done via
              the XMLDOM or using ME's keyboard macro to make a "quickie" data
              file for testing.

              I do much more work with .txt files and need the ability to format
              them more than the occaisional XML editing session.

              I'll also have to make a Winbatch syntax coloring file too. The XML
              highlighting scheme is _horrible_.
            Your message has been successfully submitted and would be delivered to recipients shortly.