Loading ...
Sorry, an error occurred while loading the content.

How do you ... ?

Expand Messages
  • Gadrin
    1) Everytime I use HELP, USER SETUP and PLATFORM to change something (or use USER SETUP at all, after hitting SAVE the program automatically loads a buffer
    Message 1 of 8 , Sep 5, 2005
    • 0 Attachment
      1) Everytime I use HELP, USER SETUP and PLATFORM to change something
      (or use USER SETUP at all, after hitting SAVE the program
      automatically loads a buffer called Owner.emf and displays it onscreen.

      I browsed thru the FAQs but didn't see anything obvious.

      Is there (hopefully) a way to disable this feature ?

      2) How do I get it to save my font-choices, which seem to work for
      that moment, but not for closing/restarting.

      change-font is perfect, but it doesn't save the choices for the next
      session.

      I've been plugging away using 1) above but it's kinda hit & miss.

      hrmmm, noticed that when I do use change-font it makes the change but
      resizes the app kinda like the old 3.8 version! LOL!

      anyway, despite these setbacks, I'm still liking this product quite a
      bit.

      Gadrin
    • Jon Green
      ... Unfortunately there is no way to turn this off. I think this is a bit of history before the .emf file was finally nailed to a defined position in the
      Message 2 of 8 , Sep 5, 2005
      • 0 Attachment
        Gadrin wrote:
        > 1) Everytime I use HELP, USER SETUP and PLATFORM to change something
        > (or use USER SETUP at all, after hitting SAVE the program
        > automatically loads a buffer called Owner.emf and displays it onscreen.
        >
        > I browsed thru the FAQs but didn't see anything obvious.
        >
        > Is there (hopefully) a way to disable this feature ?

        Unfortunately there is no way to turn this off.

        I think this is a bit of history before the <user>.emf file was finally nailed to a defined
        position in the file system. We should think about disabling this in the future.

        It is not really a problem once you are set up because you will not change your profile that
        often.


        >
        > 2) How do I get it to save my font-choices, which seem to work for
        > that moment, but not for closing/restarting.
        >
        > change-font is perfect, but it doesn't save the choices for the next
        > session.

        Use "Save" when you have finished in user-setup. If you quit out of user-setup then go back
        in and do the "Save".

        Note if you have multiple ME's open and change this stuff then the last one closed will
        write the configuration out so when you set up you only want one ME open then close down and
        re-start just to make sure you have written what you want.

        >
        > I've been plugging away using 1) above but it's kinda hit & miss.
        >
        > hrmmm, noticed that when I do use change-font it makes the change but
        > resizes the app kinda like the old 3.8 version! LOL!
        >
        > anyway, despite these setbacks, I'm still liking this product quite a
        > bit.

        Yes the screen does resize, this is because the width and height of the character grid take
        priority. Set your font up to the desired font then "Save" from user-set-up.
        Then resize the window to the kind of foot print you want on screen.

        Right Click on the mode line and select "Store Frame Size".

        Shut down ME and bring it back up. It should now have saved the font size and the frame will
        be restored to what you stored it as.

        Now you should be set up and will not really touch that stuff again.

        Jon.

        >
        > Gadrin
      • Gadrin
        ... screen. ... font size and the frame will ... again. ... Yes! that seems to work. I ve got the font/color schemes I want and dropping a file on the app
        Message 3 of 8 , Sep 5, 2005
        • 0 Attachment
          --- In jasspa@yahoogroups.com, Jon Green <jon@j...> wrote:
          > Then resize the window to the kind of foot print you want on
          screen.
          >
          > Right Click on the mode line and select "Store Frame Size".
          >
          > Shut down ME and bring it back up. It should now have saved the
          font size and the frame will
          > be restored to what you stored it as.
          >
          > Now you should be set up and will not really touch that stuff
          again.
          >
          > Jon.

          Yes! that seems to work.

          I've got the font/color schemes I want and dropping a file on the
          app doesn't seem to change the window size.

          Next, I need to see about getting the MS Windows selections going.

          The Tools seem a bit strange. I created one to run the ME.hlp file
          just to test, and it opens a buffer and splits the screen. I got rid
          of that, but then ME seems to hibernate until I close the help file.
          Oh well, lots of testing ahead!

          Thanks for your help/patience.
        • Steven Phillips
          Gadrin, ... In user-setup s General tab disable the Edit check box next to Setup File . ... If other settings in user-setup are working properly then you
          Message 4 of 8 , Sep 5, 2005
          • 0 Attachment
            Gadrin,

            > Subject: [jasspa] How do you ... ?
            > From: Gadrin <gadrin@...>
            > Date: Monday, September 5, 2005, 11:28:50 PM
            > To: jasspa@yahoogroups.com
            > 1) Everytime I use HELP, USER SETUP and PLATFORM to change something
            > (or use USER SETUP at all, after hitting SAVE the program
            > automatically loads a buffer called Owner.emf and displays it onscreen.

            > I browsed thru the FAQs but didn't see anything obvious.

            > Is there (hopefully) a way to disable this feature ?

            In user-setup's General tab disable the 'Edit' check box next to 'Setup File'.

            > 2) How do I get it to save my font-choices, which seem to work for
            > that moment, but not for closing/restarting.

            > change-font is perfect, but it doesn't save the choices for the next
            > session.

            > I've been plugging away using 1) above but it's kinda hit & miss.

            If other settings in user-setup are working properly then you have got a
            reasonable setup, i.e. a user-name with a setup file loading your settings
            in. In which case it is either multiple ME's running at the same time (as Jon
            mentioned) or you have found a bug. Ensure you have only one ME running, make
            your changes, Save and exit ME then restart. If this does not work email me
            the changes you are making and I will see if I can reproduce the problem.

            Steve

            > hrmmm, noticed that when I do use change-font it makes the change but
            > resizes the app kinda like the old 3.8 version! LOL!

            > anyway, despite these setbacks, I'm still liking this product quite a
            > bit.

            > Gadrin






            > __________________________________________________________________________

            > This is an unmoderated list. JASSPA is not responsible for the content of
            > any material posted to this list.

            > To unsubscribe, send a mail message to

            > mailto:jasspa-unsubscribe@yahoogroups.com

            > or visit http://groups.yahoo.com/group/jasspa and
            > modify your account settings manually.


            >
            > Yahoo! Groups Links



            >
          • Jon Green
            ... Now I did not know that - it is in the help page! Thats great - just disabled. Jon.
            Message 5 of 8 , Sep 5, 2005
            • 0 Attachment
              Steven Phillips wrote:
              > Gadrin,
              >
              >
              >>Subject: [jasspa] How do you ... ?
              >>From: Gadrin <gadrin@...>
              >>Date: Monday, September 5, 2005, 11:28:50 PM
              >>To: jasspa@yahoogroups.com
              >>1) Everytime I use HELP, USER SETUP and PLATFORM to change something
              >>(or use USER SETUP at all, after hitting SAVE the program
              >>automatically loads a buffer called Owner.emf and displays it onscreen.
              >
              >
              >>I browsed thru the FAQs but didn't see anything obvious.
              >
              >
              >>Is there (hopefully) a way to disable this feature ?
              >
              >
              > In user-setup's General tab disable the 'Edit' check box next to 'Setup File'.
              >

              Now I did not know that - it is in the help page!
              Thats great - just disabled.
              Jon.
            • Gadrin
              ... to Setup File . ah, it s in the Startup tab not General , but thanks a bunch. ... email me ... problem. ... I think Jon s suggestions worked as it
              Message 6 of 8 , Sep 5, 2005
              • 0 Attachment
                --- In jasspa@yahoogroups.com, Steven Phillips <bill@j...> wrote:

                > In user-setup's General tab disable the 'Edit' check box next
                to 'Setup File'.

                ah, it's in the "Startup" tab not "General", but thanks a bunch.


                > your changes, Save and exit ME then restart. If this does not work
                email me
                > the changes you are making and I will see if I can reproduce the
                problem.
                >
                > Steve


                I think Jon's suggestions worked as it seems to be stable now.
                Thanks for your offer.

                Do you know how to keep the Tools from splitting the screen when run
                and how they can run asynchronously from the ME app ? I'd like to be
                able to call Explorer.exe with the buffer's current path, but not
                screw up the display, etc, etc.

                Thanks again, Gadrin.
              • Phillips, Steven
                Gadrin ... With the current release the only ption you have is to use the ipipe-shell-command command, if you look at the docs for this command you will see
                Message 7 of 8 , Sep 5, 2005
                • 0 Attachment
                  Gadrin

                  >
                  > Do you know how to keep the Tools from splitting the screen when run
                  > and how they can run asynchronously from the ME app ? I'd like to be
                  > able to call Explorer.exe with the buffer's current path, but not
                  > screw up the display, etc, etc.

                  With the current release the only ption you have is to use the
                  ipipe-shell-command command, if you look at the docs for this command
                  you will see that there are bits in the argument that can be used to
                  hide the output buffer etc. This will do the job but you still end up
                  with an extra command buffer, ME monitoring the spawned command etc.

                  For the next release I have introduced a new user defined Tools
                  interface for the file browser and for that I needed a similar
                  capability to what I believe you are after. I modified the shell-command
                  command to be able to spawn a process such as explorer with no waiting
                  for its exit or gathering output etc. i.e.

                  0x24 shell-command "explorer.exe"

                  Would almost certainly do the trick. This is in the development version,
                  available at:

                  http://www.jasspa.com/development/

                  But documentation for this is not yet available,

                  Steve

                  >
                  > Thanks again, Gadrin.
                  >
                  >
                  >
                  >
                  >
                  > ------------------------ Yahoo! Groups Sponsor
                  >
                  >
                  ________________________________________________________________________
                  __
                  >
                  > This is an unmoderated list. JASSPA is not responsible for the content
                  of
                  > any material posted to this list.
                  >
                  > To unsubscribe, send a mail message to
                  >
                  > mailto:jasspa-unsubscribe@yahoogroups.com
                  >
                  > or visit http://groups.yahoo.com/group/jasspa and
                  > modify your account settings manually.
                  >
                  >
                  >
                  > Yahoo! Groups Links
                  >
                  >
                  >
                  >
                  >
                • Gadrin
                  ... run ... to be ... actually I discovered the secret just before bed late last night. the menu s are a bit counter-intuitive. anyway, USER SETUP, TOOLS, set
                  Message 8 of 8 , Sep 6, 2005
                  • 0 Attachment
                    --- In jasspa@yahoogroups.com, "Phillips, Steven" <sphillips@p...>
                    wrote:
                    > > Do you know how to keep the Tools from splitting the screen when
                    run
                    > > and how they can run asynchronously from the ME app ? I'd like
                    to be
                    > > able to call Explorer.exe with the buffer's current path, but not
                    > > screw up the display, etc, etc.
                    >

                    actually I discovered the secret just before bed late last night.

                    the menu's are a bit counter-intuitive.

                    anyway, USER SETUP, TOOLS, set the following...

                    CAPTURE to Y
                    HIDE to Y
                    CONCURRENT to Y

                    all the other Y/N options to N

                    command line of: explorer.exe c:\program files\jasspa\microemacs

                    and it works.

                    the CAPTURE had me going, as I thought it was trying to CAPTURE the
                    output of the command in a buffer.

                    boy I'm impressed by this editor.
                  Your message has been successfully submitted and would be delivered to recipients shortly.