Loading ...
Sorry, an error occurred while loading the content.

Tabs

Expand Messages
  • smithno999
    Right after the current version came out, I spent some time mapping the keyboard to my liking. There were a couple of annoyances that I have been meaning to
    Message 1 of 2 , Aug 29, 2005
    • 0 Attachment
      Right after the current version came out, I spent some time mapping the
      keyboard to my liking. There were a couple of annoyances that I have
      been meaning to tweak again. I spent a bunch of time over the weekend
      on my final tweaking of keymappings. I thought that I'd go from using
      ME from about 3/4 of time to 99%. Unfortunately the TAB key gets in the
      way.

      I've read the doc, tried several things without success, and figured it
      is time to ask. I don't mind the auto indent in most file types,
      especially the programming language. I always want the TAB key to
      insert a tab character. What are the magic settings to do this?

      I tried setting $buffer-indent. I tried global-bind-key TAB "normal-
      tab". I tried changing the tab setting in the General Tab of User
      Setup. I think I even tried multiple combinations of the three.

      I want to complement you all again on the wonderful job you have done
      making ME usable again!!
    • Jon Green
      ... Firstly you need to make sure that real TABS are inserted. * Disable the global TAB mode. * This turns TABS into SPACES from M-x user-setup. * Note that
      Message 2 of 2 , Aug 29, 2005
      • 0 Attachment
        smithno999 wrote:
        > Right after the current version came out, I spent some time mapping the
        > keyboard to my liking. There were a couple of annoyances that I have
        > been meaning to tweak again. I spent a bunch of time over the weekend
        > on my final tweaking of keymappings. I thought that I'd go from using
        > ME from about 3/4 of time to 99%. Unfortunately the TAB key gets in the
        > way.
        >
        > I've read the doc, tried several things without success, and figured it
        > is time to ask. I don't mind the auto indent in most file types,
        > especially the programming language. I always want the TAB key to
        > insert a tab character. What are the magic settings to do this?
        >
        > I tried setting $buffer-indent. I tried global-bind-key TAB "normal-
        > tab". I tried changing the tab setting in the General Tab of User
        > Setup. I think I even tried multiple combinations of the three.
        >
        > I want to complement you all again on the wonderful job you have done
        > making ME usable again!!
        >

        Firstly you need to make sure that real TABS are inserted.

        * Disable the global "TAB" mode.
        * This turns TABS into SPACES from M-x user-setup.
        * Note that this can be selectivelly enabled/disabled on a buffer basis so make sure it is
        off in both places (see buffer-setup below).

        Next diable the buffer indent (the auto-indentation)

        * M-x buffer-setup (or Help->Buffer Setup)
        * Disable "setup Auto Indent"
        * You will need to do this for each buffer type where you want to over-ride the auto indent.

        Once you have done this you can lay stuff out how you like.
        The restyle-buffer etc. will not work because you are controlling the layout.

        Jon.
      Your message has been successfully submitted and would be delivered to recipients shortly.