Loading ...
Sorry, an error occurred while loading the content.

[jasspa] Re: Setup Path Problems

Expand Messages
  • Detlef Groth
    By the way Steven has given me an other useful tip some months ago, which seems to be for me the best. Create something like the following batch-files: REM
    Message 1 of 4 , Dec 13, 1999
      By the way Steven has given me an other useful tip some months ago, which seems to be for me the best.

      Create something like the following batch-files:

      REM me32a.bat
      set MENAME=user1
      set MEPATH=C:/jemacs99/user;C:/jemacs99/macros;C:/Me/Mehelp
      c:\windows\command\start /max C:\jemacs99\me32.exe -c %1 %2 %3 %4 %5 %6

      REM me32b.bat
      set MENAME=user2
      set MEPATH=C:/jemacs99/user;C:/jemacs99/macros;C:/Me/Mehelp
      c:\windows\command\start /max C:\jemacs99\me32.exe -c %1 %2 %3 %4 %5 %6

      and so on. Best is for each project on which you are working a separate file.

      Remove the Me32.ini from the Windows-directory, remove the Me-statements from the autoexec.bat.

      Just run the Me-batch-files adjust user setup to your Mename. If you want to share the same macros in both profiles write at the beginning of user2.emf the command
      execute-file "user1.emf"
      you will have in each profile the same macros but a different session. Be aware that you use the same user-directory !

      I never get different profiles with the Me32.ini or the autoexec.bat working.
      May be using a special command line would be useful for avoiding use of bat-files
      like me32.exe -usera -c ...

      for invoking ME32 without history try a separare profile:

      REM me32.bat
      set MENAME=userx
      set MEPATH=C:/jemacs99/user;C:/jemacs99/macros;C:/Me/Mehelp
      c:\windows\command\start /max C:\jemacs99\me32.exe %1 %2 %3 %4 %5 %6
      REM -c is removed >> no history for userx


      for invoking ME to work with the DJGPP-tools I use the following:

      REM medjgpp.bat
      set MENAME=djgpp
      set MEPATH=C:/jemacs99/dgroth;C:/jemacs99/macros;C:/Me/Mehelp
      set INFOPATH=C:/djgpp/info
      REM this sets the infopath from c:/info to the djgpp-directory
      c:\windows\command\start /max C:\jemacs99\me32.exe -c %1 %2 %3 %4 %5 %6

      move this file into your path and you can load each file always with me32 myfile.txt


      At 09:26 10.12.99 +0000, you wrote:
      >Assuming your MEPATH is set to f:\username;e:\me me32 will search for the
      >first occurrence of $MENAME.erf (the setup registry file). If that file does
      >not exist in f:\username then it will look in e:\me, if it does exist there
      >then Setup Path will be set to this (in fact it will be set to e:\me if
      >$MENAME.erf is not found at all).
      >To fix this simply move the $MENAME.* files from e:\me to f:\username, now
      >me32 should find the correct one in the correct place and set Setup Path to
      >If this does not fix the problem then can you please send me your MEPATH
      >setting and the contents of default.emf so that I can try and reproduce the
      >problem. Can you also send me your variable settings (use the main menu's Help
      >-> List Variable) and probably best just filling my mail box rather than the
      >whole egroup.
      >> Subject: [jasspa] Re: Setup Path Problems
      >> From: fourje <fourje@...>
      >> Date: Fri, 10 Dec 1999 09:04:57 +0000
      >> To: jasspa@egroups.com
      >> Steve,
      >> I have MEPATH set in my autoexec.bat, and MENAME is set in default.emf. However,
      >> whenever I open user setup, the setup path is always reset to e:\me and the file
      >> dedwards.erf in e:\me is the one that gets updated every time.
      >> A puzzler!!
      >> Thanks
      >> Dave E.
      >> dedwards@...
      >> Steven Phillips wrote:
      >> > Dave,
      >> >
      >> > The Setup Path usage is obscure and does not do what first impressions would
      >> > suggest. The Setup Path does two things:
      >> >
      >> > 1) On opening the User Setup dialog it shows you where it found the
      >> > current profile. For new users this will probably be the main macro
      >> > directory (e.g. e:\me).
      >> >
      >> > 2) Can be used to set the output directory, i.e. where the user setup
      >> > files will be written when you use the Save button (e.g. f:\username).
      >> >
      >> > One thing that Setup Path does not do is change your environment, so when you
      >> > exit me32 and restart it will not know about f:\username and therefore it will
      >> > not find you setup files.
      >> >
      >> > The simplest way to setup you environment is to set two environment variables,
      >> > as follows:
      >> >
      >> > set MENAME=username
      >> > set MEPATH=f:\username;e:\me
      >> >
      >> > These two environment variables tell me32 who you are, where your setup files
      >> > are and where the system setup files are. You should now find that me32 finds
      >> > your username.erf in f:\username so Set Path should be automatically set to
      >> > f:\username.
      >> >
      >> > Hope that solves the problems,
      >> >
      >> > Steve
      >> > <snip>
    Your message has been successfully submitted and would be delivered to recipients shortly.