Loading ...
Sorry, an error occurred while loading the content.
 

Re: [jasspa] Ruby: Indentation ?

Expand Messages
  • Steven Phillips
    It should be enabled by default, use buffer-setup and check that Setup Auto Indent is enabled, if not enable it. If it is enabled check the value of variable
    Message 1 of 8 , Jun 26, 2005
      It should be enabled by default, use buffer-setup and check that 'Setup Auto
      Indent' is enabled, if not enable it. If it is enabled check the value of
      variable $buffer-indent (use list-variables while in the buffer), if this is 0
      then you may have found a bug,

      Steve

      > Subject: [jasspa] Ruby: Indentation ?
      > From: Meino Christian Cramer <Meino.Cramer@...>
      > Date: Sunday, June 26, 2005, 6:02:26 AM
      > To: jasspa@yahoogroups.com

      > Hi,

      > Is there a way to switch on indentation (pressing TAB on a source
      > line) for Ruby source code files ?

      > Happy microemacsing!
      > Meino




      > __________________________________________________________________________

      > This is an unmoderated list. JASSPA is not responsible for the content of
      > any material posted to this list.

      > To unsubscribe, send a mail message to

      > mailto:jasspa-unsubscribe@yahoogroups.com

      > or visit http://groups.yahoo.com/group/jasspa and
      > modify your account settings manually.



      > Yahoo! Groups Links
    • Meino Christian Cramer
      From: Steven Phillips Subject: Re: [jasspa] Ruby: Indentation ? Date: Sun, 26 Jun 2005 13:55:01 +0100 Hi, everything seems to be allright and
      Message 2 of 8 , Jun 26, 2005
        From: Steven Phillips <bill@...>
        Subject: Re: [jasspa] Ruby: Indentation ?
        Date: Sun, 26 Jun 2005 13:55:01 +0100

        Hi,

        everything seems to be allright and indentation via TAB works fine.
        Nevertheless I have had a file with ruby code (before I wrote the
        mail) which "indents without end" when TAB was pressed on a line.
        Even this file works now. I have had changed nothing in between.

        Whether I understand what happens...hrrmmm....I would say....no...

        But I will keep my eyes on this and if I can say more about what
        happens when I will mail again.

        Thanks for your help ! :)

        Meino



        > It should be enabled by default, use buffer-setup and check that 'Setup Auto
        > Indent' is enabled, if not enable it. If it is enabled check the value of
        > variable $buffer-indent (use list-variables while in the buffer), if this is 0
        > then you may have found a bug,
        >
        > Steve
        >
        > > Subject: [jasspa] Ruby: Indentation ?
        > > From: Meino Christian Cramer <Meino.Cramer@...>
        > > Date: Sunday, June 26, 2005, 6:02:26 AM
        > > To: jasspa@yahoogroups.com
        >
        > > Hi,
        >
        > > Is there a way to switch on indentation (pressing TAB on a source
        > > line) for Ruby source code files ?
        >
        > > Happy microemacsing!
        > > Meino
        >
        >
        >
        >
        > > __________________________________________________________________________
        >
        > > This is an unmoderated list. JASSPA is not responsible for the content of
        > > any material posted to this list.
        >
        > > To unsubscribe, send a mail message to
        >
        > > mailto:jasspa-unsubscribe@yahoogroups.com
        >
        > > or visit http://groups.yahoo.com/group/jasspa and
        > > modify your account settings manually.
        >
        >
        >
        > > Yahoo! Groups Links
        >
        >
        >
        >
        >
        >
        >
        >
        > __________________________________________________________________________
        >
        > This is an unmoderated list. JASSPA is not responsible for the content of
        > any material posted to this list.
        >
        > To unsubscribe, send a mail message to
        >
        > mailto:jasspa-unsubscribe@yahoogroups.com
        >
        > or visit http://groups.yahoo.com/group/jasspa and
        > modify your account settings manually.
        >
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
        >
        >
      • Steven Phillips
        The most likely explanation for this is as follows: Create a new buffer called foo Start writing ruby code - no indentation. write-buffer to foo.rb You may
        Message 3 of 8 , Jun 26, 2005
          The most likely explanation for this is as follows:

          Create a new buffer called "foo"
          Start writing ruby code - no indentation.
          write-buffer to "foo.rb"

          You may now think that you have a ruby file and the indentation is broken, but
          you don't, you still have "foo" with no specific file setup. You need to
          reread the file or restart ME to reinitialize foo.rb to a ruby file.

          Steve

          > Subject: [jasspa] Ruby: Indentation ?
          > From: Meino Christian Cramer <Meino.Cramer@...>
          > Date: Sunday, June 26, 2005, 2:31:37 PM
          > To: jasspa@yahoogroups.com, bill@...
          > From: Steven Phillips <bill@...>
          > Subject: Re: [jasspa] Ruby: Indentation ?
          > Date: Sun, 26 Jun 2005 13:55:01 +0100

          > Hi,

          > everything seems to be allright and indentation via TAB works fine.
          > Nevertheless I have had a file with ruby code (before I wrote the
          > mail) which "indents without end" when TAB was pressed on a line.
          > Even this file works now. I have had changed nothing in between.

          > Whether I understand what happens...hrrmmm....I would say....no...

          > But I will keep my eyes on this and if I can say more about what
          > happens when I will mail again.

          > Thanks for your help ! :)

          > Meino



          >> It should be enabled by default, use buffer-setup and check that 'Setup Auto
          >> Indent' is enabled, if not enable it. If it is enabled check the value of
          >> variable $buffer-indent (use list-variables while in the buffer), if this is 0
          >> then you may have found a bug,
          >>
          >> Steve
          >>
          >> > Subject: [jasspa] Ruby: Indentation ?
          >> > From: Meino Christian Cramer <Meino.Cramer@...>
          >> > Date: Sunday, June 26, 2005, 6:02:26 AM
          >> > To: jasspa@yahoogroups.com
          >>
          >> > Hi,
          >>
          >> > Is there a way to switch on indentation (pressing TAB on a source
          >> > line) for Ruby source code files ?
          >>
          >> > Happy microemacsing!
          >> > Meino
          >>
          >>
          >>
          >>
          >> >
          >> __________________________________________________________________________
          >>
          >> > This is an unmoderated list. JASSPA is not responsible for the content of
          >> > any material posted to this list.
          >>
          >> > To unsubscribe, send a mail message to
          >>
          >> > mailto:jasspa-unsubscribe@yahoogroups.com
          >>
          >> > or visit http://groups.yahoo.com/group/jasspa and
          >> > modify your account settings manually.
          >>
          >>
          >>
          >> > Yahoo! Groups Links
          >>
          >>
          >>
          >>
          >>
          >>
          >>
          >>
          >> __________________________________________________________________________
          >>
          >> This is an unmoderated list. JASSPA is not responsible for the content of
          >> any material posted to this list.
          >>
          >> To unsubscribe, send a mail message to
          >>
          >> mailto:jasspa-unsubscribe@yahoogroups.com
          >>
          >> or visit http://groups.yahoo.com/group/jasspa and
          >> modify your account settings manually.
          >>
          >>
          >>
          >> Yahoo! Groups Links
          >>
          >>
          >>
          >>
          >>
          >>


          > __________________________________________________________________________

          > This is an unmoderated list. JASSPA is not responsible for the content of
          > any material posted to this list.

          > To unsubscribe, send a mail message to

          > mailto:jasspa-unsubscribe@yahoogroups.com

          > or visit http://groups.yahoo.com/group/jasspa and
          > modify your account settings manually.



          > Yahoo! Groups Links
        • Meino Christian Cramer
          From: Steven Phillips Subject: Re[2]: [jasspa] Ruby: Indentation ? Date: Sun, 26 Jun 2005 14:39:58 +0100 May be this is what happened...I
          Message 4 of 8 , Jun 26, 2005
            From: Steven Phillips <bill@...>
            Subject: Re[2]: [jasspa] Ruby: Indentation ?
            Date: Sun, 26 Jun 2005 14:39:58 +0100

            May be this is what happened...I dont remember it for sure...
            What triggers the ruby-(or any other)mode: The #!<interpreter> line or
            the *.<extension> of the file ?

            Meino

            > The most likely explanation for this is as follows:
            >
            > Create a new buffer called "foo"
            > Start writing ruby code - no indentation.
            > write-buffer to "foo.rb"
            >
            > You may now think that you have a ruby file and the indentation is broken, but
            > you don't, you still have "foo" with no specific file setup. You need to
            > reread the file or restart ME to reinitialize foo.rb to a ruby file.
            >
            > Steve
            >
            > > Subject: [jasspa] Ruby: Indentation ?
            > > From: Meino Christian Cramer <Meino.Cramer@...>
            > > Date: Sunday, June 26, 2005, 2:31:37 PM
            > > To: jasspa@yahoogroups.com, bill@...
            > > From: Steven Phillips <bill@...>
            > > Subject: Re: [jasspa] Ruby: Indentation ?
            > > Date: Sun, 26 Jun 2005 13:55:01 +0100
            >
            > > Hi,
            >
            > > everything seems to be allright and indentation via TAB works fine.
            > > Nevertheless I have had a file with ruby code (before I wrote the
            > > mail) which "indents without end" when TAB was pressed on a line.
            > > Even this file works now. I have had changed nothing in between.
            >
            > > Whether I understand what happens...hrrmmm....I would say....no...
            >
            > > But I will keep my eyes on this and if I can say more about what
            > > happens when I will mail again.
            >
            > > Thanks for your help ! :)
            >
            > > Meino
            >
            >
            >
            > >> It should be enabled by default, use buffer-setup and check that 'Setup Auto
            > >> Indent' is enabled, if not enable it. If it is enabled check the value of
            > >> variable $buffer-indent (use list-variables while in the buffer), if this is 0
            > >> then you may have found a bug,
            > >>
            > >> Steve
            > >>
            > >> > Subject: [jasspa] Ruby: Indentation ?
            > >> > From: Meino Christian Cramer <Meino.Cramer@...>
            > >> > Date: Sunday, June 26, 2005, 6:02:26 AM
            > >> > To: jasspa@yahoogroups.com
            > >>
            > >> > Hi,
            > >>
            > >> > Is there a way to switch on indentation (pressing TAB on a source
            > >> > line) for Ruby source code files ?
            > >>
            > >> > Happy microemacsing!
            > >> > Meino
            > >>
            > >>
            > >>
            > >>
            > >> >
            > >> __________________________________________________________________________
            > >>
            > >> > This is an unmoderated list. JASSPA is not responsible for the content of
            > >> > any material posted to this list.
            > >>
            > >> > To unsubscribe, send a mail message to
            > >>
            > >> > mailto:jasspa-unsubscribe@yahoogroups.com
            > >>
            > >> > or visit http://groups.yahoo.com/group/jasspa and
            > >> > modify your account settings manually.
            > >>
            > >>
            > >>
            > >> > Yahoo! Groups Links
            > >>
            > >>
            > >>
            > >>
            > >>
            > >>
            > >>
            > >>
            > >> __________________________________________________________________________
            > >>
            > >> This is an unmoderated list. JASSPA is not responsible for the content of
            > >> any material posted to this list.
            > >>
            > >> To unsubscribe, send a mail message to
            > >>
            > >> mailto:jasspa-unsubscribe@yahoogroups.com
            > >>
            > >> or visit http://groups.yahoo.com/group/jasspa and
            > >> modify your account settings manually.
            > >>
            > >>
            > >>
            > >> Yahoo! Groups Links
            > >>
            > >>
            > >>
            > >>
            > >>
            > >>
            >
            >
            > > __________________________________________________________________________
            >
            > > This is an unmoderated list. JASSPA is not responsible for the content of
            > > any material posted to this list.
            >
            > > To unsubscribe, send a mail message to
            >
            > > mailto:jasspa-unsubscribe@yahoogroups.com
            >
            > > or visit http://groups.yahoo.com/group/jasspa and
            > > modify your account settings manually.
            >
            >
            >
            > > Yahoo! Groups Links
            >
            >
            >
            >
            >
            >
            >
            >
            > __________________________________________________________________________
            >
            > This is an unmoderated list. JASSPA is not responsible for the content of
            > any material posted to this list.
            >
            > To unsubscribe, send a mail message to
            >
            > mailto:jasspa-unsubscribe@yahoogroups.com
            >
            > or visit http://groups.yahoo.com/group/jasspa and
            > modify your account settings manually.
            >
            >
            >
            > Yahoo! Groups Links
            >
            >
            >
            >
            >
            >
          • Thomas Hundt
            IMO the real answer is to get in the habit of starting off by doing find-file with a real filename (.rb extension) or create the buffer using a name that ends
            Message 5 of 8 , Jun 26, 2005
              IMO the real answer is to get in the habit of starting off by doing
              find-file with a real filename (.rb extension) or create the buffer
              using a name that ends in ".rb" (foo.rb). That way it's already in Ruby
              mode when you type your code.

              If you use find-file, I think you will also gain automatic periodic
              backup capability if you do this. (See if the variable $buffer-backup is
              set.)

              -Th

              > The most likely explanation for this is as follows:
              >
              > Create a new buffer called "foo"
              > Start writing ruby code - no indentation.
              > write-buffer to "foo.rb"
              >
              > You may now think that you have a ruby file and the indentation is broken, but
              > you don't, you still have "foo" with no specific file setup. You need to
              > reread the file or restart ME to reinitialize foo.rb to a ruby file.
              >
              > Steve


              >> Nevertheless I have had a file with ruby code (before I wrote the
              >> mail) which "indents without end" when TAB was pressed on a line.
              >> Even this file works now. I have had changed nothing in between.
              >> Meino


              --
              Thomas Hundt <tom@...> +1-415-867-6698
            • Thomas Hundt
              ... Either one. They are set in .../macros/me.emf. Example (from my company file): add-file-hook .db2 fhook-sql ; DB2 Stored Procedure Builder file -1
              Message 6 of 8 , Jun 26, 2005
                > What triggers the ruby-(or any other)mode: The #!<interpreter> line or
                > the *.<extension> of the file ?
                > Meino

                Either one. They are set in .../macros/me.emf.

                Example (from my company file):

                add-file-hook ".db2" fhook-sql ; DB2 Stored Procedure Builder file
                -1 add-file-hook "CREATE PROCEDURE" fhook-sql ; DB2 stored procedure

                -Th
              • Meino Christian Cramer
                From: Thomas Hundt Subject: Re: [jasspa] Ruby: Indentation ? Date: Sun, 26 Jun 2005 09:19:27 -0700 Yes, this is something I have to get used
                Message 7 of 8 , Jun 26, 2005
                  From: Thomas Hundt <thundt@...>
                  Subject: Re: [jasspa] Ruby: Indentation ?
                  Date: Sun, 26 Jun 2005 09:19:27 -0700

                  Yes, this is something I have to get used to.... :)

                  By the way: When I am typing

                  me mynewfileinruby.rb

                  on the command line to start a new ruby code ... ME is knowing what I
                  trying to program ?!???

                  Meino

                  > IMO the real answer is to get in the habit of starting off by doing
                  > find-file with a real filename (.rb extension) or create the buffer
                  > using a name that ends in ".rb" (foo.rb). That way it's already in Ruby
                  > mode when you type your code.
                  >
                  > If you use find-file, I think you will also gain automatic periodic
                  > backup capability if you do this. (See if the variable $buffer-backup is
                  > set.)
                  >
                  > -Th
                  >
                  > > The most likely explanation for this is as follows:
                  > >
                  > > Create a new buffer called "foo"
                  > > Start writing ruby code - no indentation.
                  > > write-buffer to "foo.rb"
                  > >
                  > > You may now think that you have a ruby file and the indentation is broken, but
                  > > you don't, you still have "foo" with no specific file setup. You need to
                  > > reread the file or restart ME to reinitialize foo.rb to a ruby file.
                  > >
                  > > Steve
                  >
                  >
                  > >> Nevertheless I have had a file with ruby code (before I wrote the
                  > >> mail) which "indents without end" when TAB was pressed on a line.
                  > >> Even this file works now. I have had changed nothing in between.
                  > >> Meino
                  >
                  >
                  > --
                  > Thomas Hundt <tom@...> +1-415-867-6698
                  >
                  >
                  > __________________________________________________________________________
                  >
                  > This is an unmoderated list. JASSPA is not responsible for the content of
                  > any material posted to this list.
                  >
                  > To unsubscribe, send a mail message to
                  >
                  > mailto:jasspa-unsubscribe@yahoogroups.com
                  >
                  > or visit http://groups.yahoo.com/group/jasspa and
                  > modify your account settings manually.
                  >
                  >
                  >
                  > Yahoo! Groups Links
                  >
                  >
                  >
                  >
                  >
                  >
                Your message has been successfully submitted and would be delivered to recipients shortly.