Loading ...
Sorry, an error occurred while loading the content.

Re: [jasspa] Font on X

Expand Messages
  • Jon Green
    ... That sounds right, its fonts.dir and fonts.scale that get updated on Solaris as well. No we do not use XFT, this is an extension that is not available on
    Message 1 of 7 , Feb 6, 2005
    • 0 Attachment
      first last wrote:
      > If I am not wrong, ME doesn't use XFT, the new font system on X. To
      > make those fonts available to all applications you need to copy them to
      > the right folder, usually /usr/X11R6/lib/X11/fonts/TrueType, run
      > ttmkfdir > fonts.scale and ttmkfdir > fonts.dir and, finally, make sure
      > that the folder is somewhere in the font path (Fedora uses XFS but you
      > can add the fonts directly to xorg.conf, next to the entry for xfs).
      >
      > Hope this works.
      >
      > Gabriel
      >

      That sounds right, its fonts.dir and fonts.scale that get updated
      on Solaris as well.

      No we do not use XFT, this is an extension that is not available on
      all UNIX systems, the X11 features are all based on R4/R5 which are
      compatible with R6.

      Jon.
    • Salman Khilji
      ... Sometimes, its crap like this that make me feel like dumping Linux and using some other UNIX. I am following instructions from:
      Message 2 of 7 , Feb 6, 2005
      • 0 Attachment
        --- Jon Green <jon@...> wrote:

        >
        > Are you sure that you do not need to do define
        > your downloaded font to X ? I do not use Linux
        > by choice (too volatile), under Solaris then


        Sometimes, its crap like this that make me feel like
        dumping Linux and using some other UNIX.

        I am following instructions from:
        http://gobase.org/dict/JIS/helponXfonts.html

        I am using the pcf format fonts. It works, but when I
        restart my computer, the changes that I make are
        totally lost! I remember that SuSE 8.0 Pro used to do
        this on me and after I coudl not find a solution to
        the problem, I reformatted my drive and tried another
        distro.

        basically I created a folder

        /usr/share/fonts/proggyfonts

        and then:

        xset fp+ /usr/share/fonts/proggyfonts
        xset fp rehash

        as root.

        To try the TTF fonts, I did ttmkfdir. ttmkfdir, now,
        does not output to stdout, so you cannot do the '>'
        thingy. Instead, you must do -o <filename>. I did
        this and xfontsel could see the font from proggy font
        website. However, ttmkfdir must have screwed up.
        XFontSel could not display the font correctly. And
        neither could ME.

        Maybe teh true-type fonts from the proggy site are
        simply not compatible with Linux.

        Salman





        __________________________________
        Do you Yahoo!?
        Yahoo! Mail - Helps protect you from nasty viruses.
        http://promotions.yahoo.com/new_mail
      • Salman Khilji
        Okay...so I finally confirmed that Linux cannot handle TTF fonts from the proggy site (Yes, I know its Xorg---not Linux---that cannot handle them). I basically
        Message 3 of 7 , Feb 6, 2005
        • 0 Attachment
          Okay...so I finally confirmed that Linux cannot handle
          TTF fonts from the proggy site (Yes, I know its
          Xorg---not Linux---that cannot handle them).

          I basically modified the .spec file from msttcorefonts
          and built myself an RPM using the EXACT same procedure
          as the msttcorefonts people d---they call chkfontpath
          and fc-cache at appropriate times. The resulting RPM
          installs and registers the fonts, but xfontsel kinda
          'freezes' and cannot display the font.

          I am talking about the Crisp.ttf font. Not sure which
          list I should report this bug to---probably somewhere
          on x.org

          Salman



          __________________________________
          Do you Yahoo!?
          Meet the all-new My Yahoo! - Try it today!
          http://my.yahoo.com
        • Salman Khilji
          Never mind. In XFontSel, one must remember to select iso8859 in the registry field for these fonts. If left to * , it causes problems. After all this
          Message 4 of 7 , Feb 6, 2005
          • 0 Attachment
            Never mind. In XFontSel, one must remember to select
            iso8859 in the "registry" field for these fonts. If
            left to '*', it causes problems.

            After all this trouble, I finally concluded that
            misc-fixed at 14 points on a 1280x1024 was more
            legible than the proggy font (or atleast thats what I
            prefer). The Crisp font was good as well, but a
            little too big to display all 80 columns when the
            viewed in a vertically split maximized ME window.

            Salman



            __________________________________
            Do you Yahoo!?
            Take Yahoo! Mail with you! Get it on your mobile phone.
            http://mobile.yahoo.com/maildemo
          Your message has been successfully submitted and would be delivered to recipients shortly.