Loading ...
Sorry, an error occurred while loading the content.

Font on X

Expand Messages
  • Salman Khilji
    I am using Jasspa on Fedora Core 3 and GNOME 2.8. I have downloaded some true-type programming font from http://www.proggyfonts.com/. As everyone suggests,
    Message 1 of 7 , Feb 5, 2005
    • 0 Attachment
      I am using Jasspa on Fedora Core 3 and GNOME 2.8. I
      have downloaded some true-type programming font from
      http://www.proggyfonts.com/. As everyone suggests, to
      install new fonts, you have to copy them to ~/.fonts.
      I did this.

      To use a font in jasspa, I really do not know any
      better way to use the XFontSel utility and then "cut'n
      paste" the resulting font into jasspa's font dialog
      box. The problem is that the XFontSel utility does
      not list the font that I have downloaded.

      Gnome Terminal can use the font just fine. Does
      anyone know of an alternate way to install fonts in X
      so that jasspa will be able to use them?

      Salman




      __________________________________
      Do you Yahoo!?
      Yahoo! Mail - now with 250MB free storage. Learn more.
      http://info.mail.yahoo.com/mail_250
    • Jon Green
      ... Don t know is the simple answer. If Xfontsel cannot see the fonts then the fonts are not in X space - they are probably available from gtk at a higher
      Message 2 of 7 , Feb 6, 2005
      • 0 Attachment
        Salman Khilji wrote:
        > I am using Jasspa on Fedora Core 3 and GNOME 2.8. I
        > have downloaded some true-type programming font from
        > http://www.proggyfonts.com/. As everyone suggests, to
        > install new fonts, you have to copy them to ~/.fonts.
        > I did this.
        >
        > To use a font in jasspa, I really do not know any
        > better way to use the XFontSel utility and then "cut'n
        > paste" the resulting font into jasspa's font dialog
        > box. The problem is that the XFontSel utility does
        > not list the font that I have downloaded.
        >
        > Gnome Terminal can use the font just fine. Does
        > anyone know of an alternate way to install fonts in X
        > so that jasspa will be able to use them?
        >
        > Salman
        >

        Don't know is the simple answer. If Xfontsel cannot
        see the fonts then the fonts are not in X space -
        they are probably available from gtk at a higher
        level (Gnome terminal is based on this I think) but
        as ME is 100% X for portability then you are not
        going to see something that is not X centric
        and built on the base services of the system.

        Are you sure that you do not need to do define
        your downloaded font to X ? I do not use Linux
        by choice (too volatile), under Solaris then
        there is a font administration tool that allows
        you to install new fonts, this will re-build
        all of the X-windows font tables and make the
        font available - maybe there is something
        similar for Linux ?

        Jon.
      • first last
        If I am not wrong, ME doesn t use XFT, the new font system on X. To make those fonts available to all applications you need to copy them to the right folder,
        Message 3 of 7 , Feb 6, 2005
        • 0 Attachment
          If I am not wrong, ME doesn't use XFT, the new font system on X. To
          make those fonts available to all applications you need to copy them to
          the right folder, usually /usr/X11R6/lib/X11/fonts/TrueType, run
          ttmkfdir > fonts.scale and ttmkfdir > fonts.dir and, finally, make sure
          that the folder is somewhere in the font path (Fedora uses XFS but you
          can add the fonts directly to xorg.conf, next to the entry for xfs).

          Hope this works.

          Gabriel

          --- Jon Green <jon@...> wrote:

          ---------------------------------
          Salman Khilji wrote:
          > I am using Jasspa on Fedora Core 3 and GNOME 2.8. I
          > have downloaded some true-type programming font from
          > http://www.proggyfonts.com/. As everyone suggests, to
          > install new fonts, you have to copy them to ~/.fonts.
          > I did this.
          >
          > To use a font in jasspa, I really do not know any
          > better way to use the XFontSel utility and then "cut'n
          > paste" the resulting font into jasspa's font dialog
          > box. The problem is that the XFontSel utility does
          > not list the font that I have downloaded.
          >
          > Gnome Terminal can use the font just fine. Does
          > anyone know of an alternate way to install fonts in X
          > so that jasspa will be able to use them?
          >
          > Salman
          >

          Don't know is the simple answer. If Xfontsel cannot
          see the fonts then the fonts are not in X space -
          they are probably available from gtk at a higher
          level (Gnome terminal is based on this I think) but
          as ME is 100% X for portability then you are not
          going to see something that is not X centric
          and built on the base services of the system.

          Are you sure that you do not need to do define
          your downloaded font to X ? I do not use Linux
          by choice (too volatile), under Solaris then
          there is a font administration tool that allows
          you to install new fonts, this will re-build
          all of the X-windows font tables and make the
          font available - maybe there is something
          similar for Linux ?

          Jon.



          __________________________________________________________________________

          This is an unmoderated list. JASSPA is not responsible for the content
          of
          any material posted to this list.

          To unsubscribe, send a mail message to

          mailto:jasspa-unsubscribe@yahoogroups.com

          or visit http://groups.yahoo.com/group/jasspa and
          modify your account settings manually.






          ---------------------------------
          Yahoo! Groups Links

          To visit your group on the web, go to:
          http://groups.yahoo.com/group/jasspa/

          To unsubscribe from this group, send an email to:
          jasspa-unsubscribe@yahoogroups.com

          Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.






          ___________________________________________________________
          ALL-NEW Yahoo! Messenger - all new features - even more fun! http://uk.messenger.yahoo.com
        • Jon Green
          ... That sounds right, its fonts.dir and fonts.scale that get updated on Solaris as well. No we do not use XFT, this is an extension that is not available on
          Message 4 of 7 , Feb 6, 2005
          • 0 Attachment
            first last wrote:
            > If I am not wrong, ME doesn't use XFT, the new font system on X. To
            > make those fonts available to all applications you need to copy them to
            > the right folder, usually /usr/X11R6/lib/X11/fonts/TrueType, run
            > ttmkfdir > fonts.scale and ttmkfdir > fonts.dir and, finally, make sure
            > that the folder is somewhere in the font path (Fedora uses XFS but you
            > can add the fonts directly to xorg.conf, next to the entry for xfs).
            >
            > Hope this works.
            >
            > Gabriel
            >

            That sounds right, its fonts.dir and fonts.scale that get updated
            on Solaris as well.

            No we do not use XFT, this is an extension that is not available on
            all UNIX systems, the X11 features are all based on R4/R5 which are
            compatible with R6.

            Jon.
          • Salman Khilji
            ... Sometimes, its crap like this that make me feel like dumping Linux and using some other UNIX. I am following instructions from:
            Message 5 of 7 , Feb 6, 2005
            • 0 Attachment
              --- Jon Green <jon@...> wrote:

              >
              > Are you sure that you do not need to do define
              > your downloaded font to X ? I do not use Linux
              > by choice (too volatile), under Solaris then


              Sometimes, its crap like this that make me feel like
              dumping Linux and using some other UNIX.

              I am following instructions from:
              http://gobase.org/dict/JIS/helponXfonts.html

              I am using the pcf format fonts. It works, but when I
              restart my computer, the changes that I make are
              totally lost! I remember that SuSE 8.0 Pro used to do
              this on me and after I coudl not find a solution to
              the problem, I reformatted my drive and tried another
              distro.

              basically I created a folder

              /usr/share/fonts/proggyfonts

              and then:

              xset fp+ /usr/share/fonts/proggyfonts
              xset fp rehash

              as root.

              To try the TTF fonts, I did ttmkfdir. ttmkfdir, now,
              does not output to stdout, so you cannot do the '>'
              thingy. Instead, you must do -o <filename>. I did
              this and xfontsel could see the font from proggy font
              website. However, ttmkfdir must have screwed up.
              XFontSel could not display the font correctly. And
              neither could ME.

              Maybe teh true-type fonts from the proggy site are
              simply not compatible with Linux.

              Salman





              __________________________________
              Do you Yahoo!?
              Yahoo! Mail - Helps protect you from nasty viruses.
              http://promotions.yahoo.com/new_mail
            • Salman Khilji
              Okay...so I finally confirmed that Linux cannot handle TTF fonts from the proggy site (Yes, I know its Xorg---not Linux---that cannot handle them). I basically
              Message 6 of 7 , Feb 6, 2005
              • 0 Attachment
                Okay...so I finally confirmed that Linux cannot handle
                TTF fonts from the proggy site (Yes, I know its
                Xorg---not Linux---that cannot handle them).

                I basically modified the .spec file from msttcorefonts
                and built myself an RPM using the EXACT same procedure
                as the msttcorefonts people d---they call chkfontpath
                and fc-cache at appropriate times. The resulting RPM
                installs and registers the fonts, but xfontsel kinda
                'freezes' and cannot display the font.

                I am talking about the Crisp.ttf font. Not sure which
                list I should report this bug to---probably somewhere
                on x.org

                Salman



                __________________________________
                Do you Yahoo!?
                Meet the all-new My Yahoo! - Try it today!
                http://my.yahoo.com
              • Salman Khilji
                Never mind. In XFontSel, one must remember to select iso8859 in the registry field for these fonts. If left to * , it causes problems. After all this
                Message 7 of 7 , Feb 6, 2005
                • 0 Attachment
                  Never mind. In XFontSel, one must remember to select
                  iso8859 in the "registry" field for these fonts. If
                  left to '*', it causes problems.

                  After all this trouble, I finally concluded that
                  misc-fixed at 14 points on a 1280x1024 was more
                  legible than the proggy font (or atleast thats what I
                  prefer). The Crisp font was good as well, but a
                  little too big to display all 80 columns when the
                  viewed in a vertically split maximized ME window.

                  Salman



                  __________________________________
                  Do you Yahoo!?
                  Take Yahoo! Mail with you! Get it on your mobile phone.
                  http://mobile.yahoo.com/maildemo
                Your message has been successfully submitted and would be delivered to recipients shortly.