Loading ...
Sorry, an error occurred while loading the content.

Re: [jasspa] ishell blocks on Zaurus

Expand Messages
  • p.de.reus@falconleven.nl
    grep is indeed working correctly. The ME version by the way is 20040701 and the corresponding macro files (I have edited me.emf slightly, because on a Z the
    Message 1 of 6 , Nov 2, 2004
    • 0 Attachment
      grep is indeed working correctly. The ME version by the way is 20040701 and the corresponding macro files (I have edited me.emf slightly, because on a Z the default user is 'zaurus'. This == $platform and causes problems  when executing 'zaurus.emf' (which is either platform specific file or user settings file).

      I do not have X (just Qt), so I have compiled using the mec entry in the makefile, building a ncurses only microemacs.
      I'll look into the unixterm.c source and see what I can find and try to compile it against termcap (thanks Pierre!).

      Any other suggestions are welcome



      Jon Green <jnaught@...>

      02-11-2004 12:30
      Please respond to jasspa

             
              To:        jasspa@yahoogroups.com
              cc:        
              Subject:        Re: [jasspa] ishell blocks on Zaurus


      p.de.reus@... wrote:

      > I have compiled microEmacs for the Zaurus. It's running fine with
      > libcurses on my SL-C760 in a terminal window. The only hickup I experience
      > is when I open up an ishell (with the ishell command): I get a new *shell*
      > buffer and the /bin/bash line, but no prompt. It looks as if the bash
      > process is blocked.
      > I have no clue where to look for a solution: in the macro file, the bash
      > parameters  or somewhere in the source. Could anyone give me some
      > pointers?
      >
      > Thanks!
      >
      > Paul
      >  
      > note: the Z is running bash 2.05.0 and linux kernel 2.4.18

      I assume that commands such as 'grep' are working correctly
      so the problem is with the terminal configuration.

      I do not run Zaurus and do not know how Linux is configured for
      this system. Based on problems with other systems then the
      likely culpret is in the source:-

      unixterm.c - TCAPgetattr() not being configured correctly
                           for Zaurus.

      From the  symptoms that you describe then this area of the
      code was added into the last release and fixed most issues
      related to a shell terminal (especially as "su root"
      which caused a lot of problems). Specifically the case
      (isX != 0) which is where you may be mis-configured.

      For the above then open a terminal window and run "me -n".
      Then run a shell - is this OK ? Now run from X off desktop -
      and run a shell does this fail ? If this is the case then
      the (isX != 0) condition is the problem (see specials for
      HP-UX in the code) and the termio modes should be configured.
      To debug this then add some printfs (best to write to
      "/tmp/me.log" so they do not appear on stdout) to work out
      what mode termios is being launched with.

      Hope this helps.

      Jon.



      ------------------------ Yahoo! Groups Sponsor --------------------~-->
      $9.95 domain names from Yahoo!. Register anything.
      http://us.click.yahoo.com/J8kdrA/y20IAA/yQLSAA/89EolB/TM
      --------------------------------------------------------------------~->

      __________________________________________________________________________

      This is an unmoderated list. JASSPA is not responsible for the content of
      any material posted to this list.

      To unsubscribe, send a mail message to

         mailto:jasspa-unsubscribe@yahoogroups.com

      or visit http://groups.yahoo.com/group/jasspa and
      modify your account settings manually.



      Yahoo! Groups Links

      <*> To visit your group on the web, go to:
         http://groups.yahoo.com/group/jasspa/

      <*> To unsubscribe from this group, send an email to:
         jasspa-unsubscribe@yahoogroups.com

      <*> Your use of Yahoo! Groups is subject to:
         http://docs.yahoo.com/info/terms/








      ***********************DISCLAIMER***********************
      Deze e-mail is uitsluitend bestemd voor de geadresseerde(n).
      Verstrekking aan en gebruik door anderen is niet toegestaan.
      Falcon Leven N.V. sluit iedere aansprakelijkheid uit die
      voortvloeit uit elektronische verzending.
      This e-mail is intended exclusively for the addressee(s),
      and may not be passed on to, or made available for use
      by any person other than the addressee(s).
      Falcon Leven N.V. rules out any and every liability
      resulting from any electronic transmission.
      ********************************************************
    • Pierre Gaston
      Thanks for nothing, you remember me about the ncurse/termcap... the pdaxrom version has been built with ncurse. there is an older console version compiled
      Message 2 of 6 , Nov 2, 2004
      • 0 Attachment
        Thanks for nothing, you remember me about the ncurse/termcap... the
        pdaxrom version has been built with ncurse.

        there is an older console version compiled here:
        http://sourceforge.net/project/showfiles.php?group_id=77149&release_id=149088


        p.de.reus@... wrote:

        >
        > grep is indeed working correctly. The ME version by the way is
        > 20040701 and the corresponding macro files (I have edited me.emf
        > slightly, because on a Z the default user is 'zaurus'. This ==
        > $platform and causes problems when executing 'zaurus.emf' (which is
        > either platform specific file or user settings file).
        >
        > I do not have X (just Qt), so I have compiled using the mec entry in
        > the makefile, building a ncurses only microemacs.
        > I'll look into the unixterm.c source and see what I can find and try
        > to compile it against termcap (thanks Pierre!).
        >
        > Any other suggestions are welcome
        >
        >
        >
        >
        > *Jon Green <jnaught@...>*
        >
        > 02-11-2004 12:30
        > Please respond to jasspa
        >
        >
        > To: jasspa@yahoogroups.com
        > cc:
        > Subject: Re: [jasspa] ishell blocks on Zaurus
        >
        >
        >
        > p.de.reus@... wrote:
        >
        > > I have compiled microEmacs for the Zaurus. It's running fine with
        > > libcurses on my SL-C760 in a terminal window. The only hickup I
        > experience
        > > is when I open up an ishell (with the ishell command): I get a new
        > *shell*
        > > buffer and the /bin/bash line, but no prompt. It looks as if the bash
        > > process is blocked.
        > > I have no clue where to look for a solution: in the macro file, the
        > bash
        > > parameters or somewhere in the source. Could anyone give me some
        > > pointers?
        > >
        > > Thanks!
        > >
        > > Paul
        > >
        > > note: the Z is running bash 2.05.0 and linux kernel 2.4.18
        >
        > I assume that commands such as 'grep' are working correctly
        > so the problem is with the terminal configuration.
        >
        > I do not run Zaurus and do not know how Linux is configured for
        > this system. Based on problems with other systems then the
        > likely culpret is in the source:-
        >
        > unixterm.c - TCAPgetattr() not being configured correctly
        > for Zaurus.
        >
        > From the symptoms that you describe then this area of the
        > code was added into the last release and fixed most issues
        > related to a shell terminal (especially as "su root"
        > which caused a lot of problems). Specifically the case
        > (isX != 0) which is where you may be mis-configured.
        >
        > For the above then open a terminal window and run "me -n".
        > Then run a shell - is this OK ? Now run from X off desktop -
        > and run a shell does this fail ? If this is the case then
        > the (isX != 0) condition is the problem (see specials for
        > HP-UX in the code) and the termio modes should be configured.
        > To debug this then add some printfs (best to write to
        > "/tmp/me.log" so they do not appear on stdout) to work out
        > what mode termios is being launched with.
        >
        > Hope this helps.
        >
        > Jon.
        >
        >
        >
        >
        > __________________________________________________________________________
        >
        > This is an unmoderated list. JASSPA is not responsible for the content of
        > any material posted to this list.
        >
        > To unsubscribe, send a mail message to
        >
        > mailto:jasspa-unsubscribe@yahoogroups.com
        >
        > or visit http://groups.yahoo.com/group/jasspa and
        > modify your account settings manually.
        >
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        > ***********************DISCLAIMER***********************
        > Deze e-mail is uitsluitend bestemd voor de geadresseerde(n).
        > Verstrekking aan en gebruik door anderen is niet toegestaan.
        > Falcon Leven N.V. sluit iedere aansprakelijkheid uit die
        > voortvloeit uit elektronische verzending.
        > This e-mail is intended exclusively for the addressee(s),
        > and may not be passed on to, or made available for use
        > by any person other than the addressee(s).
        > Falcon Leven N.V. rules out any and every liability
        > resulting from any electronic transmission.
        > ********************************************************
        >
        >
        > __________________________________________________________________________
        >
        > This is an unmoderated list. JASSPA is not responsible for the content of
        > any material posted to this list.
        >
        > To unsubscribe, send a mail message to
        >
        > mailto:jasspa-unsubscribe@yahoogroups.com
        >
        > or visit http://groups.yahoo.com/group/jasspa and
        > modify your account settings manually.
        >
        >
        >
        >
        >
        > *Yahoo! Groups Sponsor*
        > <http://us.ard.yahoo.com/SIG=1297muhcj/M=281955.5530326.6602771.3001176/D=groups/S=1705004924:HM/EXP=1099483582/A=2343726/R=0/SIG=12iug94am/*http://clk.atdmt.com/VON/go/yhxxxvon01900091von/direct/01/&time=1099397182539596>
        >
        >
        > Get unlimited calls to
        >
        > U.S./Canada
        >
        > <http://us.ard.yahoo.com/SIG=1297muhcj/M=281955.5530326.6602771.3001176/D=groups/S=1705004924:HM/EXP=1099483582/A=2343726/R=1/SIG=12iug94am/*http://clk.atdmt.com/VON/go/yhxxxvon01900091von/direct/01/&time=1099397182539596>
        >
        >
        >
        > ------------------------------------------------------------------------
        > *Yahoo! Groups Links*
        >
        > * To visit your group on the web, go to:
        > http://groups.yahoo.com/group/jasspa/
        >
        > * To unsubscribe from this group, send an email to:
        > jasspa-unsubscribe@yahoogroups.com
        > <mailto:jasspa-unsubscribe@yahoogroups.com?subject=Unsubscribe>
        >
        > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
        > Service <http://docs.yahoo.com/info/terms/>.
        >
        >
      • Pierre Gaston
        I ve just discover, that in zaurus.emf the frame size should be set only when me is used in , so something like should be done !if &seq %platform zaurusc
        Message 3 of 6 , Nov 3, 2004
        • 0 Attachment
          I've just discover, that in zaurus.emf the frame size should be set only
          when me is used in ,
          so something like should be done

          !if &seq %platform "zaurusc"
          !if ¬ &set #l0 ® "/history" &cat %platform "/frame-width" "0"
          change-frame-width 71
          !endif
          !if ¬ &set #l0 ® "/history" &cat %platform "/frame-depth" "0"
          change-frame-depth 28
          !endif
          !endif

          Thanks


          Pierre Gaston wrote:

          >Thanks for nothing, you remember me about the ncurse/termcap... the
          >pdaxrom version has been built with ncurse.
          >
          >there is an older console version compiled here:
          >http://sourceforge.net/project/showfiles.php?group_id=77149&release_id=149088
          >
          >
          >p.de.reus@... wrote:
          >
          >
          >
          >>grep is indeed working correctly. The ME version by the way is
          >>20040701 and the corresponding macro files (I have edited me.emf
          >>slightly, because on a Z the default user is 'zaurus'. This ==
          >>$platform and causes problems when executing 'zaurus.emf' (which is
          >>either platform specific file or user settings file).
          >>
          >>I do not have X (just Qt), so I have compiled using the mec entry in
          >>the makefile, building a ncurses only microemacs.
          >>I'll look into the unixterm.c source and see what I can find and try
          >>to compile it against termcap (thanks Pierre!).
          >>
          >>Any other suggestions are welcome
          >>
          >>
          >>
          >>
          >> *Jon Green <jnaught@...>*
          >>
          >>02-11-2004 12:30
          >>Please respond to jasspa
          >>
          >>
          >> To: jasspa@yahoogroups.com
          >> cc:
          >> Subject: Re: [jasspa] ishell blocks on Zaurus
          >>
          >>
          >>
          >>p.de.reus@... wrote:
          >>
          >>
          >>
          >>>I have compiled microEmacs for the Zaurus. It's running fine with
          >>>libcurses on my SL-C760 in a terminal window. The only hickup I
          >>>
          >>>
          >>experience
          >>
          >>
          >>>is when I open up an ishell (with the ishell command): I get a new
          >>>
          >>>
          >>*shell*
          >>
          >>
          >>>buffer and the /bin/bash line, but no prompt. It looks as if the bash
          >>>process is blocked.
          >>>I have no clue where to look for a solution: in the macro file, the
          >>>
          >>>
          >>bash
          >>
          >>
          >>>parameters or somewhere in the source. Could anyone give me some
          >>>pointers?
          >>>
          >>>Thanks!
          >>>
          >>>Paul
          >>>
          >>>note: the Z is running bash 2.05.0 and linux kernel 2.4.18
          >>>
          >>>
          >>I assume that commands such as 'grep' are working correctly
          >>so the problem is with the terminal configuration.
          >>
          >>I do not run Zaurus and do not know how Linux is configured for
          >>this system. Based on problems with other systems then the
          >>likely culpret is in the source:-
          >>
          >>unixterm.c - TCAPgetattr() not being configured correctly
          >> for Zaurus.
          >>
          >>From the symptoms that you describe then this area of the
          >>code was added into the last release and fixed most issues
          >>related to a shell terminal (especially as "su root"
          >>which caused a lot of problems). Specifically the case
          >>(isX != 0) which is where you may be mis-configured.
          >>
          >>For the above then open a terminal window and run "me -n".
          >>Then run a shell - is this OK ? Now run from X off desktop -
          >>and run a shell does this fail ? If this is the case then
          >>the (isX != 0) condition is the problem (see specials for
          >>HP-UX in the code) and the termio modes should be configured.
          >>To debug this then add some printfs (best to write to
          >>"/tmp/me.log" so they do not appear on stdout) to work out
          >>what mode termios is being launched with.
          >>
          >>Hope this helps.
          >>
          >>Jon.
          >>
          >>
          >>
          >>
          >>__________________________________________________________________________
          >>
          >>This is an unmoderated list. JASSPA is not responsible for the content of
          >>any material posted to this list.
          >>
          >>To unsubscribe, send a mail message to
          >>
          >> mailto:jasspa-unsubscribe@yahoogroups.com
          >>
          >>or visit http://groups.yahoo.com/group/jasspa and
          >>modify your account settings manually.
          >>
          >>
          >>
          >>Yahoo! Groups Links
          >>
          >>
          >>
          >>
          >>
          >>
          >>
          >>
          >>
          >>
          >>
          >>***********************DISCLAIMER***********************
          >>Deze e-mail is uitsluitend bestemd voor de geadresseerde(n).
          >>Verstrekking aan en gebruik door anderen is niet toegestaan.
          >>Falcon Leven N.V. sluit iedere aansprakelijkheid uit die
          >>voortvloeit uit elektronische verzending.
          >>This e-mail is intended exclusively for the addressee(s),
          >>and may not be passed on to, or made available for use
          >>by any person other than the addressee(s).
          >>Falcon Leven N.V. rules out any and every liability
          >>resulting from any electronic transmission.
          >>********************************************************
          >>
          >>
          >>__________________________________________________________________________
          >>
          >>This is an unmoderated list. JASSPA is not responsible for the content of
          >>any material posted to this list.
          >>
          >>To unsubscribe, send a mail message to
          >>
          >> mailto:jasspa-unsubscribe@yahoogroups.com
          >>
          >>or visit http://groups.yahoo.com/group/jasspa and
          >>modify your account settings manually.
          >>
          >>
          >>
          >>
          >>
          >>*Yahoo! Groups Sponsor*
          >><http://us.ard.yahoo.com/SIG=1297muhcj/M=281955.5530326.6602771.3001176/D=groups/S=1705004924:HM/EXP=1099483582/A=2343726/R=0/SIG=12iug94am/*http://clk.atdmt.com/VON/go/yhxxxvon01900091von/direct/01/&time=1099397182539596>
          >>
          >>
          >>Get unlimited calls to
          >>
          >>U.S./Canada
          >>
          >><http://us.ard.yahoo.com/SIG=1297muhcj/M=281955.5530326.6602771.3001176/D=groups/S=1705004924:HM/EXP=1099483582/A=2343726/R=1/SIG=12iug94am/*http://clk.atdmt.com/VON/go/yhxxxvon01900091von/direct/01/&time=1099397182539596>
          >>
          >>
          >>
          >>------------------------------------------------------------------------
          >>*Yahoo! Groups Links*
          >>
          >> * To visit your group on the web, go to:
          >> http://groups.yahoo.com/group/jasspa/
          >>
          >> * To unsubscribe from this group, send an email to:
          >> jasspa-unsubscribe@yahoogroups.com
          >> <mailto:jasspa-unsubscribe@yahoogroups.com?subject=Unsubscribe>
          >>
          >> * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
          >> Service <http://docs.yahoo.com/info/terms/>.
          >>
          >>
          >>
          >>
          >
          >
          >
          >
          >__________________________________________________________________________
          >
          >This is an unmoderated list. JASSPA is not responsible for the content of
          >any material posted to this list.
          >
          >To unsubscribe, send a mail message to
          >
          > mailto:jasspa-unsubscribe@yahoogroups.com
          >
          >or visit http://groups.yahoo.com/group/jasspa and
          >modify your account settings manually.
          >
          >
          >
          >Yahoo! Groups Links
          >
          >
          >
          >
          >
          >
          >
          >
          >
          >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.