Loading ...
Sorry, an error occurred while loading the content.

Re: [jasspa] KeyBinding

Expand Messages
  • Steven Phillips
    This will not work because is the quote character in a string, i.e. consider binding the key C- global-bind-key void C- Is as bogus as it looks and will
    Message 1 of 3 , Sep 27, 2004
    • 0 Attachment
      This will not work because \ is the quote character in a string, i.e.
      consider binding the key C-"

      global-bind-key void "C-""

      Is as bogus as it looks and will also fail, to fix this you must protect the
      '"' (or quote) by using "C-\"", but this means that '\' chars must also be
      similarly protected, i.e. try the following:

      global-bind-key restyle-buffer "esc C-\\"

      Steve

      > Subject: [jasspa] KeyBinding
      > From: Salman Khilji <salmankhilji@...>
      > Date: Monday, September 27, 2004, 10:40:15 PM
      > To: jasspa@yahoogroups.com
      > Like XEmacs and GNU Emacs, I would like the
      > "restyle-buffer" command to be bound to "esc C-\".
      > However, putting the following command in
      > "C:\Documents and Settings\khilji\Application
      > Data\jasspa\khilji.emf" did not do the trick.

      > global-bind-key restyle-buffer "esc C-\"




      > _______________________________
      > Do you Yahoo!?
      > Declare Yourself - Register online to vote today!
      > http://vote.yahoo.com



      > __________________________________________________________________________

      > This is an unmoderated list. JASSPA is not responsible for the content of
      > any material posted to this list.

      > To unsubscribe, send a mail message to

      > mailto:jasspa-unsubscribe@yahoogroups.com

      > or visit http://groups.yahoo.com/group/jasspa and
      > modify your account settings manually.



      > Yahoo! Groups Links
    • Jon Green
      ... Simple mistake .. In macros the backslash is an escape character so you need two of them to get one i.e. backslash = backslashbackslash. Following does
      Message 2 of 3 , Sep 27, 2004
      • 0 Attachment
        Salman Khilji wrote:
        > Like XEmacs and GNU Emacs, I would like the
        > "restyle-buffer" command to be bound to "esc C-\".
        > However, putting the following command in
        > "C:\Documents and Settings\khilji\Application
        > Data\jasspa\khilji.emf" did not do the trick.
        >
        > global-bind-key restyle-buffer "esc C-\"

        Simple mistake ..

        In macros the backslash is an escape character
        so you need two of them to get one i.e.
        backslash = backslashbackslash. Following
        does what you want.

        global-bind-key restyle-buffer "esc C-\\"

        Just tried it and it is OK.

        Regards
        Jon.
      Your message has been successfully submitted and would be delivered to recipients shortly.