Loading ...
Sorry, an error occurred while loading the content.

Re: [jasspa] Disable WordWrap during compilations

Expand Messages
  • Jon Green
    ... You will have to edit tools.emf as follows:- cd /home/jon/.jasspa/ gdiff --context --minimal --ignore-space-change --recursive
    Message 1 of 3 , Sep 13, 2004
    • 0 Attachment
      Salman Khilji wrote:
      > When I do M-x compile, I notice that *compile* buffer
      > has WordWrap enabled. How do I disable this behavior?
      >
      >

      You will have to edit tools.emf as follows:-


      cd /home/jon/.jasspa/
      gdiff --context --minimal --ignore-space-change --recursive
      "/opt/jasspa/macros/tools.emf" "/home/jon/.jasspa/tools.emf"

      *** /opt/jasspa/macros/tools.emf 2004-08-24 20:20:54.479498000 +0100
      --- /home/jon/.jasspa/tools.emf 2004-09-13 20:37:30.034964000 +0100
      ***************
      *** 48,54 ****
      set-variable %compile-com @ml20 "compile" %compile-com
      !endif
      @# save-some-buffers @mna
      ! 0 ipipe-shell-command %compile-com "*compile*" @mna
      !emacro
      define-macro grep
      !force set-variable #l0 @1
      --- 48,54 ----
      set-variable %compile-com @ml20 "compile" %compile-com
      !endif
      @# save-some-buffers @mna
      ! 0x40 ipipe-shell-command %compile-com "*compile*" @mna
      !emacro
      define-macro grep
      !force set-variable #l0 @1
      [EXIT 1]

      Copy to your .jasspa directory and then edit.
      The downside is that you do not get an "EXIT"
      message.

      Jon.
    • Phillips, Steven
      The better solution is to create a myipipe.emf file in your .jasspa directory with the following: ***** /home/bill/.jasspa/myipipe.emf 0 define-macro
      Message 2 of 3 , Sep 14, 2004
      • 0 Attachment
        The better solution is to create a myipipe.emf file in your .jasspa directory with the following:

        ***** /home/bill/.jasspa/myipipe.emf

        0 define-macro my-fhook-ipipe
        !if &seq $buffer-bname "*compile*"
        -1 buffer-mode "wrap"
        !endif
        !emacro

        *****

        As this is an extension to the ipipe hook you will not miss any updates to the tools.emf (and you don't loose the EXIT line).

        Steve

        > -----Original Message-----
        > From: Jon Green [mailto:jon@...]
        > Sent: Monday, September 13, 2004 8:43 PM
        > To: jasspa@yahoogroups.com
        > Subject: Re: [jasspa] Disable WordWrap during compilations
        >
        >
        >
        > Salman Khilji wrote:
        > > When I do M-x compile, I notice that *compile* buffer
        > > has WordWrap enabled. How do I disable this behavior?
        > >
        > >
        >
        > You will have to edit tools.emf as follows:-
        >
        >
        > cd /home/jon/.jasspa/
        > gdiff --context --minimal --ignore-space-change --recursive
        > "/opt/jasspa/macros/tools.emf" "/home/jon/.jasspa/tools.emf"
        >
        > *** /opt/jasspa/macros/tools.emf 2004-08-24
        > 20:20:54.479498000 +0100
        > --- /home/jon/.jasspa/tools.emf 2004-09-13
        > 20:37:30.034964000 +0100
        > ***************
        > *** 48,54 ****
        > set-variable %compile-com @ml20 "compile" %compile-com
        > !endif
        > @# save-some-buffers @mna
        > ! 0 ipipe-shell-command %compile-com "*compile*" @mna
        > !emacro
        > define-macro grep
        > !force set-variable #l0 @1
        > --- 48,54 ----
        > set-variable %compile-com @ml20 "compile" %compile-com
        > !endif
        > @# save-some-buffers @mna
        > ! 0x40 ipipe-shell-command %compile-com "*compile*" @mna
        > !emacro
        > define-macro grep
        > !force set-variable #l0 @1
        > [EXIT 1]
        >
        > Copy to your .jasspa directory and then edit.
        > The downside is that you do not get an "EXIT"
        > message.
        >
        > Jon.
        >
        >
        >
        > ------------------------ Yahoo! Groups Sponsor
        > --------------------~-->
        > $9.95 domain names from Yahoo!. Register anything.
        > http://us.click.yahoo.com/J8kdrA/y20IAA/yQLSAA/89EolB/TM
        > --------------------------------------------------------------
        > ------~->
        >
        > ______________________________________________________________
        > ____________
        >
        > This is an unmoderated list. JASSPA is not responsible for
        > the content of
        > any material posted to this list.
        >
        > To unsubscribe, send a mail message to
        >
        > mailto:jasspa-unsubscribe@yahoogroups.com
        >
        > or visit http://groups.yahoo.com/group/jasspa and
        > modify your account settings manually.
        >
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
        >
        >
        >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.