Loading ...
Sorry, an error occurred while loading the content.

RE: [jasspa] Somehow "unknown user" effects

Expand Messages
  • Phillips, Steven
    Meino, For your user files to be in ~/me you must be using some customisation environment variable, in ME 2004 this could be one of $MEPATH, $MEUSERPATH or
    Message 1 of 4 , Jun 25, 2004
    • 0 Attachment
      Meino,

      For your user files to be in '~/me' you must be using some customisation environment variable, in ME 2004 this could be one of $MEPATH, $MEUSERPATH or possibly $MEINSTALLPATH, the setting of $MENAME can also cause this. The most likely cause of this problem is the setting of one or more of these env. variables, is it possible that the variable is set when you run an xterm but not when your IceWM is run? i.e. the window manager has not got this variable set so when it runs ME directly ME will not be configured properly?

      If so there are at least 3 solutions to this:

      Rather that running ME directly from IceWM, create a simple script that sets the missing env. var. first.

      Get the missing $ME..PATH variable set before IceWM is run.

      Remove the need for this variable to be set. In ME 2004 if no env. vars are set ME looks for its system setup files in any of the following directories:

      /opt/jasspa:/usr/share/jasspa:/usr/local/jasspa

      And looks for your user setup files in ~/.jasspa so you could try installing the macros into /opt/jasspa/macros, renaming ~/me to ~/.jasspa and remove any $ME.... env. variable.

      Steve

      > -----Original Message-----
      > From: Meino Christian Cramer [mailto:Meino.Cramer@...]
      > Sent: 25 June 2004 07:50
      > To: jasspa@yahoogroups.com
      > Subject: [jasspa] Somehow "unknown user" effects
      >
      >
      > Hi,
      >
      > I got a "problem with ME" -- and the "'s are for "I dont know, who is
      > guilty for that".
      >
      > I am using XFree 4.4.0 and IceWM 1.2.14 on Linux 2.6.7
      >
      > When starting xterm/rxvt from the menu of IceWM's taskbar and then
      > firing up ME from rxvt/xterm there is no problem: ME finds its user
      > related configuration files in $HOME/me/. and everything is
      > wonderful.
      >
      > BUT:
      > When starting ME directly from that menu it comes up in white on
      > black (instead my preferred "blue hue") and and there is a message in
      > the "command line" of ME saying "Failed to load file me" (the menu
      > bar at the top is also missing....).
      >
      > Other programs started from that menu "know" my $HOME and "who I am"
      > ;) (for example, when doing and "Open..." from a "File" menu entry of
      > such programms I have r/w access to my own $HOME directory at once --
      > I am not "beamed" elsewhere.
      >
      > I dont know, what is happening here...whether IceWM has a problem or
      > ME get confused or...
      >
      > Does anyone know a trick to avoid such problems?
      >
      > Thank you very much in advance for any help !
      >
      > Have a nice weekend!
      > Meino
      >
      >
      >
      >
      > ------------------------ Yahoo! Groups Sponsor
      > --------------------~-->
      > Yahoo! Domains - Claim yours for only $14.70
      > http://us.click.yahoo.com/Z1wmxD/DREIAA/yQLSAA/89EolB/TM
      > --------------------------------------------------------------
      > ------~->
      >
      > ______________________________________________________________
      > ____________
      >
      > This is an unmoderated list. JASSPA is not responsible for
      > the content of
      > any material posted to this list.
      >
      > To unsubscribe, send a mail message to
      >
      > mailto:jasspa-unsubscribe@yahoogroups.com
      >
      > or visit http://groups.yahoo.com/group/jasspa and
      > modify your account settings manually.
      >
      >
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      >
    • Jon Green
      ... Also .... If you are not allowed to write to the system directories then you can place the standard macros in ~/.jasspa/macros. Your private macros and
      Message 2 of 4 , Jun 25, 2004
      • 0 Attachment
        Phillips, Steven wrote:

        > Meino,
        >
        > For your user files to be in '~/me' you must be using some customisation environment variable, in ME 2004 this could be one of $MEPATH, $MEUSERPATH or possibly $MEINSTALLPATH, the setting of $MENAME can also cause this. The most likely cause of this problem is the setting of one or more of these env. variables, is it possible that the variable is set when you run an xterm but not when your IceWM is run? i.e. the window manager has not got this variable set so when it runs ME directly ME will not be configured properly?
        >
        > If so there are at least 3 solutions to this:
        >
        > Rather that running ME directly from IceWM, create a simple script that sets the missing env. var. first.
        >
        > Get the missing $ME..PATH variable set before IceWM is run.
        >
        > Remove the need for this variable to be set. In ME 2004 if no env. vars are set ME looks for its system setup files in any of the following directories:
        >
        > /opt/jasspa:/usr/share/jasspa:/usr/local/jasspa
        >
        > And looks for your user setup files in ~/.jasspa so you could try installing the macros into /opt/jasspa/macros, renaming ~/me to ~/.jasspa and remove any $ME.... env. variable.
        >
        > Steve
        >

        Also ....

        If you are not allowed to write to the system directories
        then you can place the standard macros in ~/.jasspa/macros.
        Your private macros and config would be placed in ~/.jasspa.
        The search order in the user local directory is:

        ~/.jasspa:~/.jasspa/company:~/.jasspa/spelling:~/.jasspa/macros

        The spelling dictionaries obviously live in ~/.jasspa/spelling.

        With a layout like this then you do not need to set any
        environment variables.

        Jon.
      • Meino Christian Cramer
        From: Phillips, Steven Subject: RE: [jasspa] Somehow unknown user effects Date: Fri, 25 Jun 2004 03:07:02 -0400 Hi, thank you very much
        Message 3 of 4 , Jun 25, 2004
        • 0 Attachment
          From: "Phillips, Steven" <sphillips@...>
          Subject: RE: [jasspa] Somehow "unknown user" effects
          Date: Fri, 25 Jun 2004 03:07:02 -0400

          Hi,

          thank you very much for these hints !

          I build a script ("mecall") which sets all needed env.-variables and
          now ME knows itsself again :)

          Great!

          Kind regards and have a nice weekend,
          Meino

          > Meino,
          >
          > For your user files to be in '~/me' you must be using some customisation environment variable, in ME 2004 this could be one of $MEPATH, $MEUSERPATH or possibly $MEINSTALLPATH, the setting of $MENAME can also cause this. The most likely cause of this problem is the setting of one or more of these env. variables, is it possible that the variable is set when you run an xterm but not when your IceWM is run? i.e. the window manager has not got this variable set so when it runs ME directly ME will not be configured properly?
          >
          > If so there are at least 3 solutions to this:
          >
          > Rather that running ME directly from IceWM, create a simple script that sets the missing env. var. first.
          >
          > Get the missing $ME..PATH variable set before IceWM is run.
          >
          > Remove the need for this variable to be set. In ME 2004 if no env. vars are set ME looks for its system setup files in any of the following directories:
          >
          > /opt/jasspa:/usr/share/jasspa:/usr/local/jasspa
          >
          > And looks for your user setup files in ~/.jasspa so you could try installing the macros into /opt/jasspa/macros, renaming ~/me to ~/.jasspa and remove any $ME.... env. variable.
          >
          > Steve

          > Also ....
          >
          > If you are not allowed to write to the system directories
          > then you can place the standard macros in ~/.jasspa/macros.
          > Your private macros and config would be placed in ~/.jasspa.
          > The search order in the user local directory is:
          >
          > ~/.jasspa:~/.jasspa/company:~/.jasspa/spelling:~/.jasspa/macros
          >
          > The spelling dictionaries obviously live in ~/.jasspa/spelling.
          >
          > With a layout like this then you do not need to set any
          > environment variables.
          >
          > Jon.


          > > -----Original Message-----
          > > From: Meino Christian Cramer [mailto:Meino.Cramer@...]
          > > Sent: 25 June 2004 07:50
          > > To: jasspa@yahoogroups.com
          > > Subject: [jasspa] Somehow "unknown user" effects
          > >
          > >
          > > Hi,
          > >
          > > I got a "problem with ME" -- and the "'s are for "I dont know, who is
          > > guilty for that".
          > >
          > > I am using XFree 4.4.0 and IceWM 1.2.14 on Linux 2.6.7
          > >
          > > When starting xterm/rxvt from the menu of IceWM's taskbar and then
          > > firing up ME from rxvt/xterm there is no problem: ME finds its user
          > > related configuration files in $HOME/me/. and everything is
          > > wonderful.
          > >
          > > BUT:
          > > When starting ME directly from that menu it comes up in white on
          > > black (instead my preferred "blue hue") and and there is a message in
          > > the "command line" of ME saying "Failed to load file me" (the menu
          > > bar at the top is also missing....).
          > >
          > > Other programs started from that menu "know" my $HOME and "who I am"
          > > ;) (for example, when doing and "Open..." from a "File" menu entry of
          > > such programms I have r/w access to my own $HOME directory at once --
          > > I am not "beamed" elsewhere.
          > >
          > > I dont know, what is happening here...whether IceWM has a problem or
          > > ME get confused or...
          > >
          > > Does anyone know a trick to avoid such problems?
          > >
          > > Thank you very much in advance for any help !
          > >
          > > Have a nice weekend!
          > > Meino
          > >
          > >
          > >
          > >
          > > ------------------------ Yahoo! Groups Sponsor
          > > --------------------~-->
          > > Yahoo! Domains - Claim yours for only $14.70
          > > http://us.click.yahoo.com/Z1wmxD/DREIAA/yQLSAA/89EolB/TM
          > > --------------------------------------------------------------
          > > ------~->
          > >
          > > ______________________________________________________________
          > > ____________
          > >
          > > This is an unmoderated list. JASSPA is not responsible for
          > > the content of
          > > any material posted to this list.
          > >
          > > To unsubscribe, send a mail message to
          > >
          > > mailto:jasspa-unsubscribe@yahoogroups.com
          > >
          > > or visit http://groups.yahoo.com/group/jasspa and
          > > modify your account settings manually.
          > >
          > >
          > >
          > > Yahoo! Groups Links
          > >
          > >
          > >
          > >
          > >
          > >
          >
          >
          >
          > __________________________________________________________________________
          >
          > This is an unmoderated list. JASSPA is not responsible for the content of
          > any material posted to this list.
          >
          > To unsubscribe, send a mail message to
          >
          > mailto:jasspa-unsubscribe@yahoogroups.com
          >
          > or visit http://groups.yahoo.com/group/jasspa and
          > modify your account settings manually.
          >
          >
          >
          > Yahoo! Groups Links
          >
          >
          >
          >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.