Loading ...
Sorry, an error occurred while loading the content.

ALT-ESC-ALTGR "madness"

Expand Messages
  • Meino Christian Cramer
    Hi, The user setup for my ME installation is set for ALT - Main Menu : N ALT - Esc : Y This way, I can go to the command line pressing ALT-x directly.
    Message 1 of 3 , Jun 23, 2004
    • 0 Attachment
      Hi,

      The user setup for my ME installation is set for

      ALT -> Main Menu : N
      ALT -> Esc : Y

      This way, I can go to the command line pressing ALT-x directly.

      Unfortunately on my keyboard layout (german) some essentials like
      "\{[]}¸~@|`µ" are reachable only via ALTGR - <key>.

      Now ME interprets ALTGR (right ALT) as CTL-C and I will be beamed
      directly into the command line with a CTRL-C prefix.

      To get (for example) a "\" I have to press ALTGR-\-\.

      What did I wrong in the configuration ?

      Is there a way to avoid the mechanism described above and remain the
      funtionality of ALT-x intact ?

      Kind regards,
      Meino
    • Sakari Tanhua
      Hi Meino, ... I recently upgraded from XFree86 4.3 to XOrg X11R6.7.0 and encountered this very same problem with finnish keyboard layout, which is pretty
      Message 2 of 3 , Jun 23, 2004
      • 0 Attachment
        Hi Meino,

        > Now ME interprets ALTGR (right ALT) as CTL-C and I will be beamed
        > directly into the command line with a CTRL-C prefix.

        I recently upgraded from XFree86 4.3 to XOrg X11R6.7.0 and encountered this
        very same problem with finnish keyboard layout, which is pretty similar to
        the german one. In 4.3 I had such settings that AltGr produced Mode_switch
        keysym, but in X11R6.7.0 it produces ISO_Level3_Shift, and this is what
        triggers the problem.

        I took a look at ME's sources, and in unixterm.c on line 1749 the
        Mode_switch is "handled", i.e. it's ignored. The problem was solved by
        adding a similar case statement for ISO_Level3_Shift:

        #ifdef XK_Mode_switch
        case XK_Mode_switch:
        case XK_ISO_Level3_Shift: /* this line added */

        And that's it. Now AltGr works like it's supposed to.

        Sakari
      • Meino Christian Cramer
        From: Sakari Tanhua Subject: Re: [jasspa] ALT-ESC-ALTGR madness Date: Wed, 23 Jun 2004 19:13:05 +0300 Hi Sakari, thank you very much for
        Message 3 of 3 , Jun 23, 2004
        • 0 Attachment
          From: Sakari Tanhua <stanhua@...>
          Subject: Re: [jasspa] ALT-ESC-ALTGR "madness"
          Date: Wed, 23 Jun 2004 19:13:05 +0300

          Hi Sakari,

          thank you very much for your very fast and help ful reply !!!

          I am using XFree 4.4.0

          I will patch me me sources and then.... TADA! :O)

          By the way: I first used MicroEmacs on my Atari 1989 (or so...?) ... it was
          the Daniel Lawrence (?) edition then...

          I am happy to have it on my Linux box again...but I am missing a
          language file set (syntax, indentation and highlightning) for the
          Ruby programming language (do you know Ruby?) ...

          Thank you very much for your help, Sakari! :O)

          Keep hacking!
          Meino



          > Hi Meino,
          >
          > > Now ME interprets ALTGR (right ALT) as CTL-C and I will be beamed
          > > directly into the command line with a CTRL-C prefix.
          >
          > I recently upgraded from XFree86 4.3 to XOrg X11R6.7.0 and encountered this
          > very same problem with finnish keyboard layout, which is pretty similar to
          > the german one. In 4.3 I had such settings that AltGr produced Mode_switch
          > keysym, but in X11R6.7.0 it produces ISO_Level3_Shift, and this is what
          > triggers the problem.
          >
          > I took a look at ME's sources, and in unixterm.c on line 1749 the
          > Mode_switch is "handled", i.e. it's ignored. The problem was solved by
          > adding a similar case statement for ISO_Level3_Shift:
          >
          > #ifdef XK_Mode_switch
          > case XK_Mode_switch:
          > case XK_ISO_Level3_Shift: /* this line added */
          >
          > And that's it. Now AltGr works like it's supposed to.
          >
          > Sakari
          >
          >
          >
          > __________________________________________________________________________
          >
          > This is an unmoderated list. JASSPA is not responsible for the content of
          > any material posted to this list.
          >
          > To unsubscribe, send a mail message to
          >
          > mailto:jasspa-unsubscribe@yahoogroups.com
          >
          > or visit http://groups.yahoo.com/group/jasspa and
          > modify your account settings manually.
          >
          >
          >
          > Yahoo! Groups Links
          >
          >
          >
          >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.