Loading ...
Sorry, an error occurred while loading the content.

HTML-Hilight inside tcl file

Expand Messages
  • Dr. Detlef Groth
    Hello, Hope everybody has a nice weekend. I am trying to get some HTML-hilighting inside a tcl-source file. Inside an if {0} block I added some html
    Message 1 of 2 , May 10, 2004
    • 0 Attachment
      Hello,

      Hope everybody has a nice weekend.

      I am trying to get some HTML-hilighting inside a tcl-source file.
      Inside an if {0} block I added some html documentation for documenting
      a package:

      to mytcl.emf I added:
      ; Force the hilighting mode to load if not already loaded.
      !if ¬ &exi .hilight.html
      !force execute-file "hkhtml"
      !endif
      ; If the hilighting mode is loaded then modify it.
      !if &and &sin "h" .fhook-html.setup &band .hilight.flags 0x02
      hilight .hilight.tcl 0x80 "^>html>" .hilight.html .scheme.hide
      hilight .hilight.html 0x80 "^>tcl>" .hilight.tcl .scheme.hide
      !endif

      However It does not work as expected. Only the line:
      >html>
      and the first tag
      <html> are hilighted. Any ideas ?

      regards,
      Detlef
    • Steven Phillips
      Detlef, Can you please send me an example and I will look at this. Also did you have any thoughts on the single template file approach? Steve
      Message 2 of 2 , May 10, 2004
      • 0 Attachment
        Detlef,

        Can you please send me an example and I will look at this. Also did you have
        any thoughts on the single template file approach?

        Steve

        > Subject: [jasspa] HTML-Hilight inside tcl file
        > From: Dr. Detlef Groth <dgroth@...>
        > Date: Monday, May 10, 2004, 9:20:24 AM
        > To: jasspa@yahoogroups.com
        > Hello,

        > Hope everybody has a nice weekend.

        > I am trying to get some HTML-hilighting inside a tcl-source file.
        > Inside an if {0} block I added some html documentation for documenting
        > a package:

        > to mytcl.emf I added:
        > ; Force the hilighting mode to load if not already loaded.
        > !if ¬ &exi .hilight.html
        > !force execute-file "hkhtml"
        > !endif
        > ; If the hilighting mode is loaded then modify it.
        > !if &and &sin "h" .fhook-html.setup &band .hilight.flags 0x02
        > hilight .hilight.tcl 0x80 "^>html>" .hilight.html .scheme.hide
        > hilight .hilight.html 0x80 "^>tcl>" .hilight.tcl .scheme.hide
        > !endif

        > However It does not work as expected. Only the line:
        >>html>
        > and the first tag
        > <html> are hilighted. Any ideas ?

        > regards,
        > Detlef





        > __________________________________________________________________________

        > This is an unmoderated list. JASSPA is not responsible for the content of
        > any material posted to this list.

        > To unsubscribe, send a mail message to

        > mailto:jasspa-unsubscribe@yahoogroups.com

        > or visit http://groups.yahoo.com/group/jasspa and
        > modify your account settings manually.



        > Yahoo! Groups Links
      Your message has been successfully submitted and would be delivered to recipients shortly.